inverse fitting problem: no link between data and estimation

A discussion forum for STANMOD users. STudio of ANalytical MODels is a software package for evaluating solute transport in porous media using analytical solutions of the convection-dispersion solute transport equation.


Post Reply
david0n
Posts: 1
Joined: Tue Nov 18, 2014 4:40 pm
Location: Germany

inverse fitting problem: no link between data and estimation

Post by david0n » Wed Nov 19, 2014 2:13 pm

Hallo dear STANMOD-friends,

I am having quite huge problems in fitting concentration curves to my experimental data breakthrough-curves. This will be a basics problem I still did not understand, so I am already sorry for asking stupid questions here, but I just don`t get it by studying all those examples and papers from the inventors Toride and van Genuchten, so could you please help me?

I obtained beautiful breakthrough curves from surfactant solutes passing sand columns, the CXTFIT 2.1W module also draws these data perfectly (red circles).
My goal is estimation of pore-velocity, Distribution factor and Retardation factor (v, D, R) with a non equilibrium CDE model.
No matter what I try in STANMOD, my estimated curves never link to the data, so the mathematical least-squares analysis is doing things I don`t understand at all.
To help you understand, I will describe my config step by step and attach the files as well.

CXTFIT-module:
1. inverse problem
2. deterministic equilibrium CDE (just because non equilibrium CDE ALWAYS leads to: "not enough data")
3. time and position are dimensional (because I want to estimate velocity, v)
4. units are mm for length, min for time and dimensionless concentration
5. concentration mode: resident concentration, third type inlet Cr (as found as suggestion of Toride) [I am pumping solute constantly with 0,5ml/min]
6. inverse parameter: used min and max, no mass estimation, max 150 iterations
7. v D R enabled for fitting with starting values and min/max values as expectable
- v: fitted (0,5; min:0,000001 max:10)
- D: fitted (10; min:0 max:100)
- R: fitted (1; min:0 max:1)
- Mu: 0 [I don’t have information about this]
9. BVP: pulse input at application time: input concentration: 1, application time: 70 [measuring starts with first pore volume of surfactant-solute pumped into the column, after time 70 relative concentration reached 1 and degradation is initialized by inserting purified water - is this BVP the right coice?]
10. IVP: zero initial concentration
11. PVP: zero production
12. inverse data structure: T,C,fixed depth BTC; 18 data points, position of the BTC 1 [what is meant by a position of BTC, the BTC starts at time 0 but no estimation possible with this value]
13. data in format of time in min and relative concentration
14. output structure: tried various values.. just don't understand, why i can generate so many output positions, no one fits to my data..

I always have the opinion, that CXTFIT is calculating its own BTC based on my information I give, but it doesn't fit the estimation to the data I inserted.
If you could please have a look on my file and give me some hint, I would be extremely graceful!
Thank you kindly for your attention already for reading this!!
Let me know, if I can give you more information.
Regards,

David
Attachments
stanmod_daVid.zip
cxtfit_data
(48.47 KiB) Downloaded 352 times

Post Reply