How to fix the Mass Balance Error

A discussion forum for users of the new HYDRUS 2D/3D. HYDRUS is a software package for simulating water, heat and solute movement in two- and three-dimensional variably saturated media. Happy Posting!
Post Reply
ari
Posts: 20
Joined: Thu Jul 28, 2016 4:16 pm
Location: USA

How to fix the Mass Balance Error

Post by ari » Thu Nov 30, 2017 7:08 pm

I am trying to simulate water flow, solute transport and root water uptake in a 10m by 11m domain with 4 layers. But I am getting a high mass balance error for the simulation. I have 15 time variable boundary conditions (for 15 years) and repeating it 10 times to run the simulation for a total of 150 years.
Precipitation is set at 0.5m/year for wet years along with evaporation (2.04 m/year) and transpiration (0.87m/year) along with incoming solute concentration of 500mg/m3.
The initial pressure head is -10m at the surface and 0 at the bottom. hCritA is set at -10m.
I am using Feddes water uptake reduction model with the following parameters:
PO=-0.1
POpt= -0.25m
P2H= -2m
P2L= -6m
P3=-9m
r2H= 1.825m/year
r2L= 0.365m/year
Maximum rooting depth is set at 9 meter and depth of maximum intensity is 7 meter.

The mass balance error is too high and I can use some help here. Is there any way you can take a look at the file and recommend some fixes? I will really appreciate your help and suggestion.

Since the size of the file is too large, I am providing a link to the file:

https://drive.google.com/file/d/13OLLRm ... sp=sharing


Sincerely,
A

Post Reply