Not running calculation when using Durner model with CW2D

A discussion forum for users of the new HYDRUS 2D/3D. HYDRUS is a software package for simulating water, heat and solute movement in two- and three-dimensional variably saturated media. Happy Posting!
Post Reply
Posts: 1
Joined: Wed Jul 05, 2017 9:24 am
Location: Belgium

Not running calculation when using Durner model with CW2D

Post by MaxPhal » Wed Jul 05, 2017 10:17 am

Dear Jirka/Board,

This post aims at asking for guidance about a problem I am encountering regarding the use of HYDRUS 2D-3D software. ​
In short, I am trying to perfom a forward modelling procedure with the hydraulic model of Durner coupled with the CW2D module.
Unfortunately, calculations never seem to run. The calculation window just pops up and vanishes a few milliseconds afterward.
Here are a list of the things I tried to investigate this problem.

1. Tried using Durner hydraulic with the Wetland_X examples.
2. Tried to reinstall the last version of HYDRUS 2.x - (Hydrus3D_2.05.0250.exe)
3. Installed Hydrus3D_2.05.0250.exe on another computer (that was not on the same server) and tried running with Durner/CW2D.

None of those worked.
Whenever I am trying to run HYDRUS 2D- CW2D with another hydraulic model (Mualem-VG, Kosugi, Brooks), calculations do run.
I am now running out of potential solutions and this is why I am asking for your help to debug my situation.

I'am looking forward to reading from you soon.

Best regards,


Posts: 4925
Joined: Sat Mar 16, 2002 3:47 pm
Location: USA
Location: Riverside, CA

Re: Not running calculation when using Durner model with CW2

Post by Jirka » Wed Jul 05, 2017 6:54 pm


There is a simple explanation for that. Only the Single-Porosity Models are available in the Wetland module.
Soil Hydraulic Models.png
Soil Hydraulic Models.png (59.27 KiB) Viewed 1542 times
None of the Dual-Porosity or Dual-Permeability models (or look-up tables) are available in the Wetland (or other specialized modules).

The notice that is printed to the screen and that you likely do not see because it disappears too quickly is:
write(*,*) 'This hydraulic property model is not implemented with the Wetland module!'

Guenter has tried to persuade me for a long time to implement the nonequilibrium (mobile-immobile) models into the Wetland module, but I have not done that and do not plan to do it in the immediate future (too complicated with the number of chemical components present, and with decisions where all these components should be present, which phase).

If you are interested only in the Durner's model, I could probably do that, since that results still in the equilibrium flow model (without those complications mentioned above). Let me know.


Post Reply