Switching from atm boundary to variable flow

A discussion forum for old Hydrus-2D & Meshgen. Happy Posting!
Download PDF document with all topics (February 8, 2008, 1.9MB):
http://www.pc-progress.com//Downloads/F ... on_H2D.pdf
Post Reply
mahardie
Posts: 41
Joined: Sun Nov 22, 2009 9:05 pm

Switching from atm boundary to variable flow

Post by mahardie » Thu Nov 28, 2013 5:23 am

I am working in 2D simulating an orchard, which is 4.5 meters wide and 1.5 meters deep. I wish to add irrigation to the central part of the domain for which I specify the variable rate flux and specify the rate at 2 cm hour for 1 hour. ....no problems so far. I also want to simulate rainfall and evaporation over the whole area including the area which recieved the variable rate flux. So the remaining nodes are set as atmospheric. What I need it to do is switch from being variable rate when im irrigating to normal rainfall / evaporation for the rest of the time. is this possible. can i switch the way the nodes behave. or is there some other way around the problem.
marcus

Jirka
Posts: 4759
Joined: Sat Mar 16, 2002 3:47 pm
Location: USA
Location: Riverside, CA

Re: Switching from atm boundary to variable flow

Post by Jirka » Thu Nov 28, 2013 3:07 pm

Marcus,

This has not been possible in earlier versions of HYDRUS (note that you posted your questions in forum for the ancient version of HYDRUS-2D, which was fully replaced with (HYDRUS (2D/3D)) in 2006).

In the current version 2, you can select many different special "Boundary Conditions Options" (the command is at the Edit Bar when Boundary conditions are displayed in the View). One of these options is "Treat the Time-Variable Flux BC as Atmospheric BC". You still need to specify the (atmospheric) flux in the column Var.Fl1 (during periods without irrigation; which is Evap-Prec (negative for inflow into and positive for outflow out of the domain)). The code will then treat this flux as atmospheric (i.e., with limiting pressure heads and switching from potential to actual fluxes).

Jirka

Post Reply