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HYDRUS (2D/3D) Introductory Example 
 

Infiltration Basin and Flow to a Nearby River 
 
By carrying out this example, you will create the following three dimensional domain, discretize 
it into finite elements, define initial and boundary conditions, specify all necessary soil hydraulic,  
solute transport, and other input parameters needed to simulate water flow and solute transport 
from an infiltration basin (water reservoir) at the top of the transport domain to a nearby river 
channel.  
 

 
 
The introductory example is divided into multiple sections dealing with specific topics, such as:  

I) defining geometry of the transport domain, 
II) discretizing it into finite elements, 
III) specifying all necessary soil hydraulic, solute transport, and other input parameters, 
IV) specifying initial and boundary conditions, carrying out calculations, and finally, 
V) analyzing calculated results. 

 
While, this example is meant to be an introductory tutorial, in which all major steps of defining 
and analyzing a project in HYDRUS are discussed, the emphasis is on features that are new in 
the Professional Level of HYDRUS, i.e., the General 3D Geometry. The first two parts of this 
introductory example are based on the video tutorial “Tutorial 5.02 – Reservoir”. 
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I. Infiltration Basin: Geometry 
 
I.1. Create a New Project.  
 
After starting the HYDRUS software, create a new project by using either a) a menu command 

File->New, b) a toolbar command New Project ( ), or c) the New command in the Project 
Manager. In the window that appears (i.e., New Project) enter the Name of the new project 
(e.g., Infiltration Basin) and its brief Description (e.g., Water flow from an infiltration basin to a 
nearby river). The Name of the project and its Description will be displayed in the Project 
Manager when it is next time opened. The name of the project must always be specified because 
this entry will be used as the name of the project file with the h3d2 extension (e.g., Infiltration 
Basin.h3d2). 
 
Notice that the New Project window provides information about where the Working Directory 
of a New Project is located, whether this Working Directory is Temporary (i.e., it exists only 
when a particular project is opened and is deleted when the project is closed) or Permanent (i.e., 
input and output (results) files are kept permanently in this directory even when the project is 
closed). By default the Working Directory is Temporary since majority of users will never 
need to access files in this directory directly. Finally, there is information about into which 
Project Group the new project belongs and where the project file (e.g., Infiltration Basin.h3d2) 
is located. The Project Group can be selected (or changed) using the Project Manager. 
 

 
 
Click Next to close the dialog box and to proceed to the next step. 
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I.2. Define Geometry Type, Units, and the Initial Workspace. 
 
In the Domain Type and Units window that appears select “3D – General” Type of Geometry, 
Length Units in “m”, and the Initial Workspace as follows: XMin = -5, XMax = 30, YMin = 0, 
YMax =10, ZMin = -5, and ZMax = 15 m. Maximum dimensions of the Initial Workspace 
define the extent of the space displayed in the View Window in the middle of the HYDRUS 
main window. Notice that when you click on different Types of Geometry radio buttons, a 
bitmap on the right will show possible types of geometries. 3D – General” Geometry is 
available only in the Professional Level of HYDRUS. 
  

 
 
Click OK or Next to close the dialog box and to proceed to the next step. Close the Main 
Processes window that automatically appears, since you will first define the project geometry. 
You will come back to the Main Processes and subsequent windows later in this tutorial. 
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I.3. Define the Grid and Work Plane Settings 
 
Although in this particular project there is no need to adjust the Grid and Work Plane settings, 
we will explore this topic nevertheless, since Grid and Work Planes are the two important tools 
intended to facilitate graphical input of complex objects in a three-dimensional space, 
understanding of which is crucial for successfully mastering the HYDRUS software (and 
especially its Professional Level).  
 
The Grid and Work Plane window is shown when selecting the menu command Tools->Grid 

and Work Plane or the Grid and Work Plane Settings command ( ) from the toolbar. 
 
A Work Plane is a working plane, in which users can specify various boundary objects, initial 
and boundary conditions, or other information. It facilitates to users to define these objects in a 
single plane, while keeping the third coordinate constant (or zero). A Work Plane can be 
defined to correspond, or be parallel, with basic coordinate planes, such as XZ, XY, or YZ (see 
the upper left corner). An Alignment Grid is a grid in a selected Work Plane that enables users 
to precisely define new objects, such as points, lines, etc. Users can define the Origin of the 
Coordinate System and a Grid. A Grid is defined by its Origin, the type (Grid Type) of 
coordinate system involved (either Cartesian or Polar), and the Grid Spacing. A Grid can also 
be rotated (can be inclined in any general direction) to facilitate work, for example when 
defining the domain for a hill slope problem. 
 

 
 
For entering data into the grid points, it is important that the Snap and Show checkboxes are 
checked so that the Grid becomes visible and the points will be snapped on the grid when 
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clicking. The status of these two checkboxes is displayed at the toolbar (  - Snap to Grid,  
- Show Grid; also menu commands “Tools->Snap to Grid” and “Tools->Show Grid”). Note that 
the Grid does not have to be displayed for the Snap option to be active. It is actually 
recommended (and set by default) that only a limited Number of Grid Points (50 in each 
direction from the Origin) is displayed. 
 
The Grid Origin coincides by default with the origin of the main coordinate axes. The Grid 
Origin can be redefined numerically by entering new X, Y, and Z coordinates in the upper right 
part of the Grid and Work Plane window or it can be selected graphically using a mouse after 

clicking on the Pick command or using the Set Grid Origin command ( ) at the toolbar (also 
the menu command “Tools->Define Work Plane->Set Origin”). 
 
The XY plane is set by default as the Work Plane. That means that all objects entered 
graphically will be generated in this plane. However, this plane has no significance for the input 
in dialog boxes.  
 
All default settings are suitable for the introductory example. To close the dialog box, click OK. 
 
 
Adjusting the Workspace graphically: 
 
There are multiple ways of adjusting the Workspace graphically. There are three major process 
modes that can be activated from the toolbar: 
 

 - Rotate View (“Shift”=Scroll, “Ctrl”=Zoom): Click this toolbar button and the mouse 
pointer turns into a hand. Now you can rotate the workspace according to your preferences by 
moving the pointer and holding the left mouse button down. 
 

 - Move View (“Shift”= Zoom, “Ctrl”=Rotate): Click this toolbar button and the mouse 
pointer turns into a hand. Now you can position (move) the workspace according to your 
preferences by moving the pointer and holding the left mouse button down.  
 

 - Zoom View (“Shift”= Scroll, “Ctrl”=Rotate): Click this toolbar button and the mouse 
pointer turns into a hand. Now you can zoom into and out of the workspace according to your 
preferences by moving the pointer up or down while holding the left mouse button down.  
 
The process mode changes when you simultaneously push the Shift or Ctrl keyboard buttons. 
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I.4. Define the Side Surface of the Domain 
 
Start first by creating the side surface of the domain in the XZ plane. To display this plane in the 

View Window of the desktop, select from the Toolbar “View Commands” ( ) menu the 
command “In Y-direction” (menu: “View->View in Direction->in Y-direction”) and then “Set 

XZ Work Plane” ( ; or menu: “Tools->Define Work Plane->Plane XZ”). From the Tools 

Sidebar select the “Line – Connected Abscissa” object ( ; or menu: 
“Insert->Domain Geometry->Curves->Line->Graphically”) and specify sequentially the 
following points with [x,z] coordinates: [0,0], [0,11], [14,11], [21,3], [24,3], [24,0], and [0,0] to 
get the following object: 
 

 
 
Press “Escape” or click the right mouse button to finish the process. Declare this object to be a 
“Surface” using the “Planar Surface via Boundaries” ( ) command 
from the Tools Sidebar (or menu: “Insert->Domain Geometry->Surfaces->Planar->Graphically”) 
and then click anywhere on the boundary. Press "Escape” or click the right mouse button to 
finish the process.  
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I.5. Extend the Side Surface into a 3D Domain 
 

Switch to the “Isometric View” ( ’ or menu: “View->View in Direction->Isometric”). Select 
the entire Surface in the View Window using a mouse (a selected object is indicated by yellow 
color) (make sure that not only the Surface, but also Points and Curves are selected), click on the 

“Translate” command ( ( ; or menu: “Tools->Translate”) on the Tools 
Sidebar, and in the “Translate” dialog that appears specify dY (Y-component of the Vector of 
Translation) equal to 27 m, Number of Copies equal to 1: 
 

 
 
This will create an exact copy of the existing selected Surface 27 m back in the direction of the 
Y axis. When you check the check box “Generate connecting objects between copies”, the 
“Manipulation Options” dialog appears, in which you can select what objects (lines, surfaces, 
or solid bodies) are to be created between the two (original one and its copy) surfaces. Unselect 
the check box “Create new solid bodies between the selected surfaces and their copies” so 
that only Lines and Surfaces are created between the two Surfaces. Click OK to close the 
window. 
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Click on the “Isometric View” ( ) command on the Toolbar to update the view (or menu: 
“View->View in Direction->Isometric”). By this time, you have created the following object: 
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I.6. Insert a Small Basin at the Top of the Domain. 
 
Subdivide the top-left line by inserting on it two points as follows. Click on the “Insert Points 

on Line” ( ) command on the Tools Sidebar (or menu: “Tools->Insert Points 

on Line->Graphically”), select the “Split Curve” radio button ( ) in the “Insert 
Mode” part of the Tools Sidebar, type “1” into “dL Point Distance” edit window on the Tools 

Sidebar ( ), and enter two points with a mouse on the top-left line with y 
coordinates equal to 10 and 17 m. 
 

Click on the “Rotate View” ( ) command at the Toolbar and rotate the entire solid so that its 
back side is facing you as follows: 

 
 
The two nodes dividing the top-left line are clearly visible. 
 
Set the Work Plane into the plane of the top of the domain as follows: Click on the “Set Grid 

Origin” ( ) command at the Toolbar and place it using a mouse into the node at the top-left 

line with the y coordinate of 10 m. Click on the “Set XY Work Plane” ( ) command at the 
Toolbar. 
 
From the Tools Sidebar select the “Line – Connected Abscissa” object 

( ) and insert lines defined by points with the following [x,y] 
coordinates: [0,7], [3,7], [3,0], and [0,0] to get: 
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Click on the “Set YZ Work Plane” ( ) command at the Toolbar, from the Tools Sidebar select 

again the “Line – Connected Abscissa” object ( ) and insert lines 
defined by points with the following [y,z] coordinates: [7,0], [6,-1], [1,-1], and [0,0] (note that 
these are coordinates in the local grid system with the origin of the coordinate system in the one 
node of the top-left line) to get: 
 

 

Click on the “Set Grid Origin” ( ) command at the Toolbar and place the grid origin using a 

mouse into the node indicated in the figure above. Click on the “Set XY Work Plane” ( ) 
command at the Toolbar, from the Tools Sidebar select again the “Line – Connected Abscissa” 

object ( ) and insert lines defined by points with the following [x,y] 
coordinates: [0,0], [2,0], [2,5], and [0,5]. Then connect the corned nodes in the back of the small 

basin using the command “Line – Abscissa” ( ), select with the mouse the 
unneeded line in front and click “Delete” at the keyboard to delete it, and to get the following: 
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 detail 
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I.7. Define Boundary Surfaces and the Solid 
 
Select the “Planar Surface via Boundaries” ( ) command from the 
Tools Sidebar (or menu: “Insert->Domain Geometry->Surfaces->Planar->Graphically”) and 
define multiple Surfaces by clicking on boundary lines of each surface. First the top surface, then 
the front surface, 

 
and then continue with four surfaces in the small basin. 

Click on the “Isometric View” ( ) command on the Toolbar to update the view. 
 

Click on the “Solid – Boundary Surfaces” ( ) command on the Tools 
Sidebar, and in the “New Solid” dialog that appears click on the “Pick” command to select 
Surfaces defining the Solid graphically. Alternatively, you can also type numerically the 
Boundary Surfaces. 
 

 
 
With the mouse select the entire object and click on the “Finish” command on the Tools Sidebar. 
The list of Boundary Surfaces defining the solid will be updated to “1,2,5-14”. 
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II. Infiltration Basin: FE-Mesh 
 
II.1. Discretize the Solid into Finite Elements 
 
Click on the “FE-Mesh” tab of the View Window (or menu “View->FE-Mesh”) and click on the 
“Generate FE-Mesh” ( ; or menu “Calculations->Generate FE-Mesh”) 
command to generate finite element mesh. Once the FE-Mesh is generated, its statistics is 
displayed. 
 

 
 
Switch to the “Solid Model” of the “Rendering Mode” from the Toolbar(or menu “Options-
>Rendering Mode->Solid Model”): 
 

 
 
to display the discretized object as follows: 



 14

 
 
Notice that this FE-Mesh was generated for default “FE-Mesh Parameters” (Tools Sidebar 
command ; or menu “Edit->FE-Mesh->FE-Mesh Parameters”), i.e., the 
Targeted FE Size is set automatically to 0.63 m and the Stretching Factor of the FE-Mesh is 
set to 1, i.e., the FE-Mesh is isotropic (there is no stretching of the FE-Mesh in any direction). 
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II.2. Alternative Spatial Discretizations (notes on spatial discretizations). 
 
While this relatively coarse FE mesh is sufficient for this application, initial and boundary 
conditions (to be specified) and the soil material (to be specified as loam), it may not be 
sufficient for other soil materials (with more nonlinear soil hydraulic properties, such as sand) or 
other boundary conditions (e.g., flux BCs). It may be necessary to generate a finer FE mesh, 
especially in the vicinity of the infiltration basin, or to use anisotropic FE-Mesh with finer 
discretization in the vertical than horizontal direction. HYDRUS (and its GENEX module for 
generating FE-Meshes for 3D- General geometries in the Professional Level of the software) 
offers several tools for this purpose. In this Section, several alternative FE meshes will be 
generated and discussed. 
 
a) Anisotropic FE-Mesh 
 
In many vadose zone applications vertical fluxes usually dominate over horizontal fluxes, and 
thus the spatial discretization should be much finer in the vertical direction than in the horizontal 
direction. HYDRUS can generate such FE meshes using the so called FE-Mesh Stretching. 
Stretching of the finite element mesh (i.e., the degree of mesh anisotropy in a certain direction) 
is defined using the Stretching Factor and the Stretching Direction. The finite elements are 
made larger in the particular Stretching Direction if the Stretching Factor is larger than one, 
and smaller if less that one. The result of this transformation is a mesh deformed in the given 
direction, which can be desirable for problems that, for example, require different spatial steps 
(mesh sizes) in the X, Y, and Z directions. If vertical fluxes are expected to be many times larger 
(e.g., 10-100 times) in the vertical direction than in the horizontal direction, the Stretching 
Factor can also be very large (e.g., 10-100). 
 
In Section II.1, you have generated FE mesh that was isotropic, i.e., it had sizes of finite 
elements the same in all direction. The Targeted FE-Mesh Size was equal to 0.63 m (i.e., the 
default size). Here, you will generate an alternative FE mesh that will have the same Targeted 
FE-Mesh Size (for horizontal directions), but will be twice as fine in the vertical direction. 
 
Click on the “FE-Mesh” tab of the View Window (or menu “View->FE-Mesh”) and click on the  

FE-Mesh Parameters command ( ; or menu “Calculations-> FE-Mesh 
Parameters”) on the Tools Sidebar. In the FE-Mesh Parameters dialog window that appears, 
leave the Automatic Targeted FE-Mesh Size equal to 0.63 m, switch to the Stretching Tab, 
and set the Stretching Factor Fs to 0.5 and the Stretching Direction to Z. 
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Then click on the “Generate FE-Mesh” ( ; or menu “Calculations->Generate 
FE-Mesh”) command on the Tools Sidebar to regenerate the finite element mesh. Once the FE-
Mesh is generated, its statistics is again displayed. 
 

  
 
As expected, we have approximately twice as many FE Nodes and 3D-Elements, than for the 
FE mesh generated in Section II.1. 
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b) Local FE-Mesh Refinement 
 
Rather then using an anisotropic FE mesh, one can also use local FE-Mesh Refinements. 
HYDRUS allows users to define FE-Mesh Refinements that can be assigned to Points, Lines, 
Surfaces, or Solids. In this particular problem, one may want to refine the FE mesh at the bottom 
of the reservoir where large pressure head and concentration gradients occur, especially at the 
beginning of the simulation. For this particular project, one could use any available FE-Mesh 
Refinement. One can assign a FE-Mesh Refinement to all four corner nodes, to boundary lines, 
as well as to the entire rectangle (Surface) defining the bottom of the reservoir. Here, we will 
use the first option, i.e., assigning a FE-Mesh Refinement to corner nodes. 
 

Click on the FE-Mesh Parameters command ( ; or menu “Calculations-> 
FE-Mesh Parameters”) on the Tools Sidebar. In the FE-Mesh Parameters dialog window that 
appears, leave the Automatic Targeted FE-Mesh Size equal to 0.63 m, switch to the Stretching 
Tab, and set the Stretching Factor Fs back to 1.0. Doing that, we get back the default 
conditions. 
 

Click on the Rotate View ( ) command on the toolbar and using a mouse rotate the object 
defining the transport domain until all four nodes defining the bottom of the reservoir are clearly 
visible. 
 

 
 

Click on the Insert Mesh Refinement ( ; or menu “Insert->FE-Mesh 
Refinement->Graphically”) command on the toolbar. In the New FE-Mesh Refinement dialog 
window from the options in the “Apply FE-Mesh Refinement to” section select ”Point – 
Circular” and leave the other parameters at their default options, i.e., Radius equal to 1.9 m, and 
Inner and  Outer Targeted FE-Sizes equal to 0.21 and 0.63 m, respectively.  
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Click OK to close the dialog window. Using a mouse pointer that turned into a square select all 
four corner nodes of the Surface representing the bottom of the reservoir. 
 

 
 
Circular symbols around the four nodes will indicate that the FE-Mesh Refinement was 
assigned to these four points. Then click on the “Generate FE-Mesh” ( ; or 
menu “Calculations->Generate FE-Mesh”) command on the Tools Sidebar to regenerate the 
finite element mesh. Once the FE-Mesh is generated, its statistics is again displayed. 
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Now, we have only slightly more nodes and elements than in the default FE mesh generated in 
Section II.1. In the Figure below notice the refined FE mesh around the four corner nodes at the 
bottom of the reservoir. 
 

 
 
This section demonstrated how alternative FE meshes can be generated. Since the calculations 
discussed below were carried out on a default FE mesh, the default conditions need to be 

established again. Click on Delete All Refinements command ( ) on the 
Tools Side Bar and then on the “Generate FE-Mesh” ( ; or menu 
“Calculations->Generate FE-Mesh”) command on the Tools Sidebar to regenerate the finite 
element mesh. 
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III. Infiltration Basin: Water Flow and Solute Transport Parameters 
 
Main Processes (Edit->Flow and Transport Parameters->Main Processes) 

Check Box: Water Flow  
Check Box: Solute Transport  
Button "Next" 

 
Time Information (Edit->Flow and Transport Parameters->Time Information) 

Time Units: days 
Final Time:   25 
Initial Time Step:   0.0001 
Minimum Time Step:  0.000001 
Maximum Time Step: 5 
Button "Next" 

 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Check T-Level Information 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 7 
Update 
Print Times: 0.2, 0.5, 1, 2.5, 5, 10, and 25 d 
Button "Next" 

 
Water Flow - Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Output Information) 

Leave default values as follows: 
Maximum Number of Iterations: 10 
Water Content Tolerance: 0.001 
Pressure Head Tolerance: 0.01 
Lower Optimal Iteration Range: 3 
Upper Optimal Iteration Range: 7 
Lower Time Step Multiplication Factor: 1.3  
Upper Time Step Multiplication Factor: 0.7 
Lower Limit of the Tension Interval: 1.e-06 
Upper Limit of the Tension Interval: 100 
Initial Condition: In the Pressure Head  
Button "Next" 

 
Water Flow - Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters ->Soil Hydraulic Model) 

Leave default values as follows: 
Radio button - van Genuchten-Mualem 
Radio button - No hysteresis 
Button "Next" 



 21

 
Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters ->Soil Hydraulic Parameters) 

Leave default values for loam 
Button "Next"  

 
Water Flow – Anisotropy Tensors (Edit->Flow and Transport Parameters->Water Flow 
Parameters ->Anisotropy Tensors) 

Leave default values for an isotropic material 
Button "Next"  

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Leave default values except set Pulse Duration to 1 d. 
Button "Next" 

 
Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Transport Parameters) 

Leave the default values 
Bulk Density = 1.5 cm3/g 
Disp.L = 0.2 m 
Disp.T = 0.02 m 
Diff.=0 
Button "Next" 

 
Solute Transport - Transport Parameters (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solute Reaction Parameters)  

Leave the default values for tracer 
Set cBnd in Boundary Conditions equal to 1 (this is a boundary concentration) 
Button "Next" 
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IV. Infiltration Basin: Initial and Boundary Conditions 
 
There are two approaches to assigning the initial and boundary conditions. One can do that either 
directly on the FE-Mesh, or one can do that on the so-called Geo Objects, i.e., geometrical 
objects, independent of the FE-Mesh, from which the properties are transferred to the FE-Mesh 
before the beginning of calculations. In general, working with Geo Objects is more convenient, 
as the properties are preserved even when the FE-Mesh is changed and need to be regenerated, in 
which case they would be lost if they were assigned to the FE-Mesh directly. In the following, 
both approaches will be demonstrated. 
 
IVa. Assigning Initial and Boundary Conditions on Geo Objects. 
 
IVa.1. Initial Conditions  
 

1. Switch to the Initial Conditions View (using either the Tab below the View Window or 

the Toolbar command View/Edit Initial Conditions ( ). 
2. You can either edit the default initial conditions by double clicking at the Tools Sidebar 

command "1 - Constant, h=-1" ( )  or create a new initial condition 
using a command New Initial Condition ( ). In the former case the 
Edit Pressure Head Initial Conditions window appears (below left), in the latter case 
the New Pressure Head Initial Conditions window appears (below right) 

  
Select “Equilibrium from the lowest located nodal point” and specify the “Bottom 
Pressure Head Value” equal to 4 m.  
HYDRUS will set the pressure head at the bottom of the domain equal to 4 m and then 
calculates the hydrostatic equilibrium (i.e., H=h+z=const, where H is the total head, h is 
the pressure head, and z is the gravitational head) for all other nodes. The pressure heat at 
the top of the domain will thus be equal to –7 m (= 4 – 11 m) since the domain has a 
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height of 11 m. 
In the latter case, the new Initial Condition will appear on the list of Initial Conditions: 

 
Click on the second IC and then on the transport domain (Solid) to assign this IC. 

 
IVa.2. Boundary Conditions  
 

1. Switch to the Boundary Conditions View (using either the tab below the View Window 

or the Toolbar command View/Edit Boundary Conditions ( ). 
2. Click on the Sections Tab of the Navigator Bar to display created Sections. Notice that 

HYDRUS created multiple Geo-Sections (representing the entire Domain, all Boundary 
Surfaces, and particular Surfaces). These Sections will greatly facilitate definitions of 
initial and boundary conditions, material distributions, and other spatially variable 
properties. 

 
3. Specify BC at the bottom of the Reservoir: Select Surface 12 (bottom of the infiltration 

basin) and click on the “Isometric View” ( ) on the Toolbar to adjust the view. Click on 

the New Boundary Condition command ( ) on the Tools Sidebar 
and in the New Water Flow Boundary Condition window select  Constant Head, type 
the Name of the boundary condition (e.g., Bottom of the Reservoir), and set the Pressure 
Head Value equal to 0.3 m (see the window below). 
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Now click on the newly created Boundary Condition ( ) and 
assign it to the bottom of the reservoir (by clicking on it). Its color should turn red. This 
means that there is a water layer 0.3 m deep at this boundary. Since the initial pressure 
head in these nodes was negative, water will infiltrate through this boundary into the 
transport domain. 

4. Specify BC at the bottom of the River: Select Surface 6 (bottom of the river) and click 

on the “Isometric View” ( ) on the Toolbar to adjust the view. Click on the New 

Boundary Condition command ( ) on the Tools Sidebar and in the 
New Water Flow Boundary Condition window select  Constant Head, type the Name 
of the boundary condition (e.g., Bottom of the River), and set the Pressure Head Value 
equal to 0.5 m. This means that there is a water layer 0.5 m deep at this boundary. Notice 
that this corresponds to the initial condition, and thus this boundary is initially in 
equilibrium with the initial state of the system. 

5. Switch to the Domain Properties View (using either the tab below the View Window or 

the Toolbar command View/Edit Domain Properties ( ). From the Data tab of the 
Navigator Bar select (double click on) Observations Nodes. Since we do not have any 
points defined in the transport domain other than those defining the geometry, we have to 
specify observation nodes on FE-Mesh, rather than on Geo-Objects.  

6. To do that, on the Tools bar click on Edit Properties on FE-mesh command 

( ). 
Click on the Sections Tab of the Navigator Bar. You will see there a list of Mesh-
Sections that will either include only "Whole FE-Mesh" or also additional Sections 
representing all boundary Surfaces, depending on the Setting of your HYDRUS. 
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If these additional Sections are not there, switch to the FE-Mesh View (using either the 

tab below the View Window or the Toolbar command View/Edit FE-Mesh ( ). On the 

Tools sidebar click on the Generate Section command ( ), check both 
checkboxes and click Generate. 

 
7. Select Surface 10 (the Mesh Section representing the back side of the transport domain 

under the infiltration basin), click on the “Isometric View” ( ) on the Toolbar to adjust 
the view, click on the Insert command ( ) on the Tools Sidebar, and 
using a mouse insert several observation nodes below the Infiltration Basin. 
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8. Select “Whole FE-Mesh” from the Sections Tab of the Navigator Bar, and click on the 

“Isometric View” ( ) on the Toolbar to adjust the view 
 

The Problem is now fully set up. 
 

Menu: File->Save (or from Toolbar ) 
 

Menu: Calculation->Run HYDRUS (or from Toolbar )  
(Execution time on 3 GHz PC – about 1200 s) 
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IVb. Assigning Initial and Boundary Conditions on FE Mesh. 
 
In the Domain Type and Units window, deselect the Edit Domain Properties, Initial and 
Boundary Conditions on Geometric Objects. When this checkbox is deselected, then 
properties are defined directly at the FE-Mesh (which obviously has to be generated first). 
 
IVb.1. Initial Conditions  
 

1. Click on the Sections Tab of the Navigator Bar. You will see there a list of Mesh-
Sections that will either include only "Whole FE-Mesh" or also additional Sections 
representing all boundary Surfaces, depending on the Setting of your HYDRUS. These 
Sections will greatly facilitate definitions of initial and boundary conditions, material 
distributions, and other spatially variable properties. 

 
If these additional Sections are not there, switch to the FE-Mesh View (using either the 

tab below the View Window or the Toolbar command View/Edit FE-Mesh ( ). On the 

Tools sidebar click on the Generate Section command ( ), check both 
checkboxes and click Generate. 

 
2. Switch to the Initial Conditions View (using either the Tab below the View Window or 

the Toolbar command View/Edit Initial Conditions ( ). 
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3. Using a mouse, select the entire transport domain. Click on the Set Pressure Head IC 

command ( ) on the Tools Sidebar and in the Water Flow Initial 
Conditions dialog select “Equilibrium from the lowest located nodal point” and specify 
the “Bottom Pressure Head Value” equal to 4 m.  

 
HYDRUS will set the pressure head at the bottom of the domain equal to 4 m and then 
calculates the hydrostatic equilibrium (i.e., H=h+z=const, where H is the total head, h is 
the pressure head, and z is the gravitational head) for all other nodes. The pressure heat at 
the top of the domain will thus be equal to –7 m (= 4 – 11 m) since the domain has a 
height of 11 m. 

 
IVb.2. Boundary Conditions  
 

1. Switch to the Boundary Conditions View (using either the tab below the View Window 

or the Toolbar command View/Edit Boundary Conditions ( ). 
2. Click on the Sections Tab of the Navigator Bar to display created Sections. 
3. Select Surfaces 5 and 6, click on the menu command View Command and select In Y-

Direction ( ), and click on Perspective View ( ) (to line up the 
domain). 

4. Click on the Constant Head command ( ) on the Tools Sidebar and select 
all nodes with a z coordinates smaller than 4 m (nodes displayed below in light blue 
color). 
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In the Constant Pressure Head BC dialog specify “Constant Pressure Head Value” of 1 
m and check the “Equilibrium from the lowest located nodal point” check box. This 
means that there is a water layer 1 m deep at this boundary. Notice that this corresponds 
to the initial condition, and thus this boundary is initially in equilibrium with the initial 
state of the system. 

 
From the Sections tab of the Navigator bar select "Whole FE-Mesh", and on the Toolbar 

click Isometric View ( ) and Perspective View ( ) to see again the entire Domain. 
 
5. From the Sections tab of the Navigator bar select Surface 12 (bottom of the infiltration 

basin) and click on the “Isometric View” ( ) on the Toolbar to adjust the view. Click on 
the Constant Head command ( ) on the Tools Sidebar, select all nodes of 
the Surface, and in the Constant Pressure Head BC dialog that will appear specify 
“Constant Pressure Head Value” of 0.3 m. This means that there is a water layer 0.3 m 
deep at this boundary. Since the initial pressure head in these nodes was negative, water 
will infiltrate through this boundary into the transport domain. 

 
 

6. Switch to the Domain Properties View (using either the tab below the View Window or 

the Toolbar command View/Edit Domain Properties ( ). From the Data tab of the 
Navigator Bar select (double click on) Observations Nodes. From the Sections Tab of 
the Navigator Bar Select Surface 10 (back side of the transport domain under the 

infiltration basin), click on the “Isometric View” ( ) on the Toolbar to adjust the view, 
click on the Insert command ( ) on the Tools Sidebar, and using a 
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mouse insert several observation nodes below the Infiltration Basin. 

 
 

7. Select “Whole FE-Mesh” from the Sections Tab of the Navigator Bar, and click on the 

“Isometric View” ( ) on the Toolbar to adjust the view 
 

The Problem is now fully set up. 
 

Menu: File->Save (or from Toolbar ) 
 

Menu: Calculation->Run HYDRUS (or from Toolbar )  
(Execution time on 3 GHz PC – about 1200 s) 
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V. Infiltration Basin: Results 
 
V.1. Results – Other Information  
 
Results – Other Information: Observation Points (from the Navigator Bar, or Results-
>Observation Points from menu). These graphs may be different depending on the precise 
position of the observations nodes.  
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Results – Other Information: Boundary Fluxes (from the Navigator Bar, or Results-
>Boundary Information->Boundary Fluxes from menu)  

Constant Boundary Flux (combined flux across all boundaries with constant head/flux 
BCs) 
 

Results – Other Information: Cumulative Fluxes (from the Navigator Bar, or Results-
>Boundary Information->Cumulative Fluxes from menu)  

Constant Boundary Flux 
 

Results – Other Information: Mass Balance Information (from the Navigator Bar, or Results-
>Mass Balance Information from menu)   
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V.2. Results – Graphical Display 
 
Results – Graphical Display: Pressure Heads (from the Navigator Bar, or Results->Display 
Quantity->Pressure Heads from menu)   

Use Listbox Time Layer or Slidebar on the Edit Bar to view results for different print 
times 
Check Flow Animation 
Select Boundary Line Chart from the Edit Bar and draw pressure heads for one vertical 
column 
Select Cross Section Chart and draw pressure heads through the middle of the column 
Select different display modes using Options->Graph Type 

 
  t = 5 d      t = 25 d 

 

 
 
Results – Graphical Display: Water Contents (from the Navigator Bar, or Results->Display 
Quantity->Water Contents from menu) 
 
Results – Graphical Display: Velocity Vectors (from the Navigator Bar, or Results->Display 
Quantity->Velocity Vectors from menu) 

 

 
 
Results – Graphical Display: Concentrations (from the Navigator Bar, or Results->Display 
Quantity->Concentration from menu) 
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  t = 5 d      t = 25 d 

 
 
 

 
 

 
Note that due to a relatively course discretization used (x=y=z=0.68 m), there are some 
minor oscillations in concentration values (small negative values). 
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V.3. Results – Sections (to view results inside of the transport domain). 
 
Various displays above were shown so far always on the entire transport domain (FE-Mesh). 
How can we display what is occurring inside of the domain? For that we can create additional 
Sections. Let’s create first a section that would cut through the middle of the reservoir and was 
perpendicular to the river and then a second one that would cut the domain horizontally at a 
depth of 7 m. 
 

From the View Commands menu ( ) at the toolbar select the “In X-direction” command (a 
menu command “View->View in Direction->in X-direction”). Now you view the transport 
domain directly from the back.  

From the Section Commands menu ( ) at the toolbar click on the “Cut with Rectangle” 

command ( ; or a menu command “Edit->Sections->Cut with Rectangle”). 
The pointer turns into an arrow with a scissor. Now using a mouse select exactly the left half of 
the transport domain (until the middle of the reservoir). The other half of the domain will be cut 

off. From the Section Commands menu ( ) at the toolbar click on the “Create New Section 

from Current View” command ( ; or a menu command 
“Edit->Sections->New Section from View”). Type “Left Half of the Transport Domain” (or any 
other text to identify this Section) into the “New FE-Mesh Section” window that appears. Click 
OK to close the view.  
 

 
 
Notice that the new Section is now displayed on the list with all other Sections created 
automatically by HYDRUS. Now you can rotate the newly created Section according to your 

preferences after clicking on the Rotate View ( ) command at the toolbar. 
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Concentrations at a cross-section in the middle of the transport domain at t = 25 d. 
 
Display again the entire transport domain by clicking at the “D0_000 – Whole FE-Mesh” 
Section in the list of Sections (Tab Sections of the Navigator Bar). From the View Commands 

menu ( ) at the toolbar select the “In Y-direction” command (a menu command “View-

>View in Direction->in Y-direction”). Make sure that the Perspective View ( ) is disabled. 
Now you view the transport domain directly from the front. From the Section Commands menu 

( ) at the toolbar click on the “Cut with Rectangle” command ( ; or a 
menu command “Edit->Sections->Cut with Rectangle”). The pointer turns into an arrow with a 
scissor. Now using a mouse select the part of the transport below the z coordinate of 7 m. The 

upper part of the domain will be cut off. From the Section Commands menu ( ) at the toolbar 
click on the “Create New Section from Current View” command 

( ; or a menu command “Edit->Sections->New Section from 
View”). Type “Horizontal cut at z=7 m” (or any other text to identify this Section) into the “New 
FE-Mesh Section” window that appears. Click OK to close the view.  
 
Note that most of these commands can also be found at the Tools Bar when the FE-Mesh View 
is selected. Now you can again rotate the newly created Section according to your preferences 
and display on it any variable (e.g., pressure heads, water contents, velocities, concentrations) as 
on the whole transport domain. 
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Pressure heads and concentrations at a cross-section at a depth of 7 m at t = 25 d. 
 
 


