TUTORIALS FOR THE HYDRUS WETLAND MODULE

These tutorials show the use of the HYDRUS Wetland Module (Langergraber and Šimůnek, 2006, 2011) for simulating vertical flow (VF) and horizontal flow (HF) wetlands. The following tutorials are provided in this section.


3) Water Flow and Reactive Transport in a Horizontal Flow Wetland (HYDRUS Wetland Module, CWM1 Biokinetic Model).
References:


Langergraber, G., and J. Šimůnek, The multi-component reactive transport module CW2D for constructed wetlands for the HYDRUS Software Package. *Hydrus Software Series 2*, Department of Environmental Sciences, University of California Riverside, Riverside, California, USA, 72p., 2006.


1 Water Flow in a Vertical Flow Wetland

This example shows the set-up of flow simulations in a VF wetland and the calibration of the flow model using measurements of the volumetric effluent flow rate. The example is based on the one provided in Langergraber and Šimůnek (2006).

The example consists of the five following steps:

1. Project set up, a 24-h long simulation with 4 loadings of 3-min duration.
2. Simulation is repeated (with the initial conditions obtained in the previous step) to reach pseudo steady-state conditions for water flow.
3. Calibration of soil hydraulic parameters against measured outflow data.
4. Simulation is re-run with the new (calibrated) soil hydraulic parameters.
5. Simulation is repeated (with the initial conditions obtained in the previous step and new soil hydraulic parameters) to reach pseudo steady-state conditions.

1.1 System Description

The VF wetland has a surface area of 1 m² (1x1 m²), a height of the main layer of the filter bed is 50 cm. The main layer consists of sand (gravel size 0.06-4 mm). An intermediate layer of 10 cm thickness with a gravel size of 4-8 mm prevents fine particles to be washed out into the drainage layer (15 cm thick; gravel 16-32 cm) where the effluent is collected by means of tile drains.

The sandy material used for the main layer has a porosity of 0.30 and the saturated hydraulic conductivity, $K_s$, of 117 cm/h. Table 1 shows the measured cumulated effluent flow for one loading interval of 6 hours and a single hydraulic loading of 10 L. The duration of a single loading is 3 minutes.

Table 1. Measured cumulated volumetric effluent flow

<table>
<thead>
<tr>
<th>Time [min]</th>
<th>20</th>
<th>40</th>
<th>60</th>
<th>80</th>
<th>100</th>
<th>120</th>
<th>140</th>
<th>160</th>
<th>180</th>
<th>200</th>
<th>240</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cum. effluent [L]</td>
<td>0.31</td>
<td>0.64</td>
<td>0.99</td>
<td>1.49</td>
<td>2.36</td>
<td>3.14</td>
<td>3.95</td>
<td>4.75</td>
<td>5.47</td>
<td>6.14</td>
<td>7.31</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time [min]</th>
<th>270</th>
<th>300</th>
<th>330</th>
<th>360</th>
</tr>
</thead>
</table>

Only the 50 cm main layer of the VF bed shall be considered in the simulation.
1.2 The HYDRUS Project Setup

Simulation 1 - Set-up:

- **Project Manager** (File → Project Manager)
  *Button* "New"

- **New Project** (or File → New Project)
  Name: Example 1a
  Description: VF wetland - flow simulation
  Working Directory: Temporary – is deleted after closing the project
  *Button* "Next"

- **Domain Type and Units** (Edit → Domain Geometry → Domain Type and Units)
  Type of Geometry: 2D - Simple
  2D-Domain Options: 2D - Vertical Plane XZ
  Units: cm
  Initial Workspace: Xmin=0 cm, Xmax=100 cm, Zmin=0 cm, Zmax=100 cm (to accommodate the transport domain)
  *Check* "Set View Stretching Factors Automatically"
  *Button* "Next"

- **Rectangular Domain Definition** (Edit → Domain Geometry → Simple Domain)
  Lx = 100 cm, Lz = 50 cm, α = 0°
  *Button* "Next"

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  Check Box: Water Flow
  *Button* "Next"

- **Time Information** (Edit → Flow and Transport Parameters → Time Information)
  Time Units: hours
  Final Time: 24
  Initial Time Step: 0.001
  Minimum Time Step: 0.0001
  Maximum Time Step: 1
  *Check* "Time-Variable Boundary Conditions"
  Number of Time-Variable Boundary Records: 8
  Number of times to repeat the same set of BC records: 1
  *Button* "Next"

- **Output Information** (Edit → Flow and Transport Parameters → Output Information)
  Print Options:
  - Check T-Level Information
  - Check Screen Output
  - Check Press Enter at the End
  Print Times: Count: 24
  Update
  Number of Subregions: 1
  *Button* "Next"

- **Water Flow - Iteration Criteria** (Edit → Flow and Transport Parameters → Water Flow Parameters → Iteration Criteria)
  Leave default values
  *Button* "Next"
• **Water Flow – Soil-Hydraulic Model** (Edit→Flow and Transport Parameters→Water Flow Parameters→Hydraulic Properties Model)

Radio button - van Genuchten-Mualem
Radio button - No hysteresis

*Button "Next"*

• **Water Flow - Soil-Hydraulic Params** (Edit→Flow and Transport Parameters→Water Flow Parameters→Soil Hydraulic Parameters)

Select "Sand" from Soil Catalog

Enter measured values for Qs = 0.30 and Ks = 117 cm/h

*Button "Next"*

• **Time-Variable Boundary Conditions** (Edit→Flow and Transport Parameters→Variably Boundary Conditions)

*Calculations:*

duration of a single loading: 3 minutes = 0.05 hours

amount of a single loading: 10 L/m² = 10 mm = 1 cm

actual loading rate: 1 cm / 0.05 h = 20 cm/h

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.05</td>
<td>20</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>6.05</td>
<td>20</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>12</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>12.05</td>
<td>20</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>18</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>18.05</td>
<td>20</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>24</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

*Remaining columns = 0*

*Button "Next"*

• **FE-Mesh - FE-Mesh Parameters** (Edit→FE-Mesh→FE-Mesh Parameters)

horizontal Discretization in X: Count = 11 *Button "Update"

horizontal Discretization in Z: Count = 21 *Button "Update"

Generate Z-Coordinates: RS2 = 4 *Button "Generate"

*Button "OK"*

• **Water Flow Initial Conditions:**

Click on the **Initial Conditions Tab** under the View Window.
Or on the Navigator Bar click on **Initial Conditions – Pressure Head** (or Insert→Initial Conditions→Pressure Head)

Select the entire transport domain and click on the **Set Pressure Head IC** command at the Edit Bar, check **Hydrostatic equilibrium from the lowest located nodal point,**

check that Bottom Pressure Head Value is set equal to -2 cm.

*Button "OK"*
• **Water Flow Boundary Conditions:**
  Click on the **Boundary Conditions Tab** under the View Window.
  Or on the Navigator Bar click on **Boundary Conditions – Water Flow** (or
  Insert ➔ Boundary Conditions ➔ Constant Head)
  a) Select *Atmospheric Boundary* from the Edit Bar, and select the top of the boundary.
  b) Select *Constant Head* from the Edit Bar, select the bottom boundary, and specify -2 cm.

• **Observation Nodes:**
  Click on the **Domain Properties Tab** under the View Window.
  Or on the Navigator Bar click on **Domain Properties – Observation Nodes** (or
  Insert ➔ Domain Properties ➔ Observation Nodes)
  Click the "Insert Observation Node" command on the Edit Bar and insert
  5 observation nodes in the middle of the domain and at depths of approximately 5, 10,
  20, 30, 40 and 50 cm.

• **Save**
  Save the project using the **Save** command on the Toolbar (or File ➔ Save).

• **Run Calculations**
  Click the **Calculate Current Project** command on the Toolbar (or menu command
  Calculation ➔ Calculate Current Project)

• **Results – Other Information: Observation Nodes** (from the Navigator Bar, or
  Results ➔ Observation Nodes)

• **Results – Other Information: Boundary Fluxes** (from the Navigator Bar, or
  Results ➔ Boundary Information ➔ Boundary Fluxes)
  Select "Constant Boundary Flux"
Note that we have obtained pseudo-steady-state behaviour for water flux after four loadings.

*Close*

- **Save Results**
  Save the project using the *Save* command on the Toolbar (or File ➔ Save).

---

**Simulation 2 - Pseudo Steady-State:**

- **Project Manager** (File ➔ Project Manager)
  Select "Example 1a"
  *Copy*
  Enter New Name: Example 1b
  Description: VF wetland - flow simulation - pseudo steady-state
  *OK*
  *Open* Example 1b

- **Update of Water Flow Initial Conditions with previous simulation results:**
  Insert ➔ Initial Conditions ➔ Import
  Select file "Example 1a.h3d2"
  *Open*

  Select "Pressure Head"
  Select "The Last (Final) Time Layer"
  *OK*

  This action requires deleting results. Do you want to continue?
  *Yes*

- **Save New Initial Conditions**
  Save the project using the *Save* command on the Toolbar (or File ➔ Save).

- **Re-Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation ➔ Calculate Current Project)

- **View results for "Constant Boundary Flux"**
Steady-state behaviour for water flux is OK

Button ”Close”

- **Comparison with measured data**

![Graph showing measured vs. simulated boundary flux](image)

- **Save Results**
  Save the project using the *Save* command on the Toolbar (or File→Save).
Simulation 3 - Inverse Simulation:

- **Project Manager** (File ➔ Project Manager)
  Select "Example 1b"
  
  Button "Copy"
  Enter New Name: Example 1c
  
  Description: VF wetland - flow simulation - inverse simulation
  
  Button "OK"
  
  Button "Open" Example 1c

- **Main Processes** (Edit ➔ Flow and Transport Parameters ➔ Main Processes)
  Check Box: Water Flow
  
  Check Box: Inverse Solution ?
  
  Button "Next"
  
  Delete results

- **Inverse Solution** (Edit ➔ Flow and Transport Parameters ➔ Inverse Solution)
  Check Box: Soil Hydraulic Parameters
  
  Other Parameters:
  Max Number of Iterations: 10
  Number of Data Points in the Objective Function: 15 (i.e. number of measured data, see Table 1)
  
  Button "OK"

- **Output Information** (Edit ➔ Flow and Transport Parameters ➔ Output Information)
  
  Print Options:
  Un-Check Screen Output
  
  Button "OK"

- **Water Flow – Soil-Hydraulic Params** (Edit ➔ Flow and Transport Parameters ➔ Water Flow Parameters ➔ Soil Hydraulic Parameters)
  
  Check parameters Qr, Alpha, n and l to be fitted
  
  Button "OK"

- **Inverse Solution Data** (Edit ➔ Flow and Transport Parameters ➔ Data for Inverse Solution)

  Assumption:
  4th loading will be used for comparing simulation results with measured data
  i.e. Inverse Solution Data table (Table 1):
  
  X-column: time + 18 hours,
  Y-column: + 300 cm² (1 single loading: 100 cm²)
  
  one single loading = 10 mm = 10 L/m² = 10 * 1000 cm³ / 100 cm = 100 cm²

  Inverse Solution Data table:

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
<th>Type</th>
<th>Position</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>18.33</td>
<td>303.1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>18.67</td>
<td>306.4</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>19.00</td>
<td>309.9</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>19.33</td>
<td>314.9</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>19.67</td>
<td>323.6</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>20.00</td>
<td>331.4</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>20.33</td>
<td>339.5</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>
Button "OK"

- **Save**
  Save the project using the Save command on the Toolbar (or File ➔ Save).

- **Run Calculations**
  Click the Calculate Current Project command on the Toolbar (or Calculation ➔ Calculate Current Project)

- **View results for "Cumulative Fluxes" - "Constant Boundary Flux"

![Cumulative Boundary Water Fluxes Graph](image)

Button "Close"

- **View parameters after inverse simulation at "Inverse Solution Results"

<table>
<thead>
<tr>
<th>Iteration</th>
<th>SSQ</th>
<th>WCR</th>
<th>ALPHA</th>
<th>N</th>
<th>L</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.6390E-01</td>
<td>0.4500E-01</td>
<td>0.1450E+00</td>
<td>0.2680E+01</td>
<td>0.5000E+00</td>
</tr>
<tr>
<td>1</td>
<td>0.2036E-01</td>
<td>0.4525E-01</td>
<td>0.1639E+00</td>
<td>0.2202E+01</td>
<td>0.6062E+00</td>
</tr>
<tr>
<td>2</td>
<td>0.2619E-02</td>
<td>0.3168E-01</td>
<td>0.1686E+00</td>
<td>0.2115E+01</td>
<td>0.6168E+00</td>
</tr>
<tr>
<td>3</td>
<td>0.2538E-02</td>
<td>0.3155E-01</td>
<td>0.1686E+00</td>
<td>0.2115E+01</td>
<td>0.6174E+00</td>
</tr>
</tbody>
</table>
Simulation 4 - Update Steady-State Water Flow Results 1:

- **Project Manager** (File → Project Manager)
  Select "Example 1b"
  *Button "Copy"

  Enter New Name: Example 1d
  Description: VF wetland - flow simulation - update steady-state flow
  *Button "OK"

  *Button "Open" Example 1d

- **Water Flow - Soil-Hydraulic Params** (Edit → Flow and Transport Parameters → Water Flow Parameters → Soil Hydraulic Parameters)
  Change parameters to estimated values, i.e. \(Q_r = 0.032, \ Alpha = 0.169, \ n = 2.11 \) and \(l = 0.617\)
  *Button "OK"

- **Save**
  Save the project using the *Save* command on the Toolbar (or File → Save).

- **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation → Calculate Current Project)

- **Results – Other Information: Boundary Fluxes** (from the Navigator Bar, or Results → Boundary Information → Boundary Fluxes)
  Select "Constant Boundary Flux" - notice that initially there was not steady state
  *Button "Close"

- **Save Results**
  Save the project using the *Save* command on the Toolbar (or File → Save).
Simulation 5 - Update Steady-State Water Flow Results 2:

- **Project Manager** (File→Project Manager)
  Select "Example 1d"
  *Button "Copy"
  Enter New Name: Example 1e
  Description: VF wetland - flow simulation - update steady-state flow
  *Button "OK"
  *Button "Open" Example 1e

- **Update of Water Flow Initial Conditions with simulation results:**
  Insert→Initial Cond→Import
  Select file "Example 1d.h3d2" in working directory
  *Button "Open"

  Select "Pressure Head"
  Select "The Last (Final) Time Layer"
  *Button "OK"

  This action requires deleting results. Do you want to continue?
  *Button "Yes"

- **Save New Initial Conditions**
  Save the project using the *Save* command on the Toolbar (or File→Save).

- **Re-Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation→Calculate Current Project)

- **Compare with measured data:**

![Graph showing measured and simulated boundary flux](image)
2 Reactive Transport in a Vertical Flow Wetland (CW2D Biokinetic Model)

This example demonstrate the set-up of a project with reactive transport in a vertical flow wetland (VF wetland) using the CW2D biokinetic model.

2.1 System Description

The VF wetland is the same as in Example 1. The calibrated flow model will be used to set-up a reactive transport simulation using the CW2D biokinetic model. Table 2 shows the CW2D influent concentrations.

Table 2. CW2D influent concentrations (as used in "Wetland 1", Langergraber and Šimůnek, 2006)

<table>
<thead>
<tr>
<th>Component Concentration</th>
<th>SO</th>
<th>CR</th>
<th>CS</th>
<th>CI</th>
<th>XH</th>
<th>XANs</th>
<th>XANb</th>
<th>NH4N</th>
<th>NO2N</th>
<th>NO3N</th>
<th>N2</th>
<th>PO4P</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>160</td>
<td>120</td>
<td>20</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>60</td>
<td>0.1</td>
<td>0.1</td>
<td>0</td>
<td>10</td>
</tr>
</tbody>
</table>

2.2 The HYDRUS Project Setup

Simulation 1 - Set-up:

- **Project Manager** (File → Project Manager)
  Select: Example 1e
  Button "Copy"
  Name: Example 2a
  Description: VF wetland - reactive transport simulation (CW2D)
  Button "OK"

- **Open project "Example 2a"**
  Select: Example 2a
  Button "Open"

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  Check Box: Water Flow
  Check Box: Solute Transport
  Check the Radio Button: Wetland (the CW2D module should be selected by default)
  Button "Next"
  Delete Results: "OK"

- **Time Information** (Edit → Flow and Transport Parameters → Time Information)
  Final Time: 48 (simulation over 2 days)
  Maximum Time Step: 1
  Number of times to repeat the same set of BC records: 2
  Button "OK"

- **Output Information** (Edit → Flow and Transport Parameters → Output Information)
  Print Options:
  Check T-Level Information
  Every n time step: 1
  Print Times:
  Button "Default"
  Button "OK"
• Solute Transport – General Info (Edit → Flow and Transport Parameters → Solute Transport Parameters → General Information)
  Set "Mass units" = µg
  Button "Next"

• Solute Transport – Transport Parameters (Edit → Flow and Transport Parameters → Solute Transport Parameters → Solute Transport Parameters)

Soil specific parameters
Set parameter "Fract." = 0 (mandatory for the Wetland module)

Solute specific parameters (in cm²/h):

<table>
<thead>
<tr>
<th>Sol</th>
<th>Diffus.W.</th>
<th>Diffus.G.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.072</td>
<td>769</td>
</tr>
<tr>
<td>2</td>
<td>0.0456</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>0.0456</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>0.0456</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>0.0801</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>0.0801</td>
<td>0</td>
</tr>
<tr>
<td>10</td>
<td>0.0801</td>
<td>0</td>
</tr>
<tr>
<td>11</td>
<td>0.0801</td>
<td>0</td>
</tr>
<tr>
<td>12</td>
<td>0.0801</td>
<td>0</td>
</tr>
<tr>
<td>13</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Button "OK"

• Solute Transport – Reaction Parameters (Edit → Flow and Transport Parameters → Solute Transport Parameters → Solute Reaction Parameters)
Leave default parameters and browse through all these windows
  Button "Next"

• Solute Transport – Constructed Wetland Model (CW2D) Parameters I
  (Edit → Flow and Transport Parameters → Solute Transport Parameters → Constructed Wetland Parameters I)
Explore and leave default parameters
  Button "Next"

• Solute Transport – Constructed Wetland Model (CW2D) Parameters II
  (Edit → Flow and Transport Parameters → Solute Transport Parameters → Constructed Wetland Parameters II)
Explore and leave default parameters
  Button "Next"

• Time-Variable Boundary Conditions (Edit → Flow and Transport Parameters → Variably Boundary Conditions)

add influent concentrations:
cVal1-1 = 1
cVal1-2 = 160
cVal1-3 = 120
cVal1-4 = 20  
cVal1-8 = 60  
cVal1-9 = 0.1  
cVal1-10 = 0.1  
cVal1-12 = 10  

Copy values to all lines

- **Solute Transport Initial Conditions:**
  Navigator Bar click on *Initial Conditions – L1 – Dissolved Oxygen*
  Select the entire transport domain and click on the *Set L1 - IC Dissolved Oxygen*
  command at the Edit Bar, check *Use top value for entire selected region*, check that
  Top value is set equal 1.
  *Button "OK"

  Repeat for L2, L3, L4, L8, L9, L10, L12, S5, S6, S7

  Note: it is assumed that a clean sand is used and that the filter has not been loaded
  previously. Steady-state conditions for reactive transport are reached once the biomass
  has reached constant concentrations, which can be expected after longer simulation
  time (e.g., 100 days).

- **Solute Transport Boundary Conditions:**
  Navigator Bar click on *Boundary Conditions – Solute Transport*
  Select *Third-type Boundary* from the Edit Bar, and select the top of the boundary.
  Pointer to the vector of the boundary Conditions = 1
  *Button "OK"

- **Domain Properties - Observation Nodes:**
  Insert Observation Nodes

![Image of HYDRUS 2D window showing observation nodes and other settings]
• **Save**
  Save the project using the *Save* command on the Toolbar (or File→Save).

• **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation→Calculate Current Project)

• **Results – Other Information: Observation Points** (from the Navigator Bar)
  Select "Observation Points ".

View results, 1st: check oxygen concentrations
Vertical Variable: select "L1 – Dissolved Oxygen"

![Image of dissolved oxygen concentrations over time]

Note that L1 (Dissolved Oxygen) concentrations at the upper Observation Nodes (Nos.1-4) show numerical oscillations. The reason is that, oxygen consumption is by far the fastest process among all the reactions considered.

Too avoid these numerical oscillations the maximum time step needs to be reduced.

**Advice:** L1 (Dissolved Oxygen) concentrations should always be checked prior to other concentrations to avoid numerical instabilities.
Simulation 2 - Set-up:

- **Project Manager** (File→Project Manager)
  Select: Example 2a
  Button "Copy"
  Name: Example 2b
  Description: VF wetland - reactive transport simulation (CW2D) – reduced dt
  Button "OK"

- **Open project "Example 2b"**
  Select: Example 2b
  Button "Open"

- **Time Information** (Edit→Flow and Transport Parameters→Time Information)
  Maximum Time Step: 0.02
  Button "OK"

- **Save**
  Save the project using the Save command on the Toolbar (or File→Save).

- **Run Calculations**
  Click the Calculate Current Project command on the Toolbar (or Calculation→Calculate Current Project)

- **Results – Other Information: Observation Points** (from the Navigator Bar)
  Select "Observation Points"

View results, 1st: check oxygen concentrations
Vertical Variable: select "L1 – Dissolved Oxygen"

![Observation Nodes: L1 - Dissolved Oxygen](image)

Note that L1 (Dissolved Oxygen) concentrations do not show numerical oscillations anymore → the maximum time step used is OK.
- **Check the other results:**
  e.g. Growth of heterotrophic bacteria

- e.g. Growth of ammonia oxidisers
  Vertical Variable: select "S6 – Autotr. Micro - NS"

*Button "Close"

- **Save Results**
  Save the project using the Save command on the Toolbar (or File ➔ Save).
3 Water Flow and Reactive Transport in a Horizontal Flow Wetland (CWM1 Biokinetic Model)

This example demonstrates the set-up of a water flow and reactive transport simulation in a horizontal flow (HF) wetland using the CWM1 biokinetic model.

The example consists of the following three steps:

1. Project set up, a 24-h long simulation to reach steady-state conditions for water flow.
2. Simulation of a tracer experiment.
   a. Set-up of tracer simulation
   b. Inverse simulation to match measured data
   c. Updated tracer simulation
3. Simulation of reactive transport (CWM1 biokinetic model).
4. Simulation of reactive transport (CWM1 biokinetic model) and effects of wetland plants.

3.1 System Description

The HF bed as described by Langergraber and Šimůnek (2012) is used in this example. The HF bed has a length of 10.3 m, a depth of 0.55 m and a width of 5.3 m. The water level in the bed is 0.5 m. The gravel of the main layer has $d_{60}$ of 10 mm and porosity of 41 %.

The first 0.3 m of the bed, the mixing zone, is filled with coarse gravel (porosity 45 %). The HYDRUS implementation considers the mixing zone (a red circle in Figure 1, that also shows a typical flow path in a HF bed).

In the HYDRUS implementation, the vertical domain of 10.3 m and 0.6 m was discretized into 33 columns and 23 rows, resulting in a two-dimensional finite element mesh consisting of 805 nodes and 1496 triangular finite elements. An atmospheric boundary condition was applied at the top of the mixing zone, whereas the effluent boundary was represented using a constant head boundary condition (0.5 m) at the bottom of the right end of the bed.

The HF bed was loaded with wastewater with a hydraulic loading rate of 36 mm.d$^{-1}$.

To characterize the hydraulic behavior, a tracer experiment with KCl was carried out. The tracer concentration was measured by measuring the electrical conductivity (EC) in the influent and effluent of the HF wetland. A KCl solution with EC of 30 mS.cm$^{-1}$ was added for a duration of 10 minutes and then the tracer breakthrough curve was measured at the effluent of the HF wetland. During the tracer experiment the background EC was 0.8 mS.cm$^{-1}$. Table 3 shows measured effluent EC during a period of 10 days.
Table 3. Effluent EC measurements (in mS.cm\(^{-1}\)) at the HF wetland effluent.

<table>
<thead>
<tr>
<th>Time [d]</th>
<th>EC effluent [mS.cm(^{-1})]</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.5</td>
<td>0.793</td>
</tr>
<tr>
<td>1</td>
<td>0.800</td>
</tr>
<tr>
<td>1.5</td>
<td>0.805</td>
</tr>
<tr>
<td>2</td>
<td>0.808</td>
</tr>
<tr>
<td>2.5</td>
<td>0.801</td>
</tr>
<tr>
<td>3</td>
<td>0.793</td>
</tr>
<tr>
<td>3.5</td>
<td>0.810</td>
</tr>
<tr>
<td>4</td>
<td>0.812</td>
</tr>
<tr>
<td>4.5</td>
<td>0.826</td>
</tr>
<tr>
<td>5</td>
<td>0.828</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time [d]</th>
<th>EC effluent [mS.cm(^{-1})]</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.5</td>
<td>0.847</td>
</tr>
<tr>
<td>6</td>
<td>0.865</td>
</tr>
<tr>
<td>6.5</td>
<td>0.861</td>
</tr>
<tr>
<td>7</td>
<td>0.862</td>
</tr>
<tr>
<td>7.5</td>
<td>0.843</td>
</tr>
<tr>
<td>8</td>
<td>0.826</td>
</tr>
<tr>
<td>8.5</td>
<td>0.815</td>
</tr>
<tr>
<td>9</td>
<td>0.807</td>
</tr>
<tr>
<td>9.5</td>
<td>0.813</td>
</tr>
<tr>
<td>10</td>
<td>0.799</td>
</tr>
</tbody>
</table>

The influent concentrations for the CWM1 components are given in Table 4. The CWM1 influent concentrations are the same as those used in CW2D (the tutorial 2 above), when the CW2D influent concentrations were calculated as follows: CR=SF+SA; CS=XS; and CI=SI+XI. In the CW2D simulations, phosphate PO\(_4\)P was considered in the inflow while sulphur was not.

Table 4. CWM1 influent concentrations (in mg.L\(^{-1}\)) in wastewater (taken from "scenario 5" of Llorens et al., 2011).

<table>
<thead>
<tr>
<th>CWM1 component Concentration</th>
<th>SO</th>
<th>SF</th>
<th>SA</th>
<th>SI</th>
<th>SNH</th>
<th>SNO</th>
<th>SSO(_4)</th>
<th>SH(_2)S</th>
<th>XS</th>
<th>XI</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0.86</td>
<td>170</td>
<td>27</td>
<td>13</td>
<td>57</td>
<td>0</td>
<td>33</td>
<td>0</td>
<td>33</td>
<td>13</td>
</tr>
</tbody>
</table>

For evaluating the influence of wetland plants on the removal of contaminants in HF beds, the following spatial distribution of root water uptake in the vertical domain was assumed. As reported by Headley et al. (2005), root biomass was only found in the upper half of the HF bed. The same assumption that the roots are dense in the upper 20 cm and then decrease rapidly with depth was made here. The transpiration rate of common reed (\textit{Phragmites australis}) is assumed to be 7.4 mm.d\(^{-1}\) and a specific oxygen release of 5 g.m\(^{-2}\).d\(^{-1}\). The selected value of the specific oxygen release is a rather conservative value.

References:


3.3 The HYDRUS Project Setup

Simulation 1 - Set-up:

- **Project Manager** (File→Project Manager)
  
  *Button “New”*

- **New Project** (or File→New Project)
  
  Name: Example 3a
  Description: HF wetland - flow simulation
  Working Directory: Temporary – is deleted after closing the project
  *Button “Next”*

- **Domain Type and Units** (Edit→Domain Geometry→Domain Type and Units)
  
  Type of Geometry: 2D - Simple
  2D-Domain Options: 2D - Vertical Plane XZ
  Units: m
  Initial Workspace: Xmin=0 m, Xmax=12 m, Zmin=0 m, Zmax=2 m
  *Check "Set View Stretching Factors Automatically"*
  *Button “Next”*

- **Rectangular Domain Definition** (Edit→Domain Geometry→Simple Domain)
  
  Lx = 10.3 m, Lz = 0.55 m, $\alpha = 0^\circ$
  *Button “Next”*

- **Main Processes** (Edit→Flow and Transport Parameters→Main Processes)
  
  Check Box: Water Flow
  *Button “Next”*

- **Time Information** (Edit→Flow and Transport Parameters→Time Information)
  
  Time Units: hours
  Final Time: 24
  Initial Time Step: 0.001
  Minimum Time Step: 0.0001
  Maximum Time Step: 1
  *Check "Time-Variable Boundary Conditions"
  Number of Time-Variable Boundary Records: 1
  Number of times to repeat the same set of BC records: 1
  *Button “Next”*

- **Output Information** (Edit→Flow and Transport Parameters→Output Information)
  
  Print Options:
  Check T-Level Information
  Check Screen Output
  Check Press Enter at the End
  Print Times: Count: 12
  Update
  Number of Subregions: 1
  *Button “Next”*

- **Water Flow - Iteration Criteria** (Edit→Flow and Transport Parameters→Water Flow Parameters→Iteration Criteria )
  
  Leave default values
  *Button “Next”*
  Radio button - van Genuchten-Mualem
  Radio button - No hysteresis
  Button ”Next”

- **Water Flow - Soil-Hydraulic Params** (Edit → Flow and Transport Parameters → Water Flow Parameters → Soil Hydraulic Parameters)
  Number of Materials: 2 Button "Update"

  Material 1 (gravel of main layer):
  Select "Sand" from Soil Catalog
  Enter values for Qs = 0.41; n = 4 and Ks = 10 m/h
  Name: Gravel (Main Layer)

  Material 2 (course gravel in mixing zone):
  Select "Sand" from Soil Catalogue
  Enter values for Qs = 0.45; n = 4 and Ks = 50 m/h
  Name: Gravel (Mixing Zone)
  Button ”Next”

- **Time-Variable Boundary Conditions** (Edit → Flow and Transport Parameters → Variably Boundary Conditions)

  **Calculations:**
  hydraulic loading rate = 36 mm.d⁻¹ = 1.5 mm.h⁻¹ = 1.5 L.m⁻².h⁻¹
  surface area of whole HF bed: 10.3 m x 5.3 m = 54.6 m²
  hydraulic loading (whole bed) = 1.5 L.m⁻².h⁻¹ x 54.6 m² = 81.9 L.h⁻¹ = 0.0819 m³.h⁻¹

  surface area of mixing zone = 0.3 m x 5.3 m = 1.6 m²
  hydraulic loading rate (mixing zone) = 0.082 m³.h⁻¹ / 1.6 m² = 0.051 m.h⁻¹

  Time-Variable Boundary Conditions:
<table>
<thead>
<tr>
<th>Time</th>
<th>Precip.</th>
<th>Evap.</th>
<th>Transp.</th>
<th>hCritA</th>
</tr>
</thead>
<tbody>
<tr>
<td>[hours]</td>
<td>[m/h]</td>
<td>[m/h]</td>
<td>[m/h]</td>
<td>[m]</td>
</tr>
<tr>
<td>1</td>
<td>24</td>
<td>0.051</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

  Button ”Next”
- **FE-Mesh - FE-Mesh Parameters** (Edit ➤ FE-Mesh ➤ FE-Mesh Parameters)
  horizontal Discretization in X: Count = 25 Button "Update"
  vertical Discretization in Z: Count = 23 Button "Update"

Horizontal Discretization in X:

<table>
<thead>
<tr>
<th>x [m]</th>
<th>dz [m]</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>0.1</td>
</tr>
<tr>
<td>3</td>
<td>0.2</td>
</tr>
<tr>
<td>4</td>
<td>0.3</td>
</tr>
<tr>
<td>5</td>
<td>0.4</td>
</tr>
<tr>
<td>6</td>
<td>0.5</td>
</tr>
<tr>
<td>7</td>
<td>0.7</td>
</tr>
<tr>
<td>8</td>
<td>0.9</td>
</tr>
<tr>
<td>9</td>
<td>1.1</td>
</tr>
<tr>
<td>10</td>
<td>1.4</td>
</tr>
<tr>
<td>11</td>
<td>1.7</td>
</tr>
<tr>
<td>12</td>
<td>2</td>
</tr>
<tr>
<td>13</td>
<td>2.4</td>
</tr>
</tbody>
</table>

Button "OK"

- **Set stretching factor** (View ➤ View stretching)
  Stretching factor in X-Direction = 1
  Stretching factor in Z-Direction = 4
  Button "OK"

- **Water Flow Initial Conditions:**
  Click on the Initial Conditions Tab under the View Window.
  Or on the Navigator Bar click on Initial Conditions ➤ Pressure Head (or Insert ➤ Initial Conditions ➤ Pressure Head)
  Select the entire transport domain and click on the Set Pressure Head IC command at the Edit Bar, check Equilibrium from the lowest located nodal point, check that Bottom Pressure Head Value is set equal to 0.5 m (water level in the bed = 50 cm).
  Button "OK"

- **Water Flow Boundary Conditions:**
  Click on the Boundary Conditions Tab under the View Window.
  Or on the Navigator Bar click on Boundary Conditions ➤ Water Flow (or Insert ➤ Boundary Conditions ➤ Constant Head)
  a) Zoom on the upper left part of the transport domain. Select Atmospheric Boundary from the Edit Bar, and select 4 nodes in the upper left corner of the domain (top of the mixing zone).
b) Zoom on the lower right part of the transport domain. Select *Constant Head* from the Edit Bar, select 1 node at the lower right boundary (outlet of the HF bed)

Specify Constant Pressure Head Value: 0.475 m
- **Material Distribution:**
  Click on the **Domain Properties Tab** under the View Window.
  Or on the Navigator Bar click on Domain Properties – Material Distribution (or Insert  Domain Properties  Material Distribution)
  Zoom on the left part of the transport domain.
  Click the "Gravel (Mixing Zone)" and select the first 3 columns on left side to assign the mixing zone.

- **Observation Nodes:**
  Click on the **Domain Properties Tab** under the View Window.
  Or on the Navigator Bar click on Domain Properties – Observation Nodes (or Insert  Domain Properties  Observation Nodes)
  Click the "Insert Observation Node" command on the Edit Bar and insert 6 observation nodes along the flow path.
  1 observation node should be located at the effluent node.
- **Save**
  Save the project using the *Save* command on the Toolbar (or File ➔ Save).

- **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or menu command Calculation ➔ Calculate Current Project)

- **Results – Graphical Display: Pressure Head** (from the Navigator Bar, or Results ➔ Display Quantity ➔ Pressure Head)
  View results at end of simulation time, i.e. 24 hours
• View also results for velocity vectors.

• **Save Results**
  Save the project using the **Save** command on the Toolbar (or File ➔ Save).

• **Update of Water Flow Initial Conditions with simulation results from before:**
  Insert ➔ Initial Conditions ➔ Import
  Select file "Example 3a.h3d2" in the project directory
  **Button “Open”**

  Select "Pressure Head"
  Select "The Last (Final) Time Layer"
  **Button “OK”**

  Warning: This action requires deleting results. Do you want to continue?
  **Button “Yes”**

• **Save**
  Save the project using the **Save** command on the Toolbar (or File ➔ Save).

• **Run Calculations**
  Click the **Calculate Current Project** command on the Toolbar (or menu command Calculation ➔ Calculate Current Project)

• **Save Results**
  Save the project using the **Save** command on the Toolbar (or File ➔ Save).
Simulation 2a – Set-up Tracer Simulation

- **Project Manager** (File → Project Manager)
  Select "Example 3a"
  Button "Copy"
  Enter New Name: Example 3b1
  Description: HF wetland – tracer simulation
  Button "OK"
  Button "Open" Example 3b1

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  Check Box: Water Flow
  Check Box: Solute Transport
  Check Radio Button "Standard Solute Transport"
  Button "Next"

- **Time Information** (Edit → Flow and Transport Parameters → Time Information)
  Time Units: Check Radio Button "Days"
  Final Time: 10
  Boundary Conditions: Number of Time-Variably Boundary Conditions: 2
  Button "Next"

- **Output Information** (Edit → Flow and Transport Parameters → Output Information)
  Print Times:
  Count: 40 (output every 6 hours = 0.25 days)
  Button "Update"
  Button "Default"
  Button "OK"

- **Solute Transport – General Info** (Edit → Flow and Transport Parameters → Solute Transport Parameters → General Information…)
  Set "Mass units" = g
  Button "Next"

- **Solute Transport – Transport Parameters** (Edit → Flow and Transport Parameters → Solute Transport Parameters → Solute Transport Parameters…)
  Leave default values.
  Button "OK"

- **Time-Variably Boundary Conditions** (Edit → Flow and Transport Parameters → Variably Boundary Conditions)

<table>
<thead>
<tr>
<th>Time</th>
<th>Precip.</th>
<th>Evap.</th>
<th>...</th>
<th>cValue 1</th>
<th>cValue 2</th>
<th>cValue 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>[days]</td>
<td>[m/day]</td>
<td>[m/day]</td>
<td></td>
<td>g/L^3</td>
<td>g/L^3</td>
<td>g/L^3</td>
</tr>
<tr>
<td>0.00694</td>
<td>1.224</td>
<td>0</td>
<td>...</td>
<td>30</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>10</td>
<td>1.2246</td>
<td>0</td>
<td></td>
<td>0.8</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

KCl solution with EC 30 mS/cm\(^{-1}\) is added for 10 min (= 0.00694 days), afterward influent concentration is background EC of 0.8 mS/cm\(^{-1}\).

Button "OK"
• **Solute Transport Initial Conditions:**
  Navigator Bar click on *Initial Conditions – Concentration*
  Select the entire transport domain and click on the *Set Concentration IC* command at
  the Edit Bar, check *Use top value for entire selected region*, check that Top value is
  set equal 0.8.
  *Button “OK”*

• **Solute Transport Boundary Conditions:**
  Select *Third-type Boundary* from the Edit Bar, and nodes from mixing zone selected
  as Atmospheric BC.
  Pointer to the vector of the boundary Conditions = 1 (note that this was already the
  default value).
  *Button “OK”*

• **Save**
  Save the project using the *Save* command on the Toolbar (or File ➔ Save).

• **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or
  Calculation ➔ Calculate Current Project)

• **Results – Other Information – Observation points – Concentration**

![Observation Nodes](image_url)
Comparison with measured data:

![Graph showing Electrical Conductivity over Time](image)

**Simulation 2b – Inverse Tracer Simulation**

- **Project Manager** (File → Project Manager)
  Select "Example 3b1"
  *Button* "Copy"
  Enter New Name: Example 3b2
  Description: HF wetland – tracer simulation (inverse)
  *Button* "OK"
  *Button* "Open" Example 3b2

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  Check Box: Water Flow
  Check Box: Inverse Solution?
  *Button* "Next"
  Delete results

- **Inverse Solution** (Edit → Flow and Transport Parameters → Inverse Solution)
  Estimate …:
  Check Box: Solute Transport Parameters
  Concentration Type:
  Check Box: Resident concentration
  Other Parameters:
  Max Number of Iterations: 10
  Number of Data Points in the Objective Function: 20 (i.e. number of measured data, see Table 3)
  *Button* "OK"

- **Output Information** (Edit → Flow and Transport Parameters → Output Information)
  Print Options:
  Un-Check Screen Output
  *Button* "OK"
• **Solute Transport – Reaction Parameters** (Edit ➔ Flow and Transport Parameters ➔ Solute Transport Parameters ➔ Solute Transport Parameters)
  Check parameters Disp.L. to be fitted for Material 1 (Main layer)
  *Button “OK”*

• **Inverse Solution Data** (Edit ➔ Flow and Transport Parameters ➔ Data for Inverse Solution)

Inverse Solution Data table:

<table>
<thead>
<tr>
<th>Position</th>
<th>X</th>
<th>Y</th>
<th>Type</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.5</td>
<td>0.793</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>0.800</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>1.5</td>
<td>0.805</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>0.808</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>2.5</td>
<td>0.801</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td>0.793</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>3.5</td>
<td>0.810</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>4</td>
<td>0.812</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>4.5</td>
<td>0.826</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>5</td>
<td>0.828</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>5.5</td>
<td>0.847</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>12</td>
<td>6</td>
<td>0.865</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>13</td>
<td>6.5</td>
<td>0.861</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>14</td>
<td>7</td>
<td>0.862</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>15</td>
<td>7.5</td>
<td>0.843</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>16</td>
<td>8</td>
<td>0.826</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>17</td>
<td>8.5</td>
<td>0.815</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>18</td>
<td>9</td>
<td>0.807</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>19</td>
<td>9.5</td>
<td>0.813</td>
<td>4</td>
<td>1</td>
</tr>
<tr>
<td>20</td>
<td>10</td>
<td>0.799</td>
<td>4</td>
<td>1</td>
</tr>
</tbody>
</table>

*Position = Observation node number*

Use Observation node number at the outlet of the HF wetland

*Button “OK”*

• **Save**
  Save the project using the *Save* command on the Toolbar (or File ➔ Save).

• **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation ➔ Calculate Current Project)
• **Results – Other Information – Observation points – Concentration**

![Observation Nodes](image)

*Button* "Close"

• **View parameters after inverse simulation at "Inverse Solution Results"**

<table>
<thead>
<tr>
<th>Iteration</th>
<th>SSQ</th>
<th>DISPL</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.2382D+00</td>
<td>0.5000E+00</td>
</tr>
<tr>
<td>1</td>
<td>0.8620D-01</td>
<td>0.2765E+00</td>
</tr>
<tr>
<td>2</td>
<td>0.5771D-01</td>
<td>0.1789E+00</td>
</tr>
<tr>
<td>3</td>
<td>0.5659D-01</td>
<td>0.1912E+00</td>
</tr>
<tr>
<td>4</td>
<td><strong>0.5658D-01</strong></td>
<td><strong>0.1917E+00</strong></td>
</tr>
</tbody>
</table>
Simulation 2c – Updated Tracer Simulation

- **Project Manager** (File→Project Manager)
  Select "Example 3b1"
  
  *Button “Copy”*
  *Enter New Name: Example 3b3*
  *Description: HF wetland – tracer simulation (updated)*
  
  *Button “OK”*
  *Button “Open” Example 3b3*

- **Solute Transport – Transport Parameters** (Edit→Flow and Transport Parameters→Solute Transport Parameters→Solute Transport Parameters…)
  *Material 1: Disp.L. = 0.192 m*
  
  *Button “OK”*

- **Save**
  Save the project using the *Save* command on the Toolbar (or File→Save).

- **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation→Calculate Current Project)

- **Results**
  Comparison with measured data:

![Graph showing comparison between measured and simulated electrical conductivity over time](image-url)
Simulation 3 – Set-up Reactive Transport Simulations

- **Project Manager** (File → Project Manager)
  Select "Example 3a"
  
  Button "Copy"

  Enter New Name: Example 3c

  Description: HF wetland – reactive transport simulation (CWM1)
  
  Button "OK"

  Button "Open" Example 3c

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  Check Box: Water Flow

  Check Box: Solute Transport

  Check Radio Buttons "Wetland module" and "CWM1"
  
  Button "Next"

- **Time Information** (Edit → Flow and Transport Parameters → Time Information)
  Final Time: 48 (simulation over 2 days)

  Maximum Time Step: 0.01 (has to be reduced due to fast oxygen consumption)
  
  Button "Next"

- **Output Information** (Edit → Flow and Transport Parameters → Output Information)
  Print Options:

  Check T-Level information; Every n time step: 10

  Print Times:

  Count: 24
  
  Button "Update"

  Button "Default"

  Button "OK"

- **Solute Transport – General Info** (Edit → Flow and Transport Parameters → Solute Transport Parameters → General Information)
  Set "Mass units" = g
  
  Button "Next"

- **Solute Transport – Transport Parameters** (Edit → Flow and Transport Parameters → Solute Transport Parameters → Solute Transport Parameters)

  Soil specific parameters

  Set parameter "Fract." = 0 for both materials
Solute specific parameters (in m²/h):

<table>
<thead>
<tr>
<th>Sol</th>
<th>Diffus.W.</th>
<th>Diffus.G.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>7.21e-6</td>
<td>0.0769</td>
</tr>
<tr>
<td>2</td>
<td>4.56e-6</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>4.56e-6</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>4.56e-6</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>8.01e-6</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>8.01e-6</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>8.01e-6</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>8.01e-6</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>4.56e-6</td>
<td>0</td>
</tr>
<tr>
<td>10</td>
<td>4.56e-6</td>
<td>0</td>
</tr>
<tr>
<td>11</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>12</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>14</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>15</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>16</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>17</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Button ”Next”

- **Solute Transport – Reaction Parameters** (Edit→Flow and Transport Parameters→Solute Transport Parameters→ Solute Reaction Parameters)
  Leave default parameters and browse through all these windows
  Button ”Next”

- **Solute Transport – Constructed Wetland Model (CWM1) Parameters I**
  (Edit→Flow and Transport Parameters→Solute Transport Parameters→ Constructed Wetland Parameters I)
  Explore and leave default parameters
  Button ”Next”

- **Solute Transport – Constructed Wetland Model (CWM1) Parameters II**
  (Edit→Flow and Transport Parameters→Solute Transport Parameters→ Constructed Wetland Parameters II)
  Explore and leave default parameters
  Button ”Next”

- **Time-Variable Boundary Conditions** (Edit→Flow and Transport Parameters→Variably Boundary Conditions)

Change Time to 48 hours

add influent concentrations:
- `cVal1-1 = 0.86`
- `cVal1-2 = 170`
- `cVal1-3 = 27`
- `cVal1-4 = 13`
- `cVal1-5 = 57`
- `cVal1-7 = 33`
- `cVal1-9 = 33`
- `cVal1-10 = 13`
**Button "OK"**

- **Solute Transport Initial Conditions:**
  Note: it is assumed that (1) clean sand is used and (2) the HF bed is filled with wastewater at the beginning of the simulation. For the initial conditions (1) results in an homogeneous distribution of the bacteria in the filter (a value of 1 mg/kg is assumed for all bacteria species) and (2) results in initial conditions for solute species that are the influent concentrations (see above)

Navigator Bar click on **FE-Mesh – FE-Mesh Parameters**
**Button ”Next” for Window Default Domain Properties**

Enter initial concentrations for solute compounds L1-L10 and bacteria S11-S16

**Button "OK"**
To check initial conditions for compounds: Navigator Bar **Initial Conditions**
• **Solute Transport Boundary Conditions:**
  Navigator Bar click on *Boundary Conditions – Solute Transport*
  Select *Third-type Boundary* from the Edit Bar, and nodes from mixing zone selected
  as Atmospheric BC.
  Pointer to the vector of the boundary Conditions = 1 (note that this was already the
  default value).
  *Button “OK”*

• **Save**
  Save the project using the *Save* command on the Toolbar (or *File ➔ Save*).

• **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or *Calculation ➔ Calculate Current Project*)

• **Results – Graphical Display:**
  View results at the end of simulation time, i.e. 48 hours
  
  e.g. L1 – Dissolved Oxygen

Note that you get this display only after adjusting the scale for contours. Use the menu
command *Tools ➔ Color Scale ➔ Edit Scale* or simply double click on the Scale panel
on the Edit Bar. In the window "Edit Isoband Values and Color Spectra", adjust the
scales as follows for L1 - Dissolved Oxygen:
and for S11 – Heterotrophic Bacteria

The definition of the scale can be saved for future use using the command "Copy..". The scale can be saved under various names, such as "Dissolved Oxygen" or "Heterotrophic Bacteria".
• **Results – Other Information: Observation Points** (from the Navigator Bar)
check simulation results at observation points, e.g., select L2 and L3

*Button "Close"

• **Save Results**
Save the project using the *Save* command on the Toolbar (or File ➔ Save).
Note: Usually simulations need to be run until steady-state is reached, i.e. the patterns of the bacteria concentrations obtained do not change anymore.
Simulation 4 – Set-up Simulation that Considers Wetland Plants

- **Project Manager** (File → Project Manager)
  - Select "Example 3c"
  - "Copy"
  - Enter New Name: Example 3d
  - Description: HF wetland – reactive transport simulation (CWM1) + plants
  - "OK"
  - "Open" Example 3d

- **Update of Water Flow Initial Conditions with simulation results from before:**
  - Insert → Initial Condition → Import
  - Select file "Example 3b.h3d2" in working directory
  - "Open"

  Warning: This action requires deleting results. Do you want to continue?
  - "Yes"

- **Save Results**
  - Save the project using the Save command on the Toolbar (or File → Save).

- **Main Processes** (Edit → Flow and Transport Parameters → Main Processes)
  - Check Box: Water Flow
  - Check Box: Solute Transport
  - Check Box: Root Water Uptake
  - "OK"

  - Water Uptake Reduction Model: S-Shaped
  - Solute Stress Model: No Solute Stress
  - "Next"

- **Root Water and Solute Uptake: Root Water Uptake Parameters** (Edit → Flow and Transport Parameters → Root Water and Solute Uptake → Pressure Head Reduction)
  - P50 [m] = -1; P3 [-] = 3; PW [m] = -100
  - "OK"

- **Solute Transport – Reaction Parameters** (Edit → Flow and Transport Parameters → Solute Transport Parameters → Solute Reaction Parameters)
  - L1 (Dissolved Oxygen): cRoot = -675
  - L5 (Ammonia NH4): cRoot = 50
  - L6 (Nitrate NO3): cRoot = 50
  - "OK"

- **Time-Variable Boundary Conditions** (Edit → Flow and Transport Parameters → Variably Boundary Conditions)

  *Calculation:*
  - Transpiration = 7.4 L.m⁻².d⁻¹ = 7.4 mm.d⁻¹ = 0.0074 m.d⁻¹ = 0.00031 m.h⁻¹
"Length of soil surface associated with transpiration" = 10 m.  

**Button "OK"**

- **Root Distribution:**
  Click on the **Domain Properties Tab** under the View Window.  
  Or on the Navigator Bar click on **Domain Properties – Root Water Uptake** (or Insert – Domain Properties – Root Distribution)

(1) Click on "Properties in Table" on the Edit bar  
Enter the Root distribution as follows:

![Root Distribution Table](image)

Note that this table displayes values that are constant for the entire horizontal layer (for all nodes on one horizontal line). It hides values that are different along the line.

**Button "OK"**

(2) Zoon on the upper left part of the transport domain. Select the first 4 columns on the left side of the transport domain (mixing zone)  
Click on the "Set Root Water Uptake" on the Edit Bar: Top Value 0 → Same value for all nodes → "OK"
Button "OK"

- **Save**
  Save the project using the *Save* command on the Toolbar (or File→Save).

- **Run Calculations**
  Click the *Calculate Current Project* command on the Toolbar (or Calculation→Calculate Current Project)

- **Results – Graphical Display**: View the same results as without plants
  e.g. L1 – Dissolved Oxygen

  ![HYDRUS 2D: Example 3d, Results, L1 – Dissolved Oxygen](image)

  e.g. S11 – Heterotrophic Bacteria
Results – Other Information – Cumulative Fluxes:
Select "Cumulative Actual Root Water Uptake"

Calculations:
Cumulative Root Water Uptake (in 2D) = 0.15 m* (in 48 hours)
Transpiration
… for the entire wetland surface: 0.15 m² x 5.3 m / 48h = 16.56 L.h⁻¹
… for unit surface area: 16.56 L.h⁻¹ x 24 h/d /(5.3*10 m²) = 7.5 L.m⁻².d⁻¹
**Results – Other Information – Solute Fluxes:**
Select "Concentration number 1 (Dissolved Oxygen)
Select "Cumulative Root Solute Uptake" Note: the minus sign denotes oxygen release

![Cumulative Root Solute Uptake Graph]

Calculations:
Oxygen Release = -100 g/m (in 48 hours)
… for the entire wetland surface: 100 g/m x 5.3 m(width) / 48h = -11.04 g.h⁻¹
… for unit surface area: 11.04 g.h⁻¹ x 24 h/d / (5.3*10 m²) = -5 g.m⁻².d⁻¹

Same calculations for:
L5 (Ammonium N): Root uptake = 7.43 g/m (in 48 hours) → 0.37 g.m⁻².d⁻¹
L6 (Nitrate N): Root uptake = 0.0105 g/m (in 48 hours) → 0.0005 g.m⁻².d⁻¹

**Save Results**
Save the project using the Save command on the Toolbar (or File → Save).