
Unsatchem Computer Session 

Unsatchem Tutorial: Furrow infiltration  
 

A furrow irrigation problem is used in this tutorial to simulate two-dimensional infiltration of 
gypsum saturated water into a sodic soil. The simulation of sodic soil reclamation demonstrates the 
cation exchange feature of the UNSATCHEM module. The schematic representation of the flow 
domain for the considered furrow irrigation together with the finite element mesh is presented 
below. Several variants (such as using different irrigation water, effects of solution composition on 
hydraulic conductivity, etc) of the basic simulations (done first) are discussed in the second part of 
the tutorial. 
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Schematic representation and finite element mesh of the flow domain for the furrow irrigation 

system. 
 

It is assumed that every other furrow is flooded with water and that the water level in the irrigated 
furrow is kept constant at a level of 6 cm. Due to symmetry, it is necessary to carry out the 
simulation only for the domain between the axis of two neighboring furrows. Free drainage is used 
as the bottom boundary condition and zero flux is considered on the rest of the boundary. The initial 
pressure head condition is -200 cm and the soil hydraulic properties of silt are used. Water 
infiltration is evaluated for 5 days. 
 
The calculation is run at a constant temperature of 25 oC and a CO2 concentration of 0.01 cm3cm-3. 
Root water uptake and evaporation were neglected. The bulk density of the soil was taken as 1.4 g 
cm-3 and molecular diffusion as 2 cm2day-1. Longitudinal and transverse dispersivities were equal to 
2 and 0.2 cm, respectively. 
 
The solution composition of the water initially present in the soil profile is that of the following 
highly sodic water: CaT=0.2, MgT=0.0, NaT=4.8, KT=0.0, ClT=4.6, SO4T=0.0, Alk=0.4 mmolcL

-1. 
The cation exchange capacity is equal to 100 mmolckg-1 and is divided between exchangeable 



Unsatchem Computer Session 

calcium and sodium (a=5.0, a=95.0 mmolckg-1). The following Gapon selectivity coefficients were 
used: KCa/Mg=0.896, KCa/Na=1.158, and KCa/k=0.111. The solution composition of the irrigation 
water was almost gypsum saturated: CaT=32.6, MgT=0.0, NaT=4.8, KT=0.0, ClT=5.0, SO4T=32.0, 
Alk=0.4 mmolcL

-1. As a consequence of the reactions of the irrigation water with the exchanger 
composition, cation exchange was the dominant chemical processes in the soil profile. Cation 
exchange is treated as an instantaneous process in the model. 
 
Users become in this example familiar with the basic concept of the transport domain design 
(using simple geometry) and of chemical compositions used in the UNSATCHEM module. 
Initial and boundary conditions are specified, and graphical displays of the results using contour 
and spectrum maps, including animation, are provided, for a more complex transport domain 
than in the previous example. 
 
Project Manager (File->Project Manager) 

Button "New" 
 
New Project (or File->New Project) 

Name: UnsatchemFurrow 
Description: Furrow irrigation with a solute pulse - Tutorial 
Working Directory: Temporary – exists only when the project is open 
Button "Next" 

 
Domain Type and Units (Edit->Domain Geometry->Domain Type and Units) 

Type of Geometry: 2D - Simple 
2D-Domain Options: 2D - Vertical Plane XZ 
Units: cm 
Note that "Edit domain properties, initial and boundary conditions on geometric objects" 
is disabled. This approach can be used on with 2D-General Geometries. 
Initial Workspace: X-Min=0, X-Max=100, Z-Min=0, Z-Max=100 cm (exact size of the 
transport domain) 
Button "Next" 

 
Rectangular Domain Definition (Edit->Domain Geometry->Simple Domain) 

Lx: 100 cm 
Lz: 100 cm 
Slope : 0 
Button "Next" 

 
Main Processes (Edit->Flow and Transport Parameters->Main Processes) 

Check Boxes: Water Flow, Solute Transport, and Major Ion Chemistry 
Button "Next" 

 
Time Information (Edit->Flow and Transport Parameters->Time Information) 

Time Units: days 
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Final Time:   5 
Initial Time Step:   0.0001 
Minimum Time Step:  0.00001 
Maximum Time Step: 5 
Button "Next" 

 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Check T-Level Information 
Keep Evey n time steps: 1 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 8 
Update 
Print Times: 0.05, 0.1, 0.25, 0.5 1, 2, 3, 5 
Button "Next" 

 
Water Flow - Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Iteration Criteria) 

Leave default values as follows: 
Maximum Number of Iterations: 10 
Water Content Tolerance: 0.001 
Pressure Head Tolerance: 1 
Lower Optimal Iteration Range: 3 
Upper Optimal Iteration Range: 7 
Lower Time Step Multiplication Factor: 1.3  
Upper Time Step Multiplication Factor: 0.7 
Lower Limit of the Tension Interval: 0.0001 
Upper Limit of the Tension Interval: 10000 
Initial Condition: In Pressure Heads  
Button "Next" 

 
Water Flow - Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Hydraulic Properties Model) 

Radio button - van Genuchten-Mualem 
Radio button - No hysteresis 
Button "Next" 

 
Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters ->Soil Hydraulic Parameters) 

Select Silt from Soil Catalog 
Button "Next"  

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  
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Leave default values except 
Number of Solution Concentration Combinations: 2 
Button "Next" 

 
Solute Transport – Solute Compositions (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solution Compositions)  

Solution Concentrations [meq/L] 
Ca Mg Na K Alk SO4 Cl Tracer 
32.6 0 4.8 0 0.4 32 5 0 
0.2 0 4.8 0 0.4 0 4.6 1 
Adsorption Concentrations [meq/kg] 
Ca Mg Na K 
0.5 0 9.5 0 
Precipitated Concentrations [meq/kg]: all zeros 
Button "Next" 

 
Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Reaction Parameters) 

Leave default values except 
Bulk Density = 1.4 cm3/g 
Molecular Diffusion, Dw = 2 cm2/d 
Longitudinal Dispersivity, Disp.L = 2 cm 
Transverse Dispersivity, Disp.T = 0.2 cm 
Cation Exchange Capacity, CEC = 10 meq/kg 
Calcium Surface Area = 0 (used only when kinetic precipitation/dissolution is 
considered) 
Dolomite Surface Area = 0 (ditto) 
K [Ca/Mg] = 0.896 
K [Ca/Na] = 1.158 
K [Ca/K] = 0.111 
Button "Next" 

 
Solute Transport - Chemical Parameters  (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Chemical Parameters) 

Leave default values 
Button "Next" 

 
FE-Mesh - FE-Mesh Parameters  (Edit->FE-Mesh->FE-Mesh Parameters) 

Horizontal Discretization in X 
Count: 45 
Update 
VerticalHorizontal Discretization in Z 
Count: 26 
Update 

 
x [cm] dz [cm]  z [cm] 

0 -15  100 
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3 -15  99 

6 -15  97.5 

9 -15  95.5 

12 -15  93 

15 -15  90 

16.5 -13.5  87 

18 -12  84 

19.5 -10.5  81 

21 -9  78 

22.5 -7.5  75 

24 -6  72 

25.5 -4.5  69 

27 -3  66 

28.5 -1.5  62 

30 0  58 

32 0  54 

34 0  50 

36.5 0  45 

39 0  40 

42 0  34 

46 0  28 

50 0  21 

54 0  14 

58 0  7 

61 0  0 

63.5 0 

66 0 

68 0 

70 0 

71.5 -1.5 

73 -3 

74.5 -4.5 

76 -6 

77.5 -7.5 

79 -9 

80.5 -10.5 

82 -12 

83.5 -13.5 

85 -15 

88 -15 

91 -15 

94 -15 

97 -15 

100 -15 

 
Button "Next" 

 
Default Domain Properties (Edit->Domain Properties->Default Domain Properties) 
 Column h: -200 cm 
 Column Temp: 25 
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 Column Sol#: 2 
Button "Next" 

 
Water Flow Initial Conditions (Edit->Initial Conditions->Pressure Head) 
Click on the Initial Conditions Tab under the View Window.  
Click on the Pressure Head on the Navigator Bar. 
Select the entire transport domain and then click on Set Pressure Head IC ( ) on 
the Edit Bar. In the Water Flow Initial Condition window, check Same value for all nodes and 
specify Pressure Head Value equal to -200 cm. 
 
Solute Transport Initial Conditions (Edit->Initial Conditions->Solution Composition) 
Click on the Solution Composition on the Navigator Bar. 
Select the entire transport domain and then click on Solution 2 ( ) on the Edit Bar.  
 
Water Flow Boundary Conditions (Edit->Boundary Conditions->Water Flow) 
Click on the Boundary Conditions Tab under the View Window. 

a) Click on Zoom by Rectangle ( ) at the Toolbar (or View-> Zoom by Rectangle) and 
zoom on the left furrow. 

Select Constant Head ( ) from the Edit Bar, select bottom of the left 
furrow and 4 nodes on the side, specify 6 cm with Equilibrium from the lowest located 
nodal point. 

b) Click on View All ( ) at the Toolbar (or View->View All). 
Select Free Drainage ( ) from the Edit Bar, and select the entire bottom of 
the transport domain. 

c) On the Navigator Bar double click on Solute Transport 
Click on Display codes on the Edit Bar ( ) and check that "-1" (or "+1") is 
displayed in the furrow. This means that solution composition 1 will be applied with the 
irrigation water. 
Uncheck "Display Codes" again. 

 
Observation Nodes 
Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert->Domain 
Properties->Observation Nodes). 
Click on the Insert command on the Edit Bar and specify 5 points arbitrarily in the transport 
domain between the furrow and the bottom of the transport domain. 
 
Save  

Save the project using the Save command ( ) on the Toolbar (or File->Save). 
 
Run Calculations 

Click the Calculate Current Project command ( ) on the Toolbar (or Calculation->Calculate 
Current Project)  
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OUTPUT:  
Click on the Results Tab under the View Window.  
 
Results – Other Information: Observation Points (from the Navigator Bar, or Results-
>Observation Points from menu)  

Pressure Heads 
Water Contents 
Concentrations 

 
 
Results – Other Information: Boundary Fluxes (from the Navigator Bar, or Results-
>Boundary Information->Boundary Fluxes from menu)  

 Constant Boundary Flux 
 Free Drainage Boundary Flux 

 
Results – Other Information: Cumulative Fluxes (from the Navigator Bar, or Results-
>Boundary Information->Cumulative Fluxes from menu)  

 Constant Boundary Flux 
 Free Drainage Boundary Flux 

 
Results – Other Information: Solute Fluxes (from the Navigator Bar, or Results->Boundary 
Information->Solute Fluxes from menu)  

 Constant Boundary Flux 
 Seepage Face Boundary Flux 
 

Results – Other Information: Chemical Mass Balance Information (from the Navigator Bar, 
or Results->Mass Balance Information from menu)   
 
Results – Graphical Display: Pressure Heads (from the Navigator Bar, or Results->Display 
Quantity->Pressure Heads from menu)   

Use Listbox Time Layer or Slidebar on the Edit Bar to view results for different print 
times 
Check Flow Animation 
Select different display modes using Options->Graph Type 

  
Results – Graphical Display: Water Contents (from the Navigator Bar, or Results->Display 
Quantity->Water Contents from menu) 
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Results – Graphical Display: Concentrations (from the Navigator Bar, or Results->Display 
Quantity->Concentrations from menu)   
 Results – Graphical Display: Velocity Vectors (from the Navigator Bar, or Results->Display 
Quantity->Velocity Vectors from menu) 
 

 
Pressure heads (t=5 d) 

 

   
Soluble Calcium (t=5 d)                      Soluble Sodium (t=5 d) 
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Different Modifications of the Basic Run 
 
1. Considering the effects of the solution composition on the hydraulic 

conductivity 
 
Project Manager (File->Project Manager) 

Select " UnsatchemFurrow" 
Button ”Copy” 
Enter New Name: UnsatchemFurrow 1 
Description: Considering the effects of the solution composition on the hydraulic 
conductivity 
Button ”OK” 
Button ”Open” UnsatchemFurrow 1 

Solute Transport – Chemical Parameters (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Chemical Parameters)  

Check "Conductivity Reduction due to Chemistry" 
Button ”OK” 

 
Re-Run Calculations 

Click the Calculate Current Project command on the Toolbar (or CalculationCalculate 
Current Project)  

Results – Graphical Display: Pressure Heads (from the Navigator Bar, or Results->Display 
Quantity->Pressure Heads from menu)   

Use Listbox Time Layer or Slidebar on the Edit Bar to view results for different print 
times. 

 
It is clear that the movement of moisture front was dramatically slowed down. Rerun the 
simulation for longer simulation time. 
 
Time Information (Edit->Flow and Transport Parameters->Time Information) 

Final Time:   50 d 
Initial Time Step:   0.0001 
Minimum Time Step:  0.00001 
Maximum Time Step: 5 
Button "Next" 

 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Print Times: Count: 4 
Update 
Print Times: 5, 10, 25, 50 d 
Button "Next" 
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Re-Run Calculations 
Click the Calculate Current Project command on the Toolbar (or CalculationCalculate 
Current Project)  

Results – Graphical Display: Pressure Heads and other variables (from the Navigator Bar, or 
Results->Display Quantity->Pressure Heads from menu)   
 

   
Pressure heads (t=50 d)                  Soluble Sodium (t=50 d) 

 
Compare results with the previous run 
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2. Using high quality water for irrigation 
 
Project Manager (File->Project Manager) 

Select " UnsatchemFurrow" 
Button ”Copy” 
Enter New Name: UnsatchemFurrow 2 
Description: Using high quality water for irrigation 
Button ”OK” 
Button ”Open” UnsatchemFurrow 2 

Solute Transport – Solute Compositions (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solution Compositions)  

Solution Concentrations [meq/L] 
Ca Mg Na K Alk SO4 Cl Tracer 
1.5 0.5 2 0 0.5 2.5 1 0 
0.2 0 4.8 0 0.4 0 4.6 1 
Button "Next" 
 

Re-Run Calculations 
Click the Calculate Current Project command on the Toolbar (or CalculationCalculate 
Current Project)  

Results – Graphical Display: Pressure Heads and other variables (from the Navigator Bar, or 
Results->Display Quantity->Pressure Heads from menu)   
 

  
Soluble Calcium (t=5 d)                  Soluble Sodium (t=5 d) 
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3. Using high quality water for irrigation and assuming presence of calcite in 
the profile (and either instantaneous or kinetic dissolution). 

 
Project Manager (File->Project Manager) 

Select " UnsatchemFurrow" 
Button ”Copy” 
Enter New Name: UnsatchemFurrow 2 
Description: Using high quality water for irrigation, instantaneous calcite 
Button ”OK” 
Button ”Open” UnsatchemFurrow 3a 

Solute Transport – Solute Compositions (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solution Compositions)  

Precipitated Concentrations [meq/kg]:  
Calcite = 1000 
Button "Next" 

 
Run Calculations 
 

  
Sorbed Sodium                                            Calcite 

 
Project Manager (File->Project Manager) 

Select " UnsatchemFurrow" 
Button ”Copy” 
Enter New Name: UnsatchemFurrow 3a 
Description: Using high quality water for irrigation, kinetic calcite 
Button ”OK” 
Button ”Open” UnsatchemFurrow 3b 

Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Reaction Parameters) 

Leave old values except 
Calcium Surface Area = 0.02 [m2/L] 
Button "Next" 
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Solute Transport - Chemical Parameters  (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Chemical Parameters) 

Leave default values 
Check "Kinetic Precipitation/Dissolution" 
Button "Next" 
 

Run Calculations 
 

  
Sorbed Sodium                                            Calcite 
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4. Using different irrigation waters for irrigation 
 
Project Manager (File->Project Manager) 

Select " UnsatchemFurrow" 
Button ”Copy” 
Enter New Name: UnsatchemFurrow 4 
Description: Using different irrigation waters  
Button ”OK” 
Button ”Open” UnsatchemFurrow 4 

Time Information (Edit->Flow and Transport Parameters->Time Information) 
T-Level Information: Every n Time Steps: 5 
Final Time:   5 d 
Check "Time-Variable Boundary Conditions" and set the "Number of Time-Variable 
Boundary Records" equal to 2. 
Button "Next" 

 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Print Times: Count: 6 
Update 
Print Times: 0.5, 1, 2, 3, 4, 5 d 
Button "Next" 

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Leave default values except 
Number of Solution Concentration Combinations: 3 
Button "Next" 

 
Solute Transport – Solute Compositions (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solution Compositions)  

Solution Concentrations [meq/L] 
Ca Mg Na K Alk SO4 Cl Tracer 
32.6 0 4.8 0 0.4 32 5 0 
0.2 0 4.8 0 0.4 0 4.6 1 
2 0 2 0 0.5 2.5 1 2 
Button "Next" 
 

Variable Boundary Conditions (Edit->Flow and Transport Parameters->Variable Boundary 
Conditions) 
 Time Var.H-1 cValue1 
 2.5 6  1 
 5 6  3 
 
Water Flow Boundary Conditions (Edit->Boundary Conditions->Water Flow) 
Click on the Boundary Conditions Tab under the View Window. 
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Click on Zoom by Rectangle ( ) at the Toolbar (or View-> Zoom by Rectangle) and 
zoom on the left furrow. 

Select Variable Head ( ) from the Edit Bar, and overwrite the Constant 
Head BC with Variable Head BC (bottom of the left furrow and 4 nodes on the side) 

 

Re-Run Calculations 
Click the Calculate Current Project command on the Toolbar (or CalculationCalculate 
Current Project)  

Results – Graphical Display: Pressure Heads and other variables (from the Navigator Bar, or 
Results->Display Quantity->Pressure Heads from menu)   
 

 

 
    Calcium    Sodium   Tracer 


