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Abstract 
 
Šimůnek, J., D. Jacques, M. Šejna, and M. Th. van Genuchten, The HP2 Program for HYDRUS 
(2D/3D): A Coupled Code for Simulating Two-Dimensional Variably-Saturated Water Flow, Heat 
Transport, and Biogeochemistry in Porous Media, Version 1.0, PC Progress, Prague, Czech 
Republic, 78 pp., 2012. 
 

This user manual documents the HP2 program that resulted from coupling Hydrus (its two-
dimensional part) with the PHREEQC geochemical code [Parkhurst and Appelo, 1999] to 
create this new comprehensive simulation tool (HP2 - acronym for HYDRUS-PHREEQC-2D), 
corresponding to a similar one-dimensional module HP1 [Jacques and Šimůnek, 2005; Jacques 
et al., 2006; Šimůnek et al., 2006, 2008). HP2 has, apart from the dimensionality (2D), the 
same capabilities as HP1. HP2 contains modules simulating (1) transient water flow, (2) the 
transport of multiple components, (3) mixed equilibrium/kinetic biogeochemical reactions, and 
(4) heat transport in two-dimensional variably-saturated porous media (soils). HP2 is thus a 
significant expansion of the individual HYDRUS-2D and PHREEQC programs by preserving 
most of their original features. The code still uses the Richards equation for simulating two-
dimensional variably-saturated water flow and advection-dispersion type equations for heat and 
solute transport. However, the loosely coupled program can simulate also a broad range of low-
temperature biogeochemical reactions in water, the vadose zone and in ground water systems, 
including interactions with minerals, gases, exchangers and sorption surfaces based on 
thermodynamic equilibrium, kinetic, or mixed equilibrium-kinetic reactions. HP2 (similarly as 
HP1) uses the operator-splitting approach with no iterations during one time step (a non-
iterative sequential modeling approach).  

The HP2 code is fully incorporated into the HYDRUS (2D/3D) software package, and hence is 
installed automatically, together with selected examples, when one obtains HYDRUS (2D/3D) 
and HP2 licenses and downloads HYDRUS from the Hydrus website.  

The purpose of this report is to documents the HP2 program for the HYDRUS (2D/3D) software 
package [Šimůnek et al., 2011; Šejna et al., 2011] simulating two-dimensional variably-saturated 
water flow, heat transport, solute transport, and biogeochemistry. The HP2 module, as well as the 
description of the module in this report, is largely based on the earlier one-dimensional HP1 module 
Jacques and Šimůnek [2005, 2010]. One can find additional useful information, especially related 
to biogeochemical reactions, in the PHREEQC [Parkhurst and Appelo, 1999] and HP1 [Jacques 
and Šimůnek, 2005, 2010] manuals. The report serves as both a Technical Manual and a User 
Manual, as well as a reference document of the Graphical User Interface of HP2 related parts of 
the HYDRUS software package. 
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DISCLAIMER 
 
The HP2 module was developed as a supplemental module of the HYDRUS (2D/3D) software 
package to simulate the water flow, heat transport, solute transport, and biogeochemical reactions 
in soils and groundwater. The software has been verified against selected test cases. However, no 
warranty is given that the program is completely error-free. If you do encounter problems with the 
code, find errors, or have suggestions for improvement, please contact the senior author at 
 
Jirka Šimůnek 
Tel/Fax: 1-951-827-7854 
Email: jiri.simunek@ucr.edu 
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1. Introduction 
 

This user manual documents the HP2 program that resulted from coupling Hydrus (its two-
dimensional part) with the PHREEQC geochemical code [Parkhurst and Appelo, 1999] to 
create this new comprehensive simulation tool (HP2 - acronym for HYDRUS-PHREEQC-2D), 
corresponding to a similar one-dimensional module HP1 [Jacques and Šimůnek, 2005; Jacques 
et al., 2006; Šimůnek et al., 2006, 2008). HP2 has, apart from the dimensionality (2D), the 
same capabilities as HP1. HP2 contains modules simulating (1) transient water flow, (2) the 
transport of multiple components, (3) mixed equilibrium/kinetic biogeochemical reactions, and 
(4) heat transport in two-dimensional variably-saturated porous media (soils). HP2 is thus a 
significant expansion of the individual HYDRUS-2D and PHREEQC programs by preserving 
most of their original features. The code still uses the Richards equation for simulating two-
dimensional variably-saturated water flow and advection-dispersion type equations for heat and 
solute transport. However, the loosely coupled program can simulate also a broad range of low-
temperature biogeochemical reactions in water, the vadose zone and in ground water systems, 
including interactions with minerals, gases, exchangers and sorption surfaces based on 
thermodynamic equilibrium, kinetic, or mixed equilibrium-kinetic reactions. HP2 (similarly as 
HP1) uses the operator-splitting approach with no iterations during one time step (a non-
iterative sequential modeling approach). Jacques et al. [2006] evaluated the accuracy of the 
operator-splitting approach for a kinetic reaction network (i.e., sequential and parallel kinetic 
degradation reactions) by comparing HP1 with an analytical solution for TCE-degradation, as 
well as for mixed equilibrium and kinetic reactions involving different flow conditions (steady-
state and transient). 

Jacques and Šimůnek [2005], Šimůnek et al. [2006], Jacques et al. [2008ab], demonstrated the 
versatility of HP1 on several examples, which included a) the transport of heavy metals (Zn2+, 
Pb2+, and Cd2+) subject to multiple cation exchange reactions, b) transport with mineral 
dissolution of amorphous SiO2 and gibbsite (Al(OH)3), c) heavy metal transport in a medium 
with a pH-dependent cation exchange complex, d) infiltration of a hyperalkaline solution in a 
clay sample (this example considers kinetic precipitation-dissolution of kaolinite, illite, quartz, 
calcite, dolomite, gypsum, hydrotalcite, and sepiolite), e) long-term transient flow and transport 
of major cations (Na+, K+, Ca2+, and Mg2+) and heavy metals (Cd2+, Zn2+, and Pb2+) in a soil 
profile, f) cadmium leaching in acid sandy soils, g) radionuclide transport, and h) long term 
uranium migration in agricultural field soils following mineral P-fertilization. Most of these 
examples have been rerun using HP2, which verified correct implementation of various 
components of the coupled program. 

The HP2 code is fully incorporated into the HYDRUS (2D/3D) software package, and hence is 
installed automatically, together with selected examples, when one obtains HYDRUS (2D/3D) 
and HP2 licenses and downloads HYDRUS from the Hydrus website.  

The main purpose of this report is to document a two-dimensional numerical module HP2 that 
incorporates flow and transport processes, as well as biogeochemical reactions in variably-
saturated porous media. HP2 was developed specifically for the HYDRUS (2D/3D) software 
package [Šimůnek et al., 2011; Šejna et al., 2011]. The general conceptual basis of the module is 
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discussed in detail in reports of Jacques and Šimůnek [2005, 2010], and restated here for multi-
dimensional systems.  
 
The documentation in this report focuses mostly on implementation of the HP2 module into 
HYDRUS (2D/3D). All processes related to variably-saturated water flow, heat transport, and 
solute transport are described in detail in the HYDRUS (2D/3D) documentation [Šimůnek et al., 
2011], and will not be repeated here. Similarly, processes and reactions related to biogeochemical 
reactions are described in detail in the PHREEQC [Parkhurst and Apello, 1998] and HP1 [Jacques 
and Šimůnek, 2005, 2010] manuals. 
 
The HP2 module may be used to analyze water flow, solute movement, and biogeochemical 
reactions in unsaturated, partially saturated, or fully saturated porous media. HP2 can handle flow 
domains delineated by irregular boundaries. The flow region itself may be composed of nonuniform 
soils having an arbitrary degree of local anisotropy. Flow and transport can occur in the vertical 
plane, the horizontal plane, or in a three-dimensional region exhibiting radial symmetry about a 
vertical axis. The water flow part of the model considers prescribed head and flux boundaries, as 
well as boundaries controlled by atmospheric conditions. 
 
The governing flow and transport equations are solved numerically using standard Galerkin-type 
linear finite element schemes. The HP2 module is fully supported by the HYDRUS (2D/3D) 
graphical user interface [Šejna et al., 2011]. Applications of the HP2 module are demonstrated 
later in this report on several examples. 
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2. Running HP2 from the HYDRUS (2D/3D) Graphical User Interface 
 
The HP2 code is fully incorporated into the HYDRUS (2D/3D) software package, and hence is 
installed automatically, together with selected examples, when one obtains HYDRUS (2D/3D) 
and HP2 licenses and downloads HYDRUS from the Hydrus website. The documentation in this 
report focuses mostly on implementation of the HP2 module into HYDRUS (2D/3D). All processes 
related to geometry design, finite element discretization, variably-saturated water flow, heat 
transport, solute transport, initial and boundary conditions are described in detail in the HYDRUS 
(2D/3D) documentation [Šimůnek et al., 2011; Šejan et al., 2011], and will not be repeated here. 
Similarly, processes and reactions related to biogeochemical reactions are described in detail in the 
PHREEQC [Parkhurst and Apello, 1998] and HP1 [Jacques and Šimůnek, 2005, 2010] manuals. 
 
2.1. Preprocessing and Input Data 
 
HP2 projects are managed in the same way as other HYDRUS (2D/3D) projects using the 
Project Manager. The Project Manager is used to manage data of existing projects, and to 
locate, open, delete, copy, or rename projects. A new HP2 project is created in the same as any 
other HYDRUS (2D/3D) project, i.e., using the button "New" in the Project Manager. Since all 
other inputs, i.e., domain design, FE discretization, water flow and heat transport, are the same as 
in standard HYDRUS (2D/3D) projects, only parts related specifically to HP2 are discussed 
below. 
 
2.1.1. Main Processes 
 
The HP2 module is activated in the Main Processes window (Fig. 1) by selecting the Solute 
Transport check box and the HP2 (Hydrus + Phreeqc) radio button. 
 

 
 

Figure 1. The Main Processes dialog window. 



 12 

2.1.2. Solute Transport - General Information 
 
When the HP2 module is used, basic information needed for defining solute transport problem is 
entered in the Solute Transport dialog window displayed in Figure 2. Once the HP2 module is 
selected in the Main Processes window, large parts of the Solute Transport dialog window are 
disabled, since they are not relevant to HP2. However, a user can still select the Space and Time 
Weighting Schemes, and the Stability Criterion, which constraints the temporal discretization 
(see the HYDRUS Technical Manual). A user has to specify the Number of Solutes (i.e., main 
HP2 components) and can select the tortuosity model (either Millington and Quirk [ 1961] or 
Moldrup [1997, 2000] models can be used). Note that also Mass Units are disabled, since 
concentrations are entered using PHREEQC conventions (i.e., many different types of units can 
be used, such as mol/l, mmol/L, mg/L, µg/L, ppm, etc), and results are reported in mol/L (with 
the assumption that 1 L water = 1 kg water). 
 

 
 

Figure 2. The Solute Transport dialog window. 
 

 
2.1.3.  HP2/3 Components and Database Pathway 
 
The next window that appears is the HP2/3 Components and Database Pathway window (Fig. 
3). 
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Figure 3. The HP2/3 Components and Database Pathway dialog window. 
 
Note that the option to specify initial and boundary conditions In Concentrations is disabled 
and only Solution Compositions can be used for this purpose (In Solution Composition). Also, 
the check box Create PHREEQC.IN file using HYDRUS GUI is selected by default. Although 
the PHREEQC.In file can be created outside of the HYDRUS GUI (e.g., using specialized 
PHREEQC GUIs), we do not recommend to do it that way. Both these options, as well as the 
format of the structured phreeqc.in file, are discussed in detail by Jacques and Šimůnek [2010]. 
 
When the option In Solution Composition is selected together with the option Create 
PHREEQC.IN file using HYDRUS GUI, then: 

• the phreeqc.in file (the file with the definition of the geochemical model) is a structured 
file, which is created and can be modified using the HP2 Definitions dialog window (Fig. 
4) 

• the composition of the initial and boundary solutions has to be defined in phreeqc.in 
using specific solution composition numbers 

• the temporal variation of the boundary solutions is defined in the HYDRUS GUI by 
specifying the solution composition number corresponding to the solution composition 
number defined in phreeqc.in 

• the spatial distribution of the initial solutions is defined in the HYDRUS GUI by 
specifying the solution composition number in the soil domain corresponding to the 
solution composition number defined in phreeqc.in 

 
 

2.1.3.1.  Thermodynamic Databases 
 
In the HP2/3 Components and Database Pathway window, users have to select the 
thermodynamic database to be used with HP2 calculations (Path to Folder with Thermodynamic 
Databases; Fig. 2). Thermodynamic databases contain definitions of various chemical species 
and thermodynamic constants for various chemical reactions, and related information (e.g., 
temperature dependence, ion activity model, etc). Using the "Browse" button, it is possible to 
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locate and select a thermodynamic database. Note that the format of the thermodynamic data in 
the database must follow the conventions of PHREEQC (see PHREEQC-2 manual, Parkhurst 
and Appelo, 1999). A number of thermodynamic databases (e.g., phreeqc.dat, wateq4f.dat, 
minteq.dat, llnl.dat, ex15.dat, and others, typically included in the PHREEQC-2 program) are 
installed with HYDRUS into the ThermodynamicDB folder. Users can create and use their own 
database files. 
 

2.1.3.2.  Components 
 
The element names of components have to be listed in the Components column in the HP2/3 
Components and Database Pathway dialog window. The number of components is specified in 
the Solute Transport - General Information dialog window (Fig. 2). 

Components must start with a capital letter and must be present as element_name in the 
SOLUTION_MASTER_SPECIES keyword block of the thermodynamic database or in the 
phreeqc.in input file (which can be defined in the GUI in the editor Addition to the 
Thermodynamic Database of the HP2/3 Definitions dialog window, Fig. 4). Three special 
components are: 

• Total_O: a component related to O(-2) that sums up all O(-2) in the aqueous species 
except in H2O. It is recommended to include this component in each project. 

 
• Total_H: a component related to H(1) that sums up all H(1) in the aqueous species 

except in H2O. It is recommended to include this component in each project. 
 

• Charge: a component related to the charge of the aqueous phase. This component 
should be used when a non-electrical surface complexation model involving charged 
species is used. In the non-electrical surface complexation model, positive or negative 
charges on the surface are not compensated. Therefore the aqueous phase also has a 
negative or positive charge. Note that the complete system (surface + aqueous phase) is 
charge balanced. 

 
Each redox state of redox-sensitive components has to be defined as a component. Without a 
valence state, a redox-sensitive component will not be recognized. Thus, while Fe is not a valid 
component, Fe(2) and Fe(3) are. HP2 will issue a warning when a component is present in the 
aqueous phase during the geochemical calculations (with PHREEQC), but is not transported (i.e., 
when it is not defined as a component in the HP2/3 Components and Database Pathway dialog 
windows; Fig. 3). 
 
2.1.4. HP2/3 Definitions  
 
The phreeqc.in file can be modified by users using the text editors in the HP2/3 Definitions 
dialog window (Fig. 4). The HP2/3 Definitions dialog window has five pages that can be 
selected in the top left corner (List of Pages). The first four pages are four text editors using 
which one can edit: 

(1) Additions to the Thermodynamic Database (section 2.1.4.1.),  
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(2) Definitions of Solution Compositions (section 2.1.4.2.),  
(3) Geochemical Model (section 2.1.4.3.), and 
(4) Additional Output (section 2.1.4.4.) 

The fifth page (5 - Database Viewer) displays the selected database (e.g., PHREEQC.DAT) (Fig. 
4). 
 

 
 

Figure 4. The HP2/3 Definitions dialog window (with a displayed Database Viewer). 
 

The section Keywords (double-click to insert) (bottom left part) offers the most commonly 
used PHREEQC Keywords that are used in the four PHREEQC editors. The Keywords are 
hierarchically organized in a tree-like structure in seven main groups: Solution Definition, 
Geochemical Model, Output, Chemical/Physical Reaction, Database, Advanced, and 
Miscellaneous. A single click opens a particular tree subsection, a double click copies the 
selected keyword to the Editor Window. 
 
 

2.1.4.1. Additions to Thermodynamic Database 
 
Additional thermodynamic definitions can be added to the phreeqc.in file (not to the 
thermodynamic database file itsel) using the editor Additions to Thermodynamic Database in 
the HP2/3 Definitions dialog window (Fig. 4). Typical PHREEQC data blocks used here are 
(found under the Database group of the Keywords): 
 

• SOLUTION_MASTER_SPECIES 
• SOLUTION_SPECIES 
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• PHASES 
• EXCHANGE_MASTER_SPECIES 
• EXCHANGE_SPECIES 
• SURFACE_MASTER_SPECIES 
• SURFACE_SPECIES 
• RATES 

 
Users are referred to the PHREEQC-2 manual [Parkhurst and Appelo, 1999] for the conventions 
used for the input of thermodynamic data. An example of "Additions to Thermodynamic 
Database" is shown in Figure 5, in which three SOLUTION_MASTER_SPECIES (U, S, and P),  
7 SOLUTION_SPECIES (PO4

3-, SO4
2-, UO2

2+, CaPO4
-, CaHPO4, (UO2)(OH)+, and (UO2)2 

(OH)2
2+, and 2 PHASES (gypsum and calcite) are defined. 

 

 
 

Figure 5. The HP2 Definitions - Additions to Thermodynamic Database dialog window. 
 
2.1.4.2. Definitions of Solution Compositions 

 
Compositions of the initial and boundary solutions are defined using the editor Definitions of 
Solution Compositions (Fig. 6) in the HP2/3 Definitions dialog window. Typical PHREEQC 
data blocks are SOLUTION and SOLUTION_SPREAD. The solution number refers to the 
solution composition numbers of the initial and boundary solutions defined in the Hydrus GUI.  
 
A following solution composition numbering is used throughout this manual: 
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• Numbers 1001 – 2000: to define initial solutions for the mobile water phase.  
• Numbers 2001 – 3000: to define initial solutions for the immobile water phase. 
• Numbers 3001 – 4000: to define boundary solutions 

 
Note that these numbers should all be larger than the maximum number of FE nodes. Thus if the 
number of FE nodes is 10,000, numbers higher than 10,000 should be used to define the solution 
compositions otherwise these elements will be linked to a specific FE node. 
 
The initial conditions (spatial distribution of solution composition) are then defined directly 
using the solution composition numbers. Similarly, boundary conditions are defined using the 
solution composition numbers. 
 
An example of a solution composition defined using concentrations of various components (i.e., 
Ca, C, U, P, S, and Fe) and in equilibrium with two phases (i.e., gypsum and calcite) is shown in 
Figure 6. 
 

 
 

Figure 6. The HP2 Definitions - Definitions of Solution Compositions dialog window. 
 
 
 2.1.4.3. Geochemical Model 

 
The definition of the geochemical model is done using the editor Geochemical Model (Fig. 7) in 
the HP2/3 Definitions dialog window and it typically involves the following PHREEQC data 
blocks: 
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• EXCHANGE 
• EQUILIBRIUM_PHASES 
• SURFACE 
• KINETICS 
• SOLID_SOLUTIONS 

 
The numbering of geochemical keywords must either refer to the node numbers, such as 
 
 EXCHANGE 1-102 
 
or to a particular material as defined using the  HYDRUS GUI, such as 
  
 EXCHANGE 1001 
   -material 1 
 
While in the former case, if the material distribution is changed, the user must change the 
numbering of the geochemical model as well, in the latter case, there is no need for that. Note 
that the exchanger number for the latter case should again be larger than the number of FE nodes. 
 
Figure 7 shows an example of the Geochemical Model, in which a pure phase assemblage with 
three minerals  (gypsum, calcite, and O2) are defined in nodes 1 through 202 using the data block 
EQUILIBRIUM_PHASES. Cation exchange sites (EXCHANGE) with the cation exchange capacity X of 
0.0011 mol/kg and with exchange sites in equilibrium with the solution composition 1001 are 
defined are also defined. 
 

  
 

Figure 7. The HP2 Definitions - Geochemical Model dialog window. 
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Additionally, the following two lines 
  
 reactive_transport  
   -dimension 2 
 
indicating to the PHREEQC part of the computational module that the application is two-
dimensional, should be written into this window. These two lines could be written to any part of 
the PHREEQC.in file, but we recommend to place them here. 
 
Using the commands at the bottom of the window (Add: Exchange, Surface, Equilibrium Phases, 
and Kinetics), one can enter the Keyword for a particular process and a template, guiding users 
how to define a particular process. 

 
 2.1.4.4. Additional Output 
 
The user can define additional output using the editor Additional Output (Fig. 8) in the HP2/3 
Definitions dialog window by using the PHREEQC data blocks SELECTED_OUTPUT and 
USER_PUNCH.  
 
Standard output in HP2 is limited to the concentration of the components. In addition, depending 
on the options selected in the HP2/3 – Print and Punch Control dialog window (Fig. 13), a 
number of output files is created. HP2 specific output files (with the file name variable.hpo) 
have the same binary structure as other HYDRUS output files, such as h.out or concx.out and can 
be displayed using the GUI. Example shown in Figure 8 requests output for two mineral phases 
calcite and gypsum, and Na+ and Ca2+ concentrations at the cation exchange site X. 

 

 
 

Figure 8. The HP2 Definitions - Additional Output dialog window. 
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2.1.5. Solute Transport Parameters  
 
The standard structure of HYDRUS input parameters is preserved also for the HP2 transport 
module. The input parameters for individual components are described below. Figure 9 shows 
the Solute Transport Parameters dialog window, in which both soil-specific and solute-
specific (identified by their component names) transport parameters are specified. Note that the 
molecular diffusion coefficient in the liquid (Diffus.W.) and gas (Diffus.G.) phases [LT-2] are the 
only solute-specific parameters. Fig. 13). A standard definition of a HP2 transport problem 
requires equal molecular diffusion coefficients for all components (see Jacques and Šimůnek, 
2005). However, when a project is defined with no equilibrium aqueous complexation reactions 
and charged species, different molecular diffusion coefficients can be used. 
 

 
 

Figure 9. The Solute Transport Parameters dialog window. 
 

Table 1. Soil specific solute transport parameters. 
 

Parameter Notation Description 
Bulk. D. ρ Bulk density [M/L3] 
Disp.L. λL Longitudinal dispersivity [L] 
Disp.T. λT Transverse dispersivity [L] 

Mass Tr. α Mass transfer coefficient describing the rate of exchange between the 
mobile and immobile water contents [T-1]. This parameters is used only 
when the dual-porosity solute transport model is used. Set equal to zero 
when this model is not used. 

ThImob. θim Immobile water content when the dual-porosity solute transport model 
is used. Set equal to zero when this model is not used. 
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2.1.6. Solute Reaction Parameters  
 
All reaction parameters are specified in the PHREEQC.in input file (using PHREEQC specific 
text editors) and thus the Reaction Parameters dialog window (Fig. 10) is not used to specify 
the reaction parameters (that part of the window is disabled), but only to assign Solution 
Compositions to boundaries with constant water flow boundary conditions. Solution 
Compositions assigned to boundaries with time-variable water flow boundary conditions are 
given in the Variable Boundary Conditions window. Solution composition 3001 is used as the 
boundary condition in the example shown in Figure 10. 
 

 
 

Figure 10. The Reaction Parameters for Solute -1 dialog window. 
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2.1.7. Initial and Boundary Conditions 
 
Solution composition numbers (e.g., 1001) defined in Definitions of Solution Compositions 
window (Fig. 6) are used to assign different solution compositions to different parts of the 
transport domain as initial conditions (Fig. 11), similarly as other initial conditions. Solution 
composition numbers used to assign solute transport initial conditions must correspond to the 
solution composition numbers defined in phreeqc.in. 
 
 

 
 

Figure 11. The "Initial Conditions" part of Data Tab of the Navigator Bar for the HP2 module. 
 
Solution composition numbers (e.g., 1001) defined in Definitions of Solution Compositions 
window (Fig. 6) are similarly used to assign different solution compositions to different 
boundaries as boundary conditions. For boundaries with constant water flow conditions, solution 
composition numbers are specified in the Reaction Parameters dialog window (Fig. 10). For 
boundaries with time-variable water flow conditions, solution composition numbers are specified 
in the Time Variable Boundary Conditions dialog window (Fig. 12). 
 

 
 

Figure 12. The HP2-related part of the Time-Variable Boundary Conditions dialog window. 
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2.1.8. HP2 Print and Punch Controls 
 
The HP2 Print and Punch Controls dialog window (Fig. 13) allows users to specify variables 
(i.e., water, temperature, pH, pe, ionic strength, alkalinity, charge balance, and percent error), 
times (Print Times), and locations (Observation Nodes), for which output should be provided. 
The information in this dialog should be self-explanatory. More information is provided in the 
help file and in the user manual of the HP1 program [Jacques and Simunek, 2010]. 

 

 
 

Figure 13. The HP2 Print and Punch Controls dialog window. 
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2.2. Post-Processing 
 
2.2.1. Results – Graphical Display 
 
The output for the HP2 module is similar as the output for the standard HYDRUS module and for 
standard variables, such as pressure head, water contents, and so on. Multiple variables can be 
displayed in the View window (Figure 14). Main components defined in the HP2/3 Components 
and Database Pathway window (Fig. 3), variables selected in the HP2 Print and Punch 
Controls dialog window (Fig. 12), and variables specified in the Additional Output (Fig. 8) of 
the HP2/3 Definitions dialog window (Fig. 4) can be displayed this way.  
 
Figure 14 below shows the "Results - Graphical Display" part of Data Tab of the Navigator Bar 
for the Leaching of the Uranium Tailings example given below (Section 4.5). From the HP2 
variables, first seven are the main components (Total_H, Total_O, Ca, C, U, P, S, and Fe) 
defined in the HP2/3 Components and Database Pathway window (Fig. 3), the next two (pH 
and pe) are variables selected in the HP2 Print and Punch Controls dialog window (Fig. 12), 
and finally the last four (calcite, gypsum, ratherfordine and siderite) are mineral phases specified 
in the Additional Output (Fig. 8) of the HP2/3 Definitions dialog window. 

 

 
 

Figure 14. The "Results - Graphical Display" part of Data Tab of the Navigator Bar for the HP2 
module. 

 
2.2.2. Results – Other Information 
 
The content of the PHREEQC.out output file is described in detail in the PHREEQC user manual 
[Parkhurst and Appelo, 1999]. 
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3. Example Problems 
 
The HP2 module supplements the standard HYDRUS program, which includes variably-saturated 
water flow and solute transport model, and thus the water flow, solute transport and colloids 
transport parts of the model have been tested earlier. Therefore, verification and test examples 
presented in this section concentrate on the demonstration of the new features of the model. 
 
Table 2 shows selected two-dimensional examples that can be downloaded from the HYDRUS 
(HP2) website. Some of these examples are discussed in detail in the HP1 manuals [Jacques and 
Šimůnek, 2005, 2010]. Others are described in detail in Section 4 together with detailed step-by-
step instructions how to develop them using the HYDRUS GUI. We will be continuously 
expanding this list of examples and tutorials, depending on users needs and interests. 
 

Table 2. List of test examples for the HP2 module. 
 

Name Flow+ Description 
 
Verification examples that can be downloaded from the HYDRUS website 
 
2D-EQCL SS Physical equilibrium transport of chloride (verification problem 1) 
2D-NEQCL SS Physical nonequilibrium transport of chloride (verification problem 

1) 
2D-TransCl T Transient physical nonequilibrium transport (verification problem 2) 
2D-TransCla T Transient equilibrium transport (verification problem 2) 
2D-STAds SS Steady state transport of a nonlinearly adsorbing contaminant 

(verification problem 3) 
2D-STDecay SS Steady state transport of a nonlinearly adsorbing and decaying 

contaminant (verification problem 4) 
2D-SeasonChain T First-order decay chain of nonlinearly adsorbing contaminants 

during unsteady flow (verification problem 5) 
2D-CatExch SS Transport with multiple cation exchange (verification problem 6) 
2D-MinDis SS Transport with mineral dissolution 
2D-MCatExch  Heavy metal transport in a medium with a pH-dependent cation 

exchange complex 
 
Verification examples that are described below in this report and that can also be 
downloaded from the HYDRUS website 
 
2D-CEC-1 SS Example 1: Transport and Cation Exchange (Single Pulse) 
2D-CEC-1 SS Example 2: Transport and Cation Exchange (Multiple Pulses) 
2D-HP1-1 SS Example 3: Transport and Dissolution of Gypsum and Calcite 
2D-CEC-Furrow T Example 4: Furrow Irrigation with cation Exchange 
UTailing T Example 5: Leaching of the Uranium Tailings 
+SS - steady-state water flow, T - transient water flow 
 



 28 



 29 

4. Step-by-Step Instructions for Selected HP2 Examples 
 
 
The purpose of these examples is to documents how to use the version 1.0 of HP2. The following 
tutorials are described in this report: 
 

1. Example 1: Transport and Cation Exchange (Single Pulse) 
2. Example 2: Transport and Cation Exchange (Multiple Pulses) 
3. Example 3: Transport and Dissolution of Gypsum and Calcite 
4. Example 4: Furrow Irrigation with cation Exchange 
5. Example 5: Leaching of the Uranium Tailings 

 
While the first three examples involve one-dimensional steady-state water flow, examples 4 and 
5 involve transient two-dimensional water flow. Cation exchange is the main chemical process in 
examples 1, 2, and 4. Precipitation/dissolution reactions are the main chemical processes in 
examples 3 and 5. Each of these examples can be easily further modified to include additional 
chemical processes. Only simple structural FE-Meshes are used in all examples. 
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4.1. Example 1: Transport and Cation Exchange (Single Pulse) 
 

4.1.1.  Problem Definition 
 
This example is adapted from Example 11 of the PHREEQC manual [Parkhurst and Appelo, 
1999] and is also used in the HP1 manual [Jacques and Simunek, 2010]. The chemical 
composition of the effluent from an 8-cm column containing a cation exchanger is simulated in 
this example. The column initially contains a Na-K-NO3 solution in equilibrium with the cation 
exchanger. The column is flushed with three pore volumes of a CaCl2 solution. Ca, K and Na are 
at all times in equilibrium with the exchanger. The simulation is run for one day; the fluid flux 
density is equal to 24 cm/d (0.00027777 cm/s).   
 
The column is discretized vertically into 40 finite elements and horizontally into two columns 
(i.e., 82 nodes). The example assumes that the same solution is initially associated with each 
node. This is, in general, not necessary and different solutions can be defined for each node. The 
solution, however, must be specified for each node. The exchanger can be defined also for each 
node, but it does not have to be (this depends on the specific conceptual geochemical model for a 
project). In this example we use the same exchanger composition at all nodes. 
 
The initial Na-K-NO3 solution is made by using 1 x 10-3 M NaNO3 and 2 x 10-4 M KNO3 M. The 
inflowing CaCl2 solution has a concentration of 6 x 10-4 M. Both solutions were prepared under 
oxidizing conditions (in equilibrium with the partial pressure of oxygen in the atmosphere). The 
amount of exchange sites (X) is 1.1 meq/1 dm³ soil. The log K constants for the exchange 
reactions are defined in the PHREEQC.dat database and do not have to be therefore specified at 
the input. 
 
This project is available in the Project Group ‘2D_Tests’ and is named 2D-CEC-1. In this 
example, only the outflow concentrations of Cl, Ca, Na, and K are of interest. 
 

4.1.2.  Input 
 
Project Manager (File->Project Manager) 

Button "New" 
 
New Project (or File->New) 

Name: 2D-CEC-1 
Description: Transport and Cation Exchange, single pulse 
Working Directory: Temporary – exists only when the project is open 
Button "Next" 

 
Domain Type and Units (Edit->Domain Geometry->Domain Type and Units) 

Type of Geometry: 2D - Simple 
2D-Domain Options: 2D - Vertical Plane XZ 
Units: cm 
Initial Workspace: X-Min=0, X-Max=1, Z-Min=0, Z-Max=8 cm  
Button "Next" 
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Regular Domain Definition (Edit->Domain Geometry->Simple Domain) 

Dimensions: Lx = 1 cm, Lz = 8 cm, Slope α = 0 
Button "Next" 
 

Main Processes (Edit->Flow and Transport Parameters->Main Processes) 
Uncheck "Water Flow" (Note: this is a steady-state water flow) 
Check "Solute Transport"  
Button "Next" 
 

Time Information (Edit->Flow and Transport Parameters->Time Information) 
Time Units:   Seconds 
Final Time:   86400 (s) 
Initial Time Step:  180 (s) 
Minimum Time Step: 180 (s) 
Maximum Time Step: 180 (s)  (Note: we use the constant time step to have the same 

conditions as in the original comparable PHREEQC 
calculations; in general, there is no need to have constant 
time steps in HP2). 

Button "Next" 
 

Output Information (Edit->Flow and Transport Parameters->Output Information) 
Print Options: 
Check T-Level Information 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 12 
Update 
Default 
Button "Next" 
 

HP2/3 – Print and Punch Controls 
Button "Next 
 

Water Flow - Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Iteration Criteria) 

Leave default values except: 
Lower Time Step Multiplication Factor: 1 (Note: the constant time step) 
Button "Next" 

 
Water Flow - Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Hydraulic Properties Model) 

Leave default values as follows: 
Radio button - van Genuchten-Mualem 
Radio button - No hysteresis 
Button "Next" 
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Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Soil Hydraulic Parameters) 

Catalog of Soil Hydraulic Properties: Loam 
Qs: 1 (Note: to have the same conditions as in the original comparable PHREEQC 

calculations) 
Ks: 0.00027777 (cm/s) 
Button "Next" 

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Number of Solutes: 7 
Select “HP2 (HYDRUS+PHREEQC)” 
Button "Next" 

 
Solute Transport – HP2/3 Components and Database Pathway 
 Database Pathway: Leave the default PHREEQC database and default path 
 Add seven components: Total_O, Total_H, Na, K, Ca, Cl, N(5) 

Leave the checkbox on: "Create the PHREEQC.IN file Using HYDRUS GUI" 
Leave the radio button on: In Solution Composition 

 Button "Next" 
 
Solute Transport – HP2/3 Definitions 
 
 Definitions of Solution Composition 
 

Define the initial condition 1001:  
• K-Na-N(5) solution 
• use pH to charge balance the solution 
• Adapt the concentration of O(0) to be in equilibrium with the partial 

pressure of oxygen in the atmosphere 
 
Define the boundary condition 3001:  

• Ca-Cl solution  
• Use pH to charge balance the solution 
• Adapt the concentration of O(0) to be in equilibrium with the partial 

pressure of oxygen in the atmosphere 
 

Solution 1001 Initial condition 
 -units mmol/kgw 
 pH 7 charge 
 Na 1 
 K 0.2 
 N(5) 1.2 
 O(0) 1 O2(g) -0.68 
 
Solution 3001 Boundary solution 
 -units mmol/kgw 
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 pH 7 charge 
 Ca 0.6 
 Cl 1.2 
 O(0) 1 O2(g) -0.68 

 
 Geochemical Model 
 

Define for each node (82 nodes) the geochemical model, i.e., the cation exchange 
assemblage X (0.0011 moles/1000 cm³) and equilibrate it with the initial solution 
(solution 1001). Note that since no equilibrium constants for cation exchange are 
specified, they are taken from the PHREEQC.dat database. Additionally, indicate 
to PHREEQC, that this is a two-dimensional project. 
 

EXCHANGE 1-82 @Layer 1@ 
 X 0.0011 
 -equilibrate with solution 1001 
 
reactive_transport 
-dimension 2 

 
Button "OK" 
 

Additional Output 
 

Since output is required only for the total concentrations and such output is 
available in the automatically generated file obs_node.out, there is no need to 
define additional output. If we want to have spatial profiles of cation exchange 
concentrations, then we can use the following command: 
 

selected_output 
 -molalities NaX KX CaX2  

 
Button "Next" 

 
Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Transport Parameters) 

Leave default values 
Bulk Density = 1.5 cm3/g 
Longitudinal Dispersivity, Disp.L = 0.2 cm 
Transverse Dispersivity, Disp.T = 0.02 cm 
Molecular Diffusion Coefficient for Liquid Phase, Diffus.W.=0 
Button "Next" 

 
Solute Transport - Reaction Parameters (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solute Reaction Parameters)  

Boundary Condition: cBnd1=3001 (the solution composition number for the upper 
boundary condition) 
Button "Next" 
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Rectangular Domain Spatial Discretization (Edit->FE-Mesh->FE-Mesh Parameters) 
 Horizontal Discretization in X 
  Count = 1 
 Entries in the x column: 0, 1 
 Horizontal Discretization in Z 
  Count = 41 
 Default Entries in the z column 

Button "Next"  
 

 
 
Default Domain Properties (Edit->Domain Properties->Default Domain Properties) 
 Set Code on the first and last row to 1. 
 Set the initial pressure head, h, for all nodes equal to zero. 
 Set the temperature, Temp, to 25. 
 Set the solution concentration, sc, to 1001. 

Button "Next"  
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Observation Nodes  

Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert-
>Domain Properties->Observation Nodes). 
Click on the Insert Observation Node ( ) command on the Edit Bar 
and insert one observation nodes in the very bottom left node. 

 
Run Calculations 

Click the Calculate Current Project command ( ) on the Toolbar (or Calculation-
>Calculate Current Project)  
 (Execution time on 3 GHz PC – 7 s) 
 

Note: This exercise will produce following warnings: "Master species N(3) is present in solution 
n but is not transported.". The same warning occurs for N(0). N(3) and N(0) are two secondary 
master species from the primary master species N. Only the secondary master species N(5) was 
defined as a component to be transported (Solute Transport – HP2 Components). HP2, however, 
checks if all components, which are present during the geochemical calculations, are defined in 
the transport model. If not, a warning message is generated. In our example, the concentrations 
of the components N(0) and N(3) are very low under the prevailing oxidizing conditions. 
Therefore, they can be neglected in the transport problem. If you want to avoid these warnings, 
you have to either include N(0) and N(3) as components to be transported or define an alternative 
primary master species representing nitrate (such as Nit-) using 
SOLUTION_MASTER_SPECIES and SOLUTION_SPECIES. 
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4.1.3. Output 
 
When the program finishes, explore the output files. Display results for “Observation Points”. 
Figure below can be created using the Observation Points (All Concentration) information 
(information from the obs_nod.out output file). 
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Figure 15. Outflow concentrations of Cl, Ca, Na and K for the single-pulse cation exchange 

example. 
 

The results for this example are shown in Figure 15. The concentrations of node 41 (the last 
node) are plotted against time. Chloride is a conservative solute and arrives in the effluent at 
about one pore volume. The sodium initially present in the column exchanges with the incoming 
calcium and is eluted as long as the exchanger contains sodium. The midpoint of the 
breakthrough curve for sodium occurs at about 1.5 pore volumes. Because potassium exchanges 
more strongly than sodium (larger log K in the exchange reaction; note that log K for individual 
pairs of cations are defined in the database and therefore did not have to be specified), potassium 
is released after sodium. Finally, when all of the potassium has been released, the concentration 
of calcium increases to a steady-state value equal to the concentration of the applied solution. 
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4.2. Example 2: Transport and Cation Exchange (Multiple Pulses) 
 

This project is available in the Project Group ‘2D_Tests’ and is named 2D-CEC-2. 
 
4.2.1. Problem Definition 

 
This example is the same as Example 1, except that time variable concentrations are applied at 
the soil surface. The following sequence of pulses is applied at the top boundary: 
 

0 – 8 hr: 6 x 10-4 M CaCl2 
8 – 18 hr: 5 x 10-6 M CaCl2, 1 x 10-3 M NaNO3, and 2 x 10-4 M KNO3 
18 – 38 hr: 6 x 10-4 M CaCl2 
38 – 60 hr: 5 x 10-6 M CaCl2, 1 x 10-3 M NaNO3, and 8 x 10-4 M KNO3 

 
4.2.2.  Input 

 
Project Manager (File->Project Manager) 

Click on 2D-CEC-1 
Button "Copy" 
New Name: 2D-CEC-2 
Description: Transport and Cation Exchange, multiple pulses 
Button "OK", "Open" 
 

Time Information (Edit->Flow and Transport Parameters->Time Information) 
Time Units:   hours 
Final Time:   60 (h) 
Initial Time Step:  0.1 (h) 
Minimum Time Step: 0.1 (h) 
Maximum Time Step: 0.1 (h) 
Check Time-Variable Boundary Conditions 
Number of Time-Variable Boundary Records: 4 
Button "Next" 
 

Output Information (Edit->Flow and Transport Parameters->Output Information) 
Number of Print Times: 12 
Default 
Button "Next" 
 

HP2/3 – Print and Punch Controls 
Button "Next" 

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Button "Next" 
 
Solute Transport – HP2 Components and Database Pathway 
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 Button "Next" 
 
Solute Transport – HP2/3 Definitions 
 
 Definitions of Solution Composition 
 

Add additional solution compositions for boundary conditions with numbers 3002 
and 3003. 
 

Solution 3002 Boundary solution 
 -units mmol/kgw 
 ph 7 charge 
 Na 1 
 K 0.2 
 N(5) 1.2 
 Ca 5E-3 
 Cl 1E-2 
 O(0) 1 O2(g) -0.68 
 
Solution 3003 Boundary solution 
 -units mmol/kgw 
 ph 7 charge 
 Na 1 
 K 0.8 
 N(5) 1.8 
 Ca 5E-3 
 Cl 1E-2 
 O(0) 1 O2(g) -0.68 

 
Button "OK" 

Button "Next" 
 

Time-Variable Boundary Conditions (Edit->Flow and Transport Parameters->Variable 
Boundary Conditions) 

Fill in the time, and the solution composition numbers for the top boundary 
 
Time cValue1 
8 3001 
18 3002 
38 3001 
60 3003  

 
Observation Nodes  

Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert-
>Domain Properties->Observation Nodes). 
Click on the Insert Observation Node ( ) command on the Edit Bar 
and insert observation nodes on the left column at depths of 2, 4, 6, and 8 cm. 

 
Run Calculations 
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Click the Calculate Current Project command ( ) on the Toolbar (or Calculation-
>Calculate Current Project)  
(Execution time on 3 GHz PC – 7 s) 
 

4.2.3. Output 
 
Figure 16 gives the K concentration at different depths in the profile. Figure 17 shows the 
outflow concentration. The first pulse is identical to the single pulse project. Then additional 
solute pulses of different solution compositions will restart the cation exchange process 
depending on the incoming solution composition. 
 

 
 

Figure 16. Time series of K concentrations at four depths for the multiple-pulse cation exchange 
example. 

  
Figure 17. Outflow concentrations for the multiple-pulse cation exchange example. 
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4.3. Example 3: Transport and Dissolution of Gypsum and Calcite 
 
This project is available in the Project Group ‘2D_Tests’ and is named 2D-HP1-1. 
 

4.3.1. Problem Definition 
 
Sulfate-free water is infiltrated in a 50-cm long homogeneous soil column under steady-state 
saturated flow conditions. The reactive minerals present in the soil column are calcite (CaCO3) 
and gypsum (CaSO4.2H2O), both at a concentration of 2.176 x 10-2 mmol/kg soil.  
 
Physical properties of the soil column are as follows: the porosity of 0.35, the saturated hydraulic 
conductivity of 10 cm/day, the bulk density of 1.8 g/cm³, and the dispersivity of 1 cm. 
 
The input solution contains 1 mM CaCl2 and is in equilibrium with the atmospheric partial 
pressure of oxygen and carbon dioxide. The initial soil solution is in equilibrium with the 
reactive minerals and with the atmospheric partial pressure of oxygen. As a result of these 
equilibria, the initial soil solution contains only Ca and oxidized components of S and C. 
 
Calculate the movement of dissolution fronts of calcite and gypsum over a period of 2.5 days. 
 

4.3.2. Input 
 
Project Manager (File->Project Manager) 
 Button "New" 
 
New Project (or File->New) 
 Name: 2D-HP1-1 
 Description: "Dissolution of calcite and gypsum in the soil profile" 
 Working Directory: Temporary – exists only when the project is open 

Button Next" 
 
Domain Type and Units (Edit->Domain Geometry->Domain Type and Units) 

Type of Geometry: 2D - Simple 
2D-Domain Options: 2D - Vertical Plane XZ 
Units: cm 
Initial Workspace: X-Min=0, X-Max=1, Z-Min=0, Z-Max=5 cm 
Button "Next" 

 
Regular Domain Definition (Edit->Domain Geometry->Simple Domain) 

Dimensions: Lx = 1 cm, Lz = 50 cm, Slope α = 0 
Button "Next" 

 
Main Processes (Edit->Flow and Transport Parameters->Main Processes) 

Uncheck "Water Flow" (Note: this is a steady-state water flow) 
Check "Solute Transport"  
Button "Next" 
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Time Information (Edit->Flow and Transport Parameters->Time Information) 
 Time Units: Days 
 Final Time: 2.5 (d) 
 Initial Time Step: .001 (d) 
 Maximum Time Step: 0.05 
 Button "Next" 
 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Uncheck T-Level Information 
Check Interval Output 
Time Interval: 0.025 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 5 
Update 
Default 
Button "Next" 

 
HP2/3 – Print and Punch Controls 
 Check: "Make GNUplot Templates" 

This allows easy visualization of time series and profile data for variables, which are 
defined in the SELECTED_OUTPUT section below in this dialog window and also 
defined later in the Additional Output part of the Solute Transport – HP2 
Definitions dialog. 

Button "Next" 
 
Water Flow – Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Iteration Criteria) 

Leave default values 
Button "Next" 

 
Water Flow – Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Hydraulic Properties Model) 

Leave default values as follows: 
Radio button - van Genuchten-Mualem 
Button "Next" 

 
Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Soil Hydraulic Parameters) 

Catalog of Soil Hydraulic Properties: Loam 
 Qs: 0.35 
 Ks: 10 (cm/d) 
 Button "Next" 
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Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Number of Solutes: 6 
Select “HP2 (HYDRUS+PHREEQC)” 
Button "Next" 

 
Solute Transport – HP1 Components and Database Pathway 
 Database Pathway: Leave the default PHREEQC database and default path 
 Six Components: Total_O, Total_H, Ca, C(4), Cl, S(6) 
 

Note: Redox sensitive components should be entered with the secondary master species, 
i.e., with their valence state between brackets. The primary master species of a redox 
sensitive component, i.e., the element name without a valence state, is not recognized as a 
component to be transported. Therefore, the primary master species C cannot be entered 
here; one has to enter either C(4) or C(-4). Also S is not allowed; one has to enter either 
S(6) or S(-2). Note that the HYDRUS GUI will not check if a correct master species is 
entered. Because the redox potential is high in this example (a high partial pressure of 
oxygen), the secondary master species C(-4) and S(-2) are not considered. 

 
 Check: "Create PHREEQC.IN file using HYDRUS GUI" 
 Button "Next" 
 
Solute Transport – HP2/3 Definitions 
 
 Definitions of Solution Composition 
 

Define the initial condition, i.e., the solution composition of water in the soil 
column, with the identifier 1001:  

• Pure water 
• Bring it in equilibrium with gypsum, calcite, and O(0), to be in 

equilibrium with the partial pressure of oxygen in the atmosphere 
 
Define the boundary condition, i.e., the solution composition of water entering the 
soil column, with the identifier 3001:  

• Ca-Cl solution  
• Use pH to obtain the charge balance of the solution 
• Adapt the concentration of O(0) and C(4) to be in equilibrium with the 

atmospheric partial pressure of oxygen and carbon dioxide, respectively 
 

solution 1001 
equilibrium_phases 1001 
gypsum 
calcite 
O2(g) -0.68 
save solution 1001 
end 

 
solution 3001 
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-units mmol/kgw 
pH 7 charge 
Cl 2 
Ca 1 
O(0) 1 O2(g) -0.68 
C(4) 1 CO2(g) -3.5 

 
  Button "OK" 
 
 Geochemical Model 
 

Define for each node the geochemical model. Note that the initial amount of a 
mineral must be defined as mol/1 dm³ soil (i.e., 2.176 x 10-5 mol/kg soil * 1.8 
kg/1 dm³). Additionally, indicate to PHREEQC, that this is a two-dimensional 
project. 

 
Equilibrium_phases 1-101 
gypsum 0 3.9E-5 
calcite 0 3.9E-5 
O2(g) -0.68 

 
reactive_transport 
-dimension 2 

 
  Button "OK" 
 
 Additional Output 
 

Define the additional output to be written to selected output files.  
 
selected_output 
 -totals Ca Mg Cl S C 
 -equilibrium_phases gypsum calcite 

 
 Button "OK" 

Button "Next" 
 

Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Transport Parameters) 

Bulk D. = 1.8 (g/cm³) 
Longitudinal Dispersivity, Disp.L = 1 cm 
Transverse Dispersivity, Disp.T = 0.1 cm 
Molecular Diffusion Coefficient for Liquid Phase, Diffus.W.=0 
Button "Next" 

 
Solute Transport - Reaction Parameters (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solute Reaction Parameters)  

Boundary Condition: cBnd1=3001 (the solution composition number for the upper 
boundary condition) 
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Button "Next" 
 
Rectangular Domain Spatial Discretization (Edit->FE-Mesh->FE-Mesh Parameters) 
 Horizontal Discretization in X 
  Count = 1 
 Entries in the x column: 0, 1 
 Horizontal Discretization in Z 
  Count = 101 
 Default Entries in the z column 

Button "Next"  
 
Default Domain Properties (Edit->Domain Properties->Default Domain Properties) 
 Set Code on the first and last row to 1. 
 Set the initial pressure head, h, for all nodes equal to zero. 
 Set the temperature, Temp, to 25. 
 Set the solution concentration, sc, to 1001. 

Button "Next"  
 
Observation Nodes  

Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert-
>Domain Properties->Observation Nodes). 
Click on the Insert Observation Node ( ) command on the Edit Bar 
and insert observation nodes at a depth increment of 10 cm. 

 
Run Calculations 

Click the Calculate Current Project command ( ) on the Toolbar (or Calculation-
>Calculate Current Project)  
(Execution time on 3 GHz PC – 5 s) 

 
4.3.3. Output 

 
The standard HYDRUS output can be viewed using commands in the Results part of the 
Navigator Bar. Only the total concentrations of the components, which were defined in 
“Solute Transport – HP2 Components”, at the observation nodes can be viewed using 
the HYDRUS-GUI. 

 
HP2 creates a number of additional output files in the project folder. The path to the project 
folder is displayed in the Project Manager: 
 
 File -> Project Information 

Path: Gives the path to the project group folder. The path can be copied into the Windows 
Explorer to locate all project files. 

  
. 
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Following HP2 output files are created for the HP2-1 project: 
 

Createdfiles.out An ASCII text file containing a list of all files created by HP2 (in 
addition to the output files created by the HYDRUS module of 
HP2); 

Phreeqc.out An ASCII text file, which is the standard output file created by the 
PHREEQC-module in HP2 and can be viewed via the GUI: 

Results->HP2 Text Output… 
    or via the Project Navigator bar 

H3D2_2D_HP2-1.hse An ASCII text file, tab-delimited, that includes a selected output of 
all geochemical calculations in HP2 carried out before actual 
transport calculations. Inspection of this file can be done with any 
spreadsheet, such as MS Excel; 

obs_nod_chem41.out 
obs_nod_chem81.out 
obs_nod_chem121.out 
obs_nod_chem161.out 
obs_nod_chem201.out A series of ASCII files, tab-delimited, with the selected output for 

the defined observation nodes (41, 81, 121, 161, and 201) at 
specific times (every 0.025 days). Numerical values can be seen by 
opening this file in a spreadsheet, such as Excel. A single plot of 
time series at five observation nodes can be generated for each 
geochemical variable with the ts_*.plt files using the GNUPLOT 
graphical program (see below); 

ts_pH.plt  An ASCII file containing command line instructions to generate a 
plot of pH (or pe, or other variables) using GNUPLOT; 

ts_pe.plt  
ts_tot_Ca.plt  An ASCII file containing command line instructions to generate a 

plot with total concentrations of Ca (or Cl, S and C) using 
GNUPLOT;  

ts_tot_Cl.plt  
ts_tot_S.plt  
ts_tot_C.plt  
ts_eq_gypsum.plt  An ASCII file containing command line instructions to generate a 

plot with the amount of the minerals gypsum (or calcite) with 
GNUPLOT; 

ts_eq_calcite.plt  
ts_d_eq_gypsum.plt  An ASCII file containing command line instructions to generate a 

plot with the change in amount of the minerals gypsum (or calcite) 
with GNUPLOT; 

ts_d_eq_calcite.plt  
 

To view these various plots, the GNUPLOT code needs to be installed on your computer. 
GNUPLOT is freeware software that can be downloaded from http://www.gnuplot.info/. Note 
that GNUPLOT (the wgnuplot.exe program for the Windows OS) is usually, after being 
downloaded, in the gnuplot\bin folder and does not require any additional special installation. 

http://www.gnuplot.info/�
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After opening the Windows version of GNUPLOT by clicking on wgnuplot.exe, a plot can be 
directly generated by carrying out these commands: 
 
 File->Open 
 Browse to the project folder 
 Open the template file of interest (*.plt) 
 
The figure can be adapted using line commands (see tutorials on the internet). After adaptations, 
the command lines can be saved to be used later on. If you have trouble with the display of fonts, 
it is possible that the terminal on your computer is set incorrectly. In such case, type at the 
GNUPlot prompt:  
Gnuplot> set terminal "Windows" 
 
The default terminal for the plots should be Window. We illustrate here only how a plot can be 
transferred to another terminal: 
 
 Set terminal emf 
 Set output "name.emf" 
 Replot 
 Set terminal window 
 Replot 
 
A name.emf file is created in the project directory. 
 
Figure 18 shows vertical profiles of pH, total aqueous C concentration, total aqueous Ca 
concentration, total aqueous S concentration, the amount of gypsum and the amount of calcite at 
selected print times during dissolution of calcite and gypsum. Figure 19 shows the time series of 
pH, total aqueous C concentration, total aqueous Ca concentration, total aqueous S concentration, 
the amount of gypsum and the amount of calcite at selected observation nodes during dissolution 
of calcite and gypsum. 
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Figure 18. Vertical profiles of pH (top left), total aqueous C concentration (top right), total 
aqueous Ca concentration (middle left), total aqueous S concentration (middle right), the 

amount of gypsum (bottom left) and the amount of calcite (bottom right) at selected print times 
during dissolution of calcite and gypsum. 
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Figure 19. Time series of pH (top left), total aqueous C concentration (top right), total aqueous 

Ca concentration (middle left), total aqueous S concentration (middle right), the amount of 
gypsum (bottom left) and the amount of calcite (bottom right) at selected depths (observation 

nodes) during dissolution of calcite and gypsum. 
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4.4. Example 4: Furrow Irrigation with Cation Exchange 
 

4.4.1.  Problem Definition 
 
A furrow irrigation problem, similar to the one used in the UNSATCHEM manual, was used to 
simulate two-dimensional infiltration of gypsum saturated water into a sodic soil. The example thus 
simulates sodic soil reclamation problem and demonstrates the cation exchange feature of HP2. The 
schematic representation of the flow domain for the considered furrow irrigation together with the 
finite element mesh is presented in Figure 20. It is assumed that every other furrow is flooded with 
water and that the water level in the irrigated furrow is kept constant at a level of 6 cm. Due to 
symmetry, it is necessary to carry out the simulation only for the domain between the axis of two 
neighboring furrows. Free drainage is used as the bottom boundary condition and zero flux is 
considered on the rest of the boundary. The initial pressure head condition is -200 cm and the soil 
hydraulic properties for silt are used. 
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Figure 20. Schematic representation and finite element mesh of the flow domain for the furrow
 irrigation system for example 4. 
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The calculation was run at a constant temperature of 25 oC. The bulk density of the soil was taken as 
1.4 g cm-3 and molecular diffusion as 2 cm2day-1. Longitudinal and transverse dispersivities were 
equal to 2 and 0.2 cm, respectively. 
 
The solution composition of the water initially present in the soil profile is that of the following 
highly sodic water: CaT=1.0 MgT=0.0, NaT=5.0, KT=0.0, SO4T=3.5, ClT=0.0 mmol L-1. The cation 
exchange capacity is equal to 7.143 mmol kg-1 (10 mmol dm-3) and is divided between exchangeable 
calcium and sodium (it is equilibrated with the solution). The solution composition of the irrigation 
water was almost gypsum saturated: CaT=16.3, MgT=0.0, NaT=4.4, KT=0.0, ClT=5.0, SO4T=16.0 
mmolL-1. As a consequence of the reactions of the irrigation water with the exchanger composition, 
cation exchange was the dominant chemical processes in the soil profile. Cation exchange is treated 
as an instantaneous process in the model. 
 
 

4.4.2. Input 
 
Project Manager (File->Project Manager) 

Button "New" 
 
New Project (or File->New) 

Name: 2D-CEC-Furrow 
Description: HP2 Test: Furrow Irrigation, Transport and Cation Exchange 
Working Directory: Temporary – exists only when the project is open 
Button "Next" 

 
Domain Type and Units (Edit->Domain Geometry->Domain Type and Units) 

Type of Geometry: 2D - Simple 
2D-Domain Options: 2D - Vertical Plane XZ 
Units: cm 
Initial Workspace: X-Min=0, X-Max=100, Z-Min=0, Z-Max=100 cm  
Button "Next" 

 
Regular Domain Definition (Edit->Domain Geometry->Simple Domain) 

Dimensions: Lx = 100 cm, Lz = 100 cm, Slope α = 0 
Button "Next" 
 

Main Processes (Edit->Flow and Transport Parameters->Main Processes) 
Check "Water Flow" (Note: this is transient water flow) 
Check "Solute Transport"  
Check “HP2” 
Button "Next" 
 

Time Information (Edit->Flow and Transport Parameters->Time Information) 
Time Units:   Days 
Final Time:   5 (d) 
Initial Time Step:  0.0005 (d) 
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Minimum Time Step: 1e-05 (d) 
Maximum Time Step: 5 (d) 
Button "Next" 
 

Output Information (Edit->Flow and Transport Parameters->Output Information) 
Print Options: 
Check T-Level Information 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 8  
 
Print Times: 0.05, 0.1, 0.25, 0.5, 1, 2, 3, 5 (d) 
Button "Next" 
 

HP2/3 – Print and Punch Controls 
Number of Warnings: 5 
Button "Next 
 

Water Flow - Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Iteration Criteria) 

Leave default values 
Button "Next" 

 
Water Flow - Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Hydraulic Properties Model) 

Leave default values as follows: 
Radio button - van Genuchten-Mualem 
Radio button - No hysteresis 
Button "Next" 

 
Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Soil Hydraulic Parameters) 

Catalog of Soil Hydraulic Properties: Silt 
Button "Next" 

 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Number of Solutes: 8 
Button "Next" 

 
Solute Transport – HP2/3 Components and Database Pathway 
 Database Pathway: Leave the default PHREEQC database and default path 
 Add seven components: Total_O, Total_H, Ca, Mg, Na, K, Cl, S(6) 

Leave the checkbox on: "Create the PHREEQC.IN file Using HYDRUS GUI" 
Leave the radio button on: In Solution Composition 

 Button "Next" 



 52 

 
Solute Transport – HP2/3 Definitions 
 
 Select Definitions of Solution Composition 
 

Define the initial condition 1501:  
• Ca-Na-SO4 solution 
• use pH to charge balance the solution 
• Adapt the concentration of O(0) to be in equilibrium with the partial 

pressure of oxygen in the atmosphere 
 
Define the boundary condition 3001:  

• Ca-Na-Cl-SO4 solution  
• Use pH to charge balance the solution 
• Adapt the concentration of O(0) to be in equilibrium with the partial 

pressure of oxygen in the atmosphere 
 

Solution 1501 Initial condition 
 -units mmol/kgw 
 pH 7 charge 
 Na 5.0 
 Ca 1.0 
 Cl 0.0 
 S(6) 3.5 
 O(0) 1 O2(g) -0.68 
 
Solution 3001 Boundary solution 
 -units mmol/kgw 
 pH 7 charge 
 Ca 16.3 
 Na 4.4 
 Cl 5.0 
 S(6) 16.0 
 O(0) 1 O2(g) -0.68 

 
 Select Geochemical Model 
 

Define for each node (1170 nodes) the geochemical model, i.e., the cation 
exchange assemblage X (0.01 moles/dm³) and equilibrate it with the initial 
solution (solution 1501). Note that since no equilibrium constants for cation 
exchange are specified, they are taken from the PHREEQC.dat database. 
 

EXCHANGE 1-1170 
 X 0.01 
 -equilibrate with solution 1501 

 
Additionally, you may indicate to PHREEQC, that this is a two-dimensional 
project. However, this information will be added by default in GUI, if not 
specified manually. 
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reactive_transport 
-dimension 2 

 
 

Select Additional Output 
 

Define the additional output to be written to selected output files.  
 

selected_output 
  -equilibrium_phases gypsum calcite 
  -molalities NaX CaX2 

 
Button "Next" 

 
Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Transport Parameters) 

Leave default values 
Bulk Density = 1.4 cm3/g 
Longitudinal Dispersivity, Disp.L = 2 cm 
Transverse Dispersivity, Disp.T = 0.2 cm 
Molecular Diffusion Coefficient for Liquid Phase, Diffus.W.=2 cm2/d (for all 
components) 
Button "Next" 

 
Solute Transport - Reaction Parameters (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Solute Reaction Parameters)  

Boundary Condition: cBnd1=3001 (the solution composition number for the upper 
boundary condition) 
Button "Next" 

 
Rectangular Domain Spatial Discretization (Edit->FE-Mesh->FE-Mesh Parameters) 
 Horizontal Discretization in X 
  Count = 45 
 Entries in the x column: 0, 3, 6, 9, 12, 15, 16.5, 18, 19.5, 21, 22.5, 24, 25.5, 27, 

28.5, 30, 32, 34, 36.5, 39, 42, 46, 50, 54, 58, 61, 63.5, 66, 68, 70, 71.5, 73, 74.5, 
76, 77.5, 79, 80.5, 82, 83.5, 85, 88, 91, 94, 97, 100 

 Entries in the dz column: -15, -15, -15, -15, -15, -15, -13.5, -12, -10.5, -9, -7.5, -6, 
-4.5, -3, -1.5, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, -1.5, -3, -4.5, -6, -7.5, -9, -10.5, 
-12, -13.5, -15, -15, -15, -15, -15, -15  

 Horizontal Discretization in Z 
  Count = 26 
 Entries in z column: 100, 99, 97.5, 95.5, 93, 90, 87, 84, 81, 78, 75, 72, 69, 66, 62, 

58, 54, 50, 45, 40, 34, 28, 21, 14, 7, 0 
Button "Next"  
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Default Domain Properties (Edit->Domain Properties->Default Domain Properties) 
 Set Code on the last row to -6 (free drainage). 
 Set the initial pressure head, h, for all nodes equal to -200. 
 Set the temperature, Temp, to 25. 
 Set the solution concentration, sc, to 1501. 

Button "Next"  
 
 



 55 

 
 
Water Flow Boundary Conditions (Edit->Boundary Conditions->Water Flow) 
Click on the Boundary Conditions Tab under the View Window. 

a) Click on Zoom by Rectangle ( ) at the Toolbar (or View-> Zoom by Rectangle) and 
zoom on the left furrow. 
Select Constant Head ( ) from the Edit Bar, select bottom of the left 
furrow and 4 nodes on the side, specify 6 cm with Equilibrium from the lowest located 
nodal point. 

b) Click on View All ( ) at the Toolbar (or View->View All). 
Select Free Drainage ( ) from the Edit Bar, and select the entire bottom of 
the transport domain. 

c) On the Navigator Bar double click on Solute Transport 
Click on Display codes on the Edit Bar ( ) and check that "-1" (or "+1") is 
displayed in the furrow. This means that solution composition 1 will be applied with the 
irrigation water. 
Uncheck "Display Codes" again. 

 
Observation Nodes 
Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert->Domain 
Properties->Observation Nodes). 
Click on the Insert command on the Edit Bar and specify 5 points arbitrarily in the transport 
domain between the furrow and the bottom of the transport domain. 
 
Save  
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Save the project using the Save command ( ) on the Toolbar (or File->Save). 
 
Run Calculations 
Click the Calculate Current Project command ( ) on the Toolbar (or Calculation->Calculate 
Current Project)  
 
 

4.4.3. Output 
 
Figure 21 shows the pressure head profiles for four different times. The distribution of chloride 
concentrations (a tracer) is shown on Figure 22. 
 

  

 

 

 
 

 
 

Figure 21. Pressure head (cm) profiles at times: a) 0.1, b) 0.5, c) 1, and d) 2 days for example 4. 
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Figure 22. Chloride concentration profiles (mol L-1) at times: a) 0.1, b) 1, c) 3, and d) 5 days for 

example 4. 
 

 

 

 
Figure 23. Sodium concentration profiles (mol L-1) at times: a) 0.5, b) 1, c) 3, and d) 5 days for 

example 4. 
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Figures 23 and 24 present the liquid phase and exchangeable concentrations of sodium, respectively. 
The exchange phase concentrations reflect the changes in aqueous Na and Ca concentration. Note 
the significant lagging of the exchanger front to both the water and tracer front. Also due to the high 
nonlinearity of Na-Ca exchange, the concentration and exchange fronts are very sharp, in contrast to 
the more diffuse tracer fronts. After 5 days less than 25% of the profile has been reclaimed to 
exchangeable sodium percentage less than 15 (which has been the criteria defining the designation 
sodic soil). The selected cation exchange capacity of 10 mmol kg-1 is relatively low. Selection of a 
higher exchange capacity and associated hydraulic properties of a finer textured soil would enhance 
both the time required for infiltration, as well as quantity of water required for reclamation. 
 

 

 
 

 
 

Figure 24. Exchangeable concentrations of sodium (mol kgw-1) profiles at times: a) 0.5, b) 1, c) 3, 
and d) 5 days for example 4. 
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4.5. Example 5: Leaching of the Uranium Tailings 
 

4.5.1. Problem Definition 
 
This problem was inspired by, and is a modification of (to make it more realistic), a problem 
reported by Yeh and Tripathi [1991]. The problem considers the release and migration of 
uranium from a simplified uranium mill tailings pile towards a river. The schematic of the 
transport domain is shown in Figure 25. The mill tailings pile is located adjacent to a surface that 
slopes down to a river. The medium has the hydraulic properties of a loam with the saturated 
hydraulic conductivity of KS = 3.78 m/day. 
 

1,050 dm

240 dm

39 dm

Mill Tailing
Pile

Cauchy Flow
= 0.139 dm/day

Infiltration Rate
= 0.0139 dm/day

Dirichlet Flow
Nodes

Pumping Well

 
Figure 25 Problem Description for the Uranium Tailing Problem [Yeh and Tripathi, 1991]. 
 
The horizontal bottom of the region is impermeable. The vertical left-edge has the Dirichlet 
boundary condition (Variable Head 1) with a groundwater table 12 m above the bottom of the 
transport domain (exactly in the middle of the boundary). The top boundary (except for the mill 
tailing pile and the river) has a flux boundary condition (Variable Flux 2) with a net rainfall rate 
of 0.139 cm/day. The horizontal region on the top of the mill tailings pile is a Cauchy flow 
boundary (Variable Flux 3) with an infiltration rate of 1.39 cm/day. The nodes on the vertical 
line on the right side and the nodes on the river bottom have the Dirichlet boundary condition 
(Variable Head 1) reflecting the position of water in the river (4.5 m above the bottom of the 
transport domain). A hypothetical pumping well with a withdrawal rate of 271.58 cm2/day is 
located at (x, z) = (400, 100). The region is discretized using a structural FE mesh with 1564 
elements and 852 nodes. 
 
Table 3 lists chemical reactions and their thermodynamic equilibrium constants considered in 
this example. For reactive hydrogeochemical transport, the problem consists of eight 
components: Total H, Total O, Ca, C, uranium, sulfate, phosphate, and Fe. A total of 35 species 
and 14 minerals is defined for the problem; redox reactions were not considered. Table 3 lists 
chemical reactions involved in this example. 
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Table 3. Reaction network for the uranium tailing problem. 
 
Reaction No Log K 
Aqueous Complexation Reactions 
H2O   ⇔    H+  +  OH- (R1) -14.00 
Ca2+  +  CO3

2-   ⇔   CaCO3  (aq) (R2) 3.22 
Ca2+  +  H+  +  CO3

2-   ⇔   CaHCO3
+ (R3) 11.43 

Ca2+  +  SO4
2-   ⇔   CaSO4 (aq) (R4) 2.31 

Ca2+  +  2H+  +  PO4
3-   ⇔   CaH2PO4

+ (R5) 20.96 
Ca2+  +  PO4

3-   ⇔   CaPO4- (R6) 6.46 
Ca2+  +  H+  +  PO4

3-   ⇔   CaHPO4 (aq) (R7) 15.08 
Ca2+  +  H2O   ⇔   H+  +  CaOH+ (R8) -12.58 
Fe2+  +  SO4

2-   ⇔   FeSO4 (aq) (R9) 2.20 
Fe2+  +  H2O   ⇔   H+ + FeOH+ (R10) -9.50 
Fe2+  +  2H2O   ⇔   2H+  +  Fe(OH)2 (aq) (R11) -20.57 
Fe2+  +  3H2O   ⇔   3H+  + Fe(OH)3

- (R12) -31.00 
Fe2+  +  4H2O   ⇔   4H+  +  Fe(OH)4

2- (R13) -43.00 
UO2

2+  +  H2O   ⇔   H+  +  (UO2)(OH)+ (R14) -5.30 
2UO2

2+  +  2H2O   ⇔   2H+  +  (UO2)2(OH)2
2+ (R15) -5.68 

3UO2
2+  +  4H2O   ⇔   4H+  +  (UO2)3(OH)4

2+ (R16) -11.88 
3UO2

2+  +  5H2O   ⇔   5H+  +  (UO2)3(OH)5
+ (R17) -15.82 

4UO2
2+  +  7H2O   ⇔   7H+  +  (UO2)4(OH)7

+ (R18) -21.90 
3UO2

2+  +  7H2O   ⇔   7H+  +  (UO2)3(OH)7
- (R19) -28.34 

UO2
2+  +  CO3

2-   ⇔   (UO2)(CO3)(aq) (R20) 9.65 
UO2

2+  +  2CO3
2-   ⇔   (UO2)(CO3)2

2- (R21) 17.08 
UO2

2+  +  3CO3
2-   ⇔   (UO2)(CO3)3

4- (R22) 21.70 
2UO2

2+  +  CO3
2-  +  3H2O   ⇔   3H+  +  (UO2)2(CO3)(OH)3

- (R23) -1.18 
UO2

2+  +  SO4
2-   ⇔   (UO2)(SO4) (aq) (R24) 2.95 

UO2
2+  +  2SO4

2-   ⇔   (UO2)(SO4)2
2- (R25) 4.00 

2H+  +  UO2
2+  +  PO4

3-   ⇔   H2(UO2)(PO4)+ (R26) 23.20 
3H+  +  UO2

2+  +  PO4
3-   ⇔   H3(UO2)(PO4)2+ (R27) 22.90 

Ca2+  +  4H+  +  UO2
2+  +  2PO4

3-   ⇔   CaH4(UO2)(PO4)2
2+ (R28) 45.24 

Ca2+  +  5H+  +  UO2
2+  +  2PO4

3-   ⇔   CaH5(UO2)(PO4)2
3+ (R29) 46.00 

H+  +  CO3
2-   ⇔   HCO3

- (R30) 10.32 
2H+  +  CO3

2-   ⇔   H2CO3(aq) (R31) 16.67 
H+  +  SO4

2-   ⇔   HSO4
- (R32) 1.99 
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H+  +  PO4
3-   ⇔   HPO4

2- (R33) 12.35 
2H+  +  PO4

3-   ⇔   H2PO4
- (R34) 19.55 

3H+  +  PO4
3-   ⇔   H3PO4 (R35) 21.74 

Precipitation-Dissolution Reactions 
Ca2+  +  SO4

2-   ⇔   CaSO4(s) (R36) 4.62 
Ca2+  +  CO3

2-   ⇔   CaCO3(s) (R37) 8.48 
5Ca2+  +  3PO4

3-  +  H2O   ⇔   H+  +  Ca5(OH)(PO4)3(s) (R38) 40.47 
Fe2+  +  CO3

2-   ⇔   FeCO3(s) (R39) 10.50 
Ca2+  +  2UO2

2+  +  2PO4
3-   ⇔   Ca(UO2)2(PO4)2(s) (R40) 48.61 

4Ca2+  +  H+  +  3PO4
3-   ⇔   Ca4H(PO4)3(s) (R41) 48.20 

Ca2+  +  H+  +  PO4
3-   ⇔   CaH(PO4)(s) (R42) 19.30 

Ca2+  +  2H2O   ⇔   2H+  +  Ca(OH)2(s) (R43) -21.90 
3Fe2+  +  2PO4

3-   ⇔   Fe3(PO4)2(s) (R44) 33.30 
Fe2+  +  2H2O   ⇔   2H+  +  Fe(OH)2(s) (R45) -12.10 
UO2

2+  +  2H2O   ⇔   2H+  +  (UO2)(OH)2(s) (R46) -5.40 
UO2

2+  +  CO3
2-   ⇔   (UO2)(CO3)(s) (R47) 14.11 

Fe2+  +  2UO2
2+  +  2PO4

3-   ⇔   Fe(UO2)2(PO4)2 (s) (R48) 46.00 
H+  +  UO2

2+  +  PO4
3-   ⇔   H(UO2)(PO4)(s) (R49) 25.00 

 
The composition of the pore water in the tailings, pore water outside of the tailing pile and the 
recharge water are given in Table 4. Cauchy boundary conditions are considered on all 
boundaries where boundary conditions are specified. A total of 1000 days was simulated. 
 

Table 4. Initial and boundary compositions of recharge water and pore water in the tailings 
and regions outside of the tailing for the uranium tailing problem. 
 

Species Inside the Tailing Outside the Tailing Recharge Water 
Ca2+ 1.0 x 10-2 1.0 x 10-2 1.0 x 10-3 
CO3

2- 1.0 x 10-2 1.5 x 10-3 1.5 x 10-3 
UO2

2+ 5.0 x 10-4 1.0 x 10-7 1.0 x 10-8 
PO4

3- 1.0 x 10-6 1.0 x 10-6 1.0 x 10-6 
SO4

2- 2.0 x 10-1 2.0 x 10-2 1.0 x 0-4 
H+ 2.0 x 10-1 1.0 x 10-3 1.ox 10-3 
Fe2+ 3.5 x 10-2 1.0 x 10-7 1.0x 10-7 
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4.5.2. Input 
 
Project Manager (File->Project Manager) 
 Button "New" 
 
New Project (or File->New) 
 Name: UTailing 
 Description: " Mille Tailing Pile - transient water flow and reactive transport" 
 Working Directory: Temporary – exists only when the project is open 

Button Next" 
 
Domain Type and Units (Edit->Domain Geometry->Domain Type and Units) 

Type of Geometry: 2D - Simple 
2D-Domain Options: 2D - Vertical Plane XZ 
Units: cm 
Initial Workspace: X-Min=0, X-Max=10,500, Z-Min=0, Z-Max=2,400 cm 
Button "Next" 

 
Regular Domain Definition (Edit->Domain Geometry->Simple Domain) 

Dimensions: Lx = 10,500 cm, Lz = 2,400 cm, Slope α = 0 
Button "Next" 
 

Main Processes (Edit->Flow and Transport Parameters->Main Processes) 
Check "Water Flow"  
Check "Solute Transport"  
Check “HP2” 
Button "Next" 
 

Time Information (Edit->Flow and Transport Parameters->Time Information) 
 Time Units: Days 
 Final Time: 1,000 (d) 
 Initial Time Step: 0.0001 (d) 
 Minimum Time Step: 0.00001 (d) 
 Maximum Time Step: 500 (d) 

Check Time-Variable Boundary Conditions 
Number of Time-Variable Boundary Records: 2 

 Button "Next" 
 
Output Information (Edit->Flow and Transport Parameters->Output Information) 

Print Options: 
Uncheck T-Level Information 
Check Interval Output 
Time Interval: 1 (d) 
Check Screen Output 
Check Press Enter at the End 
Print Times: Count: 20 
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Update 
Default 
Button "Next" 

 
HP2/3 – Print and Punch Controls 
 Check: "Make GNUplot Templates" 

This allows easy visualization of time series and profile data for variables, which are 
defined in the SELECTED_OUTPUT section below in this dialog window and also 
defined later in the Additional Output part of the Solute Transport – HP2 
Definitions dialog. 

Button "Next" 
 
Water Flow – Iteration Criteria (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Iteration Criteria) 

Leave default values 
Button "Next" 

 
Water Flow – Soil Hydraulic Model (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Hydraulic Properties Model) 

Leave default values as follows: 
Radio button - van Genuchten-Mualem 
No Hysteresis 
Button "Next" 

 
Water Flow - Soil Hydraulic Parameters (Edit->Flow and Transport Parameters->Water Flow 
Parameters->Soil Hydraulic Parameters) 

Number of Materials: 2 
Catalog of Soil Hydraulic Properties: Loam (both lines) 

 Name 1: Loam 
 Name 2: Mill Tailing Pile 
 Ks: 378 (cm/d) for both materials 
 Button "Next" 
 
Solute Transport – General Info (Edit->Flow and Transport Parameters->Solute Transport 
Parameters->General Information)  

Number of Solutes: 8 
Button "Next" 

 
Solute Transport – HP1 Components and Database Pathway 

Database Pathway: Create an empty database, which only defines a few obliged master 
components, such as Alkalinity, C, E, H, H(0), H(1), O, O(-2), O(0), H+, e-, H2O, and 
CO3-2 (see below) (Database Empty) 

 Six Components: Total_O, Total_H, Ca, C, U, P, S, Fe 
Check: "Create PHREEQC.IN file using HYDRUS GUI" 

 Button "Next" 
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Database for the UTailing example: 
 
SOLUTION_MASTER_SPECIES 
Alkalinity CO3-2        1.0     50.05           50.05 
C        CO3-2          2.0     61.0173         12.0111 
E        e-             0.0     0.0             0.0 
H        H+             -1.     1.008           1.008 
H(0)     H2             0.0     1.008 
H(1)     H+             -1.     1.008 
O        H2O            0.0     16.00           16.00 
O(-2)    H2O            0.0     18.016 
O(0)     O2             0.0     16.00 
SOLUTION_SPECIES 
        H+ = H+ 
        log_k           0.0 
        -gamma    9.0    0.0 
        e- = e- 
        log_k           0.0 
        H2O = H2O 
        log_k           0.0 
        CO3-2 = CO3-2 
        log_k           0.0 
        -gamma  5.4     0.0 
        2 H+ + 2 e- = H2 
        log_k           -3.15 
        delta_h -1.759 kcal 
        2H2O = O2 + 4H+ + 4e-  
        log_k           -86.08 
        delta_h 134.79 kca   

 
Solute Transport – HP2/3 Definitions 
 
 Select Additions to Thermodynamic Database 
 

SOLUTION_MASTER_SPECIES 
    Fe       Fe+2             0     55.847          55.847 
    Ca       Ca+2             0     40.08           40.08 
    U        UO2+2          0.0     238.0290        238.0290 
    S        SO4-2          0.0     96.0616         32.064 
    P        PO4-3          2.0     30.9738         30.9738 
 
SOLUTION_SPECIES 
Ca+2 = Ca+2 
    log_k     0.0 
Fe+2 = Fe+2 
    log_k     0.0 
PO4-3 = PO4-3 
    log_k     0.0 
SO4-2 = SO4-2 
    log_k     0.0 
UO2+2 = UO2+2 
    log_k     0.0 
CO3-2 + Ca+2 = CaCO3 
    log_k     3.22 
CO3-2 + Ca+2 + H+ = CaHCO3+ 
    log_k     11.43 
Fe+2 + H2O = FeOH+ + H+ 
    log_k     -9.5 
Ca+2 + SO4-2 = CaSO4 
    log_k     2.31 
Ca+2 + 2H+ + PO4-3 = CaH2PO4+ 
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    log_k     20.96 
Ca+2 + PO4-3 = CaPO4- 
    log_k     6.46 
Ca+2 + H+ + PO4-3 = CaHPO4 
    log_k     15.08 
Fe+2 + SO4-2 = FeSO4 
    log_k     2.2 
Fe+2 + 2H2O = Fe(OH)2 + 2H+ 
    log_k     -20.57 
Fe+2 + 3H2O = Fe(OH)3- + 3H+ 
    log_k     -31 
Fe+2 + 4H2O = Fe(OH)4-2 + 4H+ 
    log_k     -43 
H2O + UO2+2 = (UO2)(OH)+ + H+ 
    log_k     -5.3 
2H2O + 2UO2+2 = (UO2)2(OH)2+2 + 2H+ 
    log_k     -5.68 
4H2O + 3UO2+2 = (UO2)3(OH)4+2 + 4H+ 
    log_k     -11.88 
5H2O + 3UO2+2 = (UO2)3(OH)5+ + 5H+ 
    log_k     -15.82 
7H2O + 4UO2+2 = (UO2)4(OH)7+ + 7H+ 
    log_k     -21.9 
7H2O + 3UO2+2 = (UO2)3(OH)7- + 7H+ 
    log_k     -28.43 
CO3-2 + UO2+2 = (UO2)(CO3) 
    log_k     9.65 
2CO3-2 + UO2+2 = (UO2)(CO3)2-2 
    log_k     17.08 
3CO3-2 + UO2+2 = (UO2)(CO3)3-4 
    log_k     21.7 
2UO2+2  +  CO3-2  +  3H2O =   (UO2)2(CO3)(OH)3- + 3H+  
    log_k     -1.18 
UO2+2  +  SO4-2 =      (UO2)(SO4)  
    log_k     2.95 
UO2+2  +  2SO4-2 =  (UO2)(SO4)2-2 
    log_k     4 
2H+  +  UO2+2  +  PO4-3 = H2(UO2)(PO4)+ 
    log_k     23.2 
3H+  +  UO2+2  +  PO4-3 = H3(UO2)(PO4)+2 
    log_k     22.9 
Ca+2  +  4H+  +  UO2+2  +  2PO4-3 =   CaH4(UO2)(PO4)2+2 
    log_k     45.24 
Ca+2  +  5H+  +  UO2+2  +  2PO4-3 =   CaH5(UO2)(PO4)2+3 
    log_k     46 
H+  +  CO3-2 =      HCO3- 
    log_k     10.32 
2H+  +  CO3-2 =   H2CO3 
    log_k     16.67 
H+  +  SO4-2 =        HSO4- 
    log_k     1.99 
H+  +  PO4-3 =        HPO4-2 
    log_k     12.35 
 
 
PHASES 
gypsum 
    CaSO4 = Ca+2  +  SO4-2       
    log_k     -4.62 
calcite 
    CaCO3 = Ca+2  +  CO3-2        
    log_k     -8.48 
Hydroxyapatite 
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     Ca5(OH)(PO4)3 + H+   = 5Ca+2  +  3PO4-3  +  H2O        
    log_k     -40.47 
Siderite 
    FeCO3 = Fe+2  +  CO3-2        
    log_k     -10.5 
Autunite 
    Ca(UO2)2(PO4)2 = Ca+2  +  2UO2+2  +  2PO4-3       
    log_k     -48.61 
Ca4H(PO4)3 
    Ca4H(PO4)3 = 4Ca+2  +  H+  +  3PO4-3  
    log_k     -48.2 
CaH(PO4) 
    CaH(PO4) = Ca+2  +  H+  +  PO4-3        
    log_k     -19.5 
Portlandite 
    Ca(OH)2 + 2H+ = Ca+2  +  2H2O   
    log_k     21.9 
Vivianite 
    Fe3(PO4)2 = 3Fe+2  +  2PO4-3      
    log_k     -33.3 
Fe(OH)2 
    Fe(OH)2 + 2H+ = Fe+2  +  2H2O 
    log_k     12.1 
beta-Schoepite 
    UO2(OH)2 + 2H+  = UO2+2 + 2H2O 
    log_k     5.4 
Rutherfordine 
    UO2CO3 = UO2+2 + CO3-2  
    log_k     -14.11 
Bassetite 
    Fe(UO2)2(PO4)2 = Fe+2 + 2UO2+2 + 2PO4-3  
    log_k     -46 
H(UO2)(PO4) 
    H(UO2)(PO4) = H+  +  UO2+2  +  PO4-3 
    log_k     -25 
O2(g) 
    O2 = O2                                                                   
    log_k           -2.960 
    delta_h -1.844 kcal 
H2(g) 
    H2 = H2                                                                   
    log_k           -3.150 
    delta_h -1.759 kcal 

 
 Select Definitions of Solution Composition 
 

Define the initial condition, i.e., the solution composition of water in the soil, with 
the identifier 1001:  

• Bring it in equilibrium with gypsum, calcite, and O(0), to be in 
equilibrium with the partial pressure of oxygen in the atmosphere 

 
Define the initial condition, i.e., the solution composition of water in the mine 
tailing, with the identifier 1002:  

• pH 2.3 
• Bring it in equilibrium with O(0), to be in equilibrium with the partial 

pressure of oxygen in the atmosphere 
• Bring it in equilibrium with gypsum and calcite 
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• High level of U (=5e-4 mol/kgw) 
 
Define the boundary condition, i.e., the solution composition of water entering the 
soil column, with the identifier 3001:  

• Ca-Cl solution  
• Use pH to obtain the charge balance of the solution 
• Adapt the concentration of O(0) and C(4) to be in equilibrium with the 

atmospheric partial pressure of oxygen and carbon dioxide, respectively 
 

solution 1001 soil 
-temp 25 
-units mol/kgw 
-pH 2 charge 
Ca 1E-2 calcite 
C 1.5E-3  
U 1E-7 
P 1E-6 
S 2E-1 gypsum 
Fe 1E-7 
O(0) 1 O2(g) -0.68 # O(0) initially in equilibrium with a partial 

pressure of oxygen of 10^-0.68 atm 
end 
 
solution 1002 mine tailing 
-temp 25 
-units mol/kgw 
-pH 2.3  
Ca 1E-2 charge 
C 1E-2  
U 5E-4 
P 1E-6  
S 2E-1   
Fe 3.5E-2  
O(0) 1 O2(g) -0.68 # O(0) initially in equilibrium with a partial 

pressure of oxygen of 10^-0.68 atm 
 
equilibrium_phases 1002 
gypsum 0 3.7E-3 
calcite 0 0 
save solution 1002 
end 
 
solution 3001 boundary condition 
-temp 25 
-units mol/kgw 
-pH 7 charge 
Ca 1E-3 
C 1.5E-3 
U 1E-8 
P 1E-6 
S 1E-4 
Fe 1E-7  

 
 Select Geochemical Model 
 

Define for each node the geochemical model. Note that the initial amount of a 
mineral must be defined as mol/1 dm³ soil. There is calcite (4.7e-4 mol/dm³ soil) 
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in the soil and gypsum  (3.7e-3 mol/dm³ soil) in the waste zone. Many other 
mineral phases (see their names below) are allowed to precipitate. Additionally, 
indicate to PHREEQC, that this is a two-dimensional project (added by default). 

 
equilibrium_phases 1001 soil 
 -material 1 
    calcite   0 4.7E-4 
    gypsum    0 0 
    Autunite  0 0 
    Bassetite 0 0 
    Ca4H(PO4)3 0 0 
    CaH(PO4)  0 0 
    Fe(OH)2   0 0 
    Hydroxyapatite 0 0 
    Portlandite 0 0 
    Rutherfordine 0 0 
    Siderite  0 0 
    Vivianite 0 0 
    H(UO2)(PO4) 0 0 
    beta-Schoepite 0 0 
 
equilibrium_phases 1002 waste zone 
 -material 2 
    calcite   0 0 
    gypsum    0 3.7E-3 
    Autunite  0 0 
    Bassetite 0 0 
    Ca4H(PO4)3 0 0 
    CaH(PO4)  0 0 
    Fe(OH)2   0 0 
    Hydroxyapatite 0 0 
    Portlandite 0 0 
    Rutherfordine 0 0 
    Siderite  0 0 
    Vivianite 0 0 
    H(UO2)(PO4) 0 0 
    beta-Schoepite 0 0 

 
   
 Select Additional Output 
 

Define the additional output to be written to selected output files.  
 

selected_output 
    -equilibrium_phases   calcite  gypsum  Rutherfordine 
                          Siderite  

 
  

Button "Next" 
 

Solute Transport - Solute Transport Parameters (Edit->Flow and Transport Parameters-
>Solute Transport Parameters->Solute Transport Parameters) 

Bulk D. = 1.5 (g/cm³) 
Longitudinal Dispersivity, Disp.L = 250 cm 
Transverse Dispersivity, Disp.T = 25 cm 
Molecular Diffusion Coefficient for Liquid Phase, Diffus.W.=0 
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Button "Next" 
 
Time-Variable Boundary Conditions* (Edit->Flow and Transport Parameters->Solute 
Transport Parameters->Variable Boundary Conditions)  

 

 

 
Button "Next" 

 
*Why are we using Time-Variable Boundary Conditions, when the fluxes and concentrations are constant in time? 
HYDRUS reports actual and cumulative water (and solute fluxes) for different boundary parts with different types 
of boundary conditions. If we select everywhere Constant BC, then we would get only one total flux integrated over 
all boundary parts. By using different boundary types, HYDRUS will report various fluxes for different boundary 
parts. 
 
Rectangular Domain Spatial Discretization (Edit->FE-Mesh->FE-Mesh Parameters) 
 Horizontal Discretization in X 
  Count = 55 
 Horizontal Discretization in Z 
  Count = 16 
 
x[cm]: 0, 250, 500, 750, 1000, 1250, 1500, 1750, 2000, 2250, 2500, 2750, 3000, 3250, 3500, 

3750, 4000, 4250, 4500, 4750, 5000, 5200, 5400, 5600, 5800, 6000, 6200, 6400, 6600, 
6800, 7000, 7200, 7400, 7550, 7700, 7850, 8000, 8150, 8300, 8450, 8600, 8750, 8900, 
9050, 9200, 9350, 9500, 9625, 9750, 9875, 10000, 10125, 10250, 10375, 10500 

dz[cm]: 19*0, -35, -70, -140, -210, -310, -410, -535, -660, -770, -880, -1005, -1130, -1190, -
1250, -1295, -1340, -1370, -1400, -1430, -1460, -1490, -1520, -1550, -1580, -1610, -
1640, -1670, -1700, -1730, -1760, -1785, -1810, -1830, -1850, -1865, -1880 

z[cm]: 2400, 2350, 2300, 2200, 2100, 2000, 1900, 1800, 1650, 1500, 1250, 1000, 750, 500, 
250, 0 

 
Button "OK"  
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Click on the FE-Mesh Tab under the View Window.  
Zoom on the right side of the transport domain 
From the Tool Bar select the command Select by Rhomboid ( )  
(or Edit->Select->Select by Rhomboid) 
Select the 6 elements vertically from the top and 4 element horizontally from the right. 
On the Navigator Bar click on Remove Selected Elements ( ) to 
get the domain as shown below. 
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Material Distribution 
Click on the Domain Properties Tab under the View Window.  
On the Navigator Bar click on Domain Properties – Material Distribution (or Insert-
>Domain Properties->Material Distribution). 
On the Edit Bar select Material 2 (Mill Tailing) and assign it as shown below 

 
 
Nodal Recharge 

On the Navigator Bar click on Domain Properties – Nodal Recharge (or Insert->Domain 
Properties->Nodal Recharge). 
Double Click on the node with coordinates x=4,000 cm and z=1,000 cm. 
In the Edit Nodal Recharge window set Value to -271.58 cm2/d. 

 
Subregions 

On the Navigator Bar click on Domain Properties – Subregions (or Insert->Domain 
Properties->Subregions). 
Click on Set Subregions = Materials (Edit bar)  
On the Edit Bar select Subregion 2 (Mill Tailing) and assign it in the same part of the 
domain as Material 2. 

 
Observation Nodes  

On the Navigator Bar click on Domain Properties – Observation Nodes (or Insert-
>Domain Properties->Observation Nodes). 
Click on the Insert Observation Node ( ) command on the Edit Bar 
and insert observation nodes at similar locations as shown below. 

  
 
Initial Conditions 

Click on the Initial Conditions under the View Window. 
On the Navigator Bar click on Pressure Head.  
Select the entire transport domain 
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From the Edit Bar select the command Set Pressure Head IC ( ) (or 
Insert->Initial Condition->Pressure Head/Water Content) 
In the Water Flow Initial Condition window : 
 Check Equilibrium from the lowest located nodal point 
 Check Slope in X-direction 
 Set the slope to -4.4o 
 Set Bottom Pressure Head Value to 1,200 cm 

 
 

 
 

On the Navigator Bar click on Solution Composition.  
Assigned the Solution Compositions as follows 

 
Boundary Conditions 

Click on the Boundary Conditions under the View Window.  
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On the Navigator Bar click on Water Flow. 
Assign BC as follows:  

 
 

On the Navigator Bar click on Solute Transport. 
Assign Third-Type BC with the following pointers as shown below:  
 

 
 
Run Calculations 

Click the Calculate Current Project command ( ) on the Toolbar (or Calculation-
>Calculate Current Project)  
(Execution time on 3 GHz PC – 468 s) 

 
4.5.3. Output 

 
The steady-state pressure heads and velocity fields are depicted in Figure 26. Uranium 
concentration profiles are shown in Figure 27. pH , calcite, and gypsum profiles are shown in 
Figure 28. 
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Figure 26. The steady-state pressure head (cm) (top) and flux (cm/d) (bottom) profiles for the 
Tailing Pile Leaching example. 

 

 

 

 
 

Figure 27. Uranium concentration profiles at time 0 (top), 250 (middle), and 500 (bottom) d for 
Tailing Pile Leaching example. 
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Figure 28. pH (top), calcite (mol/L) (middle), and gypsum (mol/L) (bottom) profiles after 1000 d 
for the Tailing Pile Leaching example. 
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